You are on page 1of 139

Architecture des

rseaux

Revue des principes de fonctionnement des rseaux


Introduction larchitecture des rseaux
Laccs rseau
Technologie Lan: Ethernet

Protocoles Wan: PPP


Protocoles Wan: Frame Relay
Protocoles Wan: ATM

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

Chapitre 1 :
Introduction larchitecture des rseaux

Objectifs
1.1 Les rseaux locaux, les rseaux tendus et Internet
1.2 Le rseau en tant que plate-forme
1.3 volution de l'environnement rseau

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

Les rseaux que nous avons connus et


ceux de notre vie quotidienne

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

Fourniture de ressources dans un rseau

Clients et serveurs

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

Fourniture de ressources dans un rseau

Peer-to-Peer (P2P)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

Composants d'un rseau

Les priphriques finaux


Voici quelques exemples de priphriques finaux :
Ordinateurs (stations de travail, ordinateurs portables,

serveurs de fichiers, serveurs Web)


Imprimantes rseau
Tlphones VoIP
Terminal TelePresence
Camras de surveillance
Appareils portatifs (smartphones, tablettes, PDA, lecteurs

de carte sans fil et lecteurs de codes barres)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

Composants d'un rseau

quipements de l'infrastructure rseau


Parmi ces priphriques rseau intermdiaires, citons :
Les priphriques d'accs rseau (commutateurs et points

d'accs sans fil)


Les priphriques interrseau (routeurs)
Les dispositifs de scurit (pare-feu)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

Composants d'un rseau

Schmas de topologie

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

10

Les rseaux locaux et les rseaux tendus

Types de rseau
Les deux types d'infrastructures rseau les plus rpandus sont :
Le rseau local (LAN)
Le rseau tendu (WAN)

Autres types de rseau :


Le rseau mtropolitain (MAN)
Le rseau local sans fil (WLAN)
Le rseau de stockage (SAN)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

11

Les rseaux locaux, les rseaux tendus et Internet

Internet

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

12

Internet

Intranet et Extranet

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

13

Les rseaux locaux, les rseaux tendus et Internet

Technologies d'accs Internet

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

14

Connexion Internet

Connexion des utilisateurs distants Internet

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

15

Connexion Internet

Connexion des entreprises Internet

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

16

Rseau fiable

Architecture prenant en charge le rseau


Alors que les rseaux voluent, nous dcouvrons que les
architectures sous-jacentes doivent prendre en considration
quatre caractristiques de base si elles veulent rpondre aux
attentes des utilisateurs :
Tolrance aux pannes
volutivit
Qualit de service (QS)
Scurit

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

17

Tendances relatives aux rseaux

Cloud computing
Il existe quatre types principaux de cloud :
Clouds publics
Clouds privs
Clouds personnaliss
Clouds hybrides

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

18

Tendances relatives aux rseaux

Service des Cloud computing


Il existe 3 services rendu par le cloud :
IAAS (Infrastructure As Service)
PAAS (Plateform As Service)
SAAS (Software As Service)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

19

Tendances relatives aux rseaux

Data centers
Un data center hberge des systmes informatiques et les
composants associs :
Connexions de communication de donnes redondantes
Serveurs virtuels haut dbit (parfois appels batteries de serveurs ou

clusters de serveurs)
Systmes de stockage redondants (gnralement, technologie SAN)
Alimentations redondantes ou de secours
Systmes de contrle de l'environnement (par exemple, climatisation,

systme d'extinction des incendies)


Dispositifs de scurit

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

20

L'avenir des rseaux

Scurit du rseau

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

21

Scurit du rseau

Menaces pour la scurit


Les menaces externes les plus courantes pour les rseaux
sont les suivantes :
Virus, vers et chevaux de Troie
Logiciels espions et logiciels publicitaires
Attaques zero-day (galement appeles attaques zero-hour)
Piratage informatique
Attaques par dni de service
Interception et vol de donnes
Usurpation d'identit

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

22

Scurit du rseau

Solutions de scurit
La scurit du rseau repose souvent sur les lments
suivants :
Antivirus et logiciel anti-espion
Filtrage au niveau du pare-feu
Systmes de pare-feu ddis
Listes de contrle d'accs (ACL)
Systmes de protection contre les intrusions
VPN

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

23

Chapitre 2 :
L'accs rseau
Architecture des rseaux

Objectifs
Les protocoles de couche liaison de donnes
Le contrle d'accs au support

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

25

Principes fondamentaux de la couche 1

Bande passante

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

26

Principes fondamentaux de la couche 1

Dbit

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

27

Rle de la couche liaison de donnes

Couche liaison de donnes

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

28

Rle de la couche liaison de donnes

Sous-couches liaison de donnes

Rseau

Sous-couche LLC
Liaison de
donnes
802.15
802.15
Bluetooth
Bluetooth

802.11
802.11
WiFi
WiFi

802.3
802.3
Ethernet
Ethernet

Sous-couche MAC

Physique

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

29

Rle de la couche liaison de donnes

Le contrle d'accs au support

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

30

Couche liaison de donnes

Structure de trame de la couche 2

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

31

Structure de trame de la couche 2

Cration d'une trame

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

32

Couche liaison de donnes

Normes de couche 2

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

33

Topologies

Contrle d'accs au support de transmission

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

34

Topologies de rseau tendu (WAN)

Topologies WAN physiques courantes

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

35

Topologies de rseau tendu (WAN)

Topologie PPP physique

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

36

Topologies de rseau tendu (WAN)

Topologie PPP logique

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

37

Topologies de rseau local (LAN)

Topologie logique pour des supports de


transmission mixtes

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

38

Trame liaison de donnes

Trames LAN et WAN

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

39

Trame liaison de donnes

Trame Ethernet

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

40

Trame liaison de donnes

Trame du protocole PPP (Point-to-Point)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

41

Chapitre 3:
Technologie Lan Ethernet

Le fonctionnement d'Ethernet

Les sous-couches LLC et MAC


Ethernet

La technologie LAN la plus rpandue

Fonctionne au niveau de la couche liaison de donnes et de la


couche physique

Famille de technologies rseau dfinies par les normes IEEE 802.2


et 802.3

Prend en charge des bandes passantes de donnes de 10, 100,


1 000, 10 000, 40 000 et 100 000 Mbit/s (100 Gbit/s)

Normes Ethernet

Dfinissent les protocoles de couche 2 et les technologies de


couche 1

Deux sous-couches distinctes de la couche liaison de donnes pour


fonctionner : LLC (Logical Link Control) et MAC

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

43

Le fonctionnement d'Ethernet

Les sous-couches LLC et MAC

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

44

Le fonctionnement d'Ethernet

Le contrle d'accs au support

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

45

Le fonctionnement d'Ethernet

Adresse MAC : identit Ethernet

Une adresse MAC Ethernet de couche 2 est une valeur binaire de 48 bits
constitue de 12 chiffres hexadcimaux
L'IEEE demande aux revendeurs de suivre deux rgles simples :

L'adresse doit utiliser dans ses 3 premiers octets l'identifiant unique (OUI)
attribu au revendeur

Toutes les adresses MAC ayant le mme identifiant OUI doivent utiliser
une valeur unique dans les 3 derniers octets

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

46

Les attributs de la trame Ethernet

Encapsulation Ethernet

Les versions prcdentes d'Ethernet taient relativement lentes, de l'ordre de


10 Mbit/s
Les rseaux Ethernet offrent dsormais au moins 10 gigabits par seconde
Dans une trame Ethernet, un en-tte et un code de fin sont ajouts autour de
l'unit de donnes de protocole de couche 3 pour encapsuler le message
envoy

Ethernet II est le
format de trame
Ethernet utilis par
les rseaux
TCP/IP.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

47

Les attributs de la trame Ethernet

La taille de la trame Ethernet


La figure montre les champs contenus dans la balise VLAN 802.1Q

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

48

Le protocole ARP
(Address Resolution Protocol)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

49

Le protocole ARP

Initiation au protocole ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

50

Le protocole ARP

Fonctions et fonctionnement du protocole


ARP
Table ARP
Sert trouver l'adresse de la couche liaison de donnes qui est mappe
l'adresse IPv4 de destination
Quand un nud reoit des trames en provenance du support, il enregistre les
adresses MAC et IP source dans la table ARP sous forme de mappages

Requte ARP
Diffusion de couche 2 vers tous les priphriques du LAN Ethernet
Le nud qui correspond l'adresse IP de la diffusion rpond
Si aucun priphrique ne rpond la requte ARP, le paquet est abandonn
du fait qu'il est impossible de crer une trame

Des entres de mappage statiques peuvent galement tre ajoutes


dans la table ARP, ce qui est rare.
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

51

Le protocole ARP

Fonctions et fonctionnement du
protocole ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

52

Le protocole ARP

Fonctions et fonctionnement du
protocole ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

53

Le protocole ARP

Fonctions et fonctionnement du
protocole ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

54

Le protocole ARP

Fonctions et fonctionnement du
protocole ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

55

Le protocole ARP

Fonctions et fonctionnement du
protocole ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

56

Le protocole ARP

Fonctions et fonctionnement du
protocole ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

57

Le protocole ARP

Suppression des entres d'une table ARP


Le minuteur du cache ARP supprime les entres qui n'ont pas t utilises
pendant un certain temps
Des commandes permettent aussi de supprimer manuellement la totalit
ou une partie des entres de la table ARP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

58

Le protocole ARP

Tables ARP sur les priphriques rseau

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

59

5.3

Les commutateurs LAN

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

60

La commutation

Table d'adresses MAC du commutateur

1. Le commutateur reoit une trame de diffusion du PC 1 sur le


port 1.
2. Le commutateur ajoute l'adresse MAC source et le port de
commutateur ayant reu la trame dans la table d'adresses.
3. L'adresse de destination tant une diffusion, le commutateur
envoie la trame sur tous les ports, sauf celui sur lequel il l'a
reue.
4. Le priphrique de destination ragit la diffusion en envoyant
une trame de monodiffusion au PC 1.
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

61

La commutation

Table d'adresses MAC du commutateur

5. Le commutateur enregistre l'adresse MAC source du PC 2


et le numro de port du commutateur ayant reu la trame
dans la table d'adresses. L'adresse de destination de la
trame et le port qui lui est associ se trouvent dans la table
d'adresses MAC.
6. Le commutateur peut alors transmettre les trames entre les
priphriques source et de destination sans les diffuser
partout, puisqu'il dispose des entres qui identifient les ports
associs dans la table d'adresses .
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

62

La commutation

Auto-MDIX

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

63

La commutation

Mthodes de transmission de trames sur les


commutateurs Cisco

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

64

La commutation

Commutation cut-through

Deux variantes :
Commutation Fast-Forward :
Avec le temps de latence le
plus faible, transmet un paquet
immdiatement aprs la lecture
de l'adresse de
destination commutation cutthrough classique
Commutation Fragment-free :
Le commutateur stocke les
64 premiers octets de la trame
avant la transmission, la
plupart des erreurs rseau et
des collisions se produisant
dans ces 64 premiers octets

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

65

La commutation

Mise en mmoire tampon sur les


commutateurs

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

66

La commutation de couche 3

Commutation de couche 2 et commutation


de couche 3

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

67

La commutation de couche 3

Types d'interface de couche 3


Les principaux types d'interface de couche 3 sont les suivants :
Interface virtuelle de commutateur (SVI) : sur un

commutateur, interface logique associe un rseau local


virtuel (VLAN).
Port rout : sur un commutateur de couche 3, port physique

configur pour faire office de port de routeur. Pour configurer


ces ports, mettez l'interface en mode couche 3 avec la
commande de configuration no switchport.
EtherChannel sur la couche 3 : interface logique d'un

priphrique Cisco associ un ensemble de ports routs.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

68

La commutation de couche 3

Configuration d'un port rout sur un commutateur


de couche 3

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

69

Chapitre 2:
Conception dune architecture de Campus
CCNP SWITCH:
Implementing IP
Switching

Objectives
Dcrire les options de conception du campus et comment les

choix de conception affectent la mise en uvre et le soutien d'un


campus LAN.
Dcrire les couches accs, de distribution et de base.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

71

Introduction la
conception de
rseau Campus
d Enterprise

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

72

Rseaux denterprise
Core (Backbone)
Campus
Data Center
Branch
WAN
Internet Edge

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

73

Conception de campus
Modulaire - soutient facilement la croissance et le changement.

Facilit de mise niveau du rseau par l'ajout de nouveaux


modules au lieu de refontes compltes.
Rsilients - haute disponibilit (HA) bonne caractristiques se

traduisent par prs de 100% de disponibilit.


Flexible changement dans lactivit est une garantie pour toute

entreprise. Ces changements conduisent les exigences du


rseau de campus s'adapter rapidement.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

74

Multilayer Switches in Campus Networks


Prise en charge des protocoles

RIP, OSPF, EIGRP


Vitesse de commutation de

couche 3 se rapproche de celle


des commutateurs de niveau 2
Commutation de couche 4 et

couche 7 supporte sur certains


commutateurs

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

75

Cisco Switches
Catalyst 6500 Family used in campus, data center, and core as

well as WAN and branch


Up to 13 slots and 16 10-Gigabit Ethernet interfaces
Redundant power supplies, fans, and supervisor engines
Runs Cisco IOS

Catalyst 4500 Family used in distribution layer and in collapsed

core environments
Up to 10 slots and several 10-Gigabit Ethernet interfaces
Runs Cisco IOS

Catalyst 3560 and 3750 Families used in fixed-port scenarios at

the access and distribution layers


Nexus 2000, 5000, and 7000 Families NX-OS based modular

data center switches


2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

76

Types de trafiques
Network Management BPDU, CDP, SNMP, RMON, SSH traffic

(for example); low bandwidth


IP Telephony Signaling traffic and encapsulated voice traffic;

low bandwidth
IP Multicast IP/TV and market data applications; intensive

configuration requirements; very high bandwidth


Normal Data File and print services, email, Internet browsing,

database access, shared network applications; low to medium


bandwidth

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

77

Client-Server Applications
Mail servers
File servers
Database servers
Access to applications is

fast, reliable, and secure

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

78

Client-Enterprise Edge Applications


Serveurs sur la priphrie

de l'entreprise, change
de donnes entre une
organisation et ses
serveurs publics
Exemples: des serveurs

de messagerie externes,
des serveurs e-commerce,
et les serveurs Web
publics
La scurit et la haute

disponibilit sont
primordiales
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

79

Conception de couche dAccs, de couche de Distribution, et de


couche Coeur
Conception de couche Cur:

haute vitesse, conu pour


commuter des paquets aussi vite
que possible; fournit une haute
disponibilit et sadapte
rapidement aux changements.
Conception de couche de

distribution: Agrgation des


liens, utilise des commutateurs
pour segmenter les groupes de
travail et isoler les problmes
rseau.
Construire couche d'accs:

accorder l'accs utilisateur aux


priphriques rseau.
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

80

Core Layer
Regroupe des commutateurs de couche de distribution.
Met en uvre des protocoles volutives et des

technologies dquilibrage de charge.


Commutation de couche 3 haut dbit en utilisant 10-

Gigabit Ethernet.
Utilise des liens de L3 redondants.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

81

Distribution Layer
Haute disponibilit, rcupration rapide de chemin, quilibrage de

charge, qualit de service et la scurit


Rsum de route et manipulation de paquets
Point de redistribution entre domaines de routage
filtrage de paquets et mise en uvre de routage bas sur la politique
Protocole de redondance de Premier saut

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

82

Access Layer
Haute disponibilit - soutenue par de nombreuses fonctionnalits

matrielles et logicielles, telles que des alimentations redondantes et


les protocoles de redondance de premiers saut.
Convergence - fournit une alimentation en ligne par Ethernet (PoE)
pour supporter les tlphones IP et les points d'accs sans fil.
Scurit - comprend la scurit des ports, DHCP snooping, Dynamic
ARP Inspection, garde source IP.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

83

Le Protocole PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

84

Point to Point Protocol


PPP comprend trois

composants principaux :
Le protocole HDLC pour
lencapsulation de datagrammes
sur des liaisons point point.
Le protocole de contrle de
liaison extensible (LCP, Link
Control Protocol) pour tablir,
configurer et tester la connexion
des liaisons de donnes.
Une famille de protocoles de
contrle rseau (NCP, Network
Control Protocol) pour tablir et
configurer diffrents protocoles de
couche rseau. PPP permet
lutilisation simultane de
plusieurs protocoles de couche
rseau.
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

85

Rle de LCP et NCP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

86

Rle de LCP et NCP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

87

Rle de LCP et NCP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

88

Encapsulation PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

89

Encapsulation PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

90

Encapsulation PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

91

Encapsulation PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

92

Encapsulation PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

93

tablissement de session PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

94

Fonctionnalits avancs PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

95

Fonctionnalits avancs PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

96

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

97

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

98

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

99

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

100

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

101

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

102

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

103

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

104

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

105

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

106

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

107

Authentification PPP

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

108

Frame Relay

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

109

Introduction Frame Relay


Frame Relay est devenu le protocole de rseau tendu le plus

utilis au monde.
Son succs est essentiellement d son prix abordable et sa

flexibilit.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

110

Introduction Frame Relay

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

111

Les circuits virtuels


Le terme circuit virtuel dsigne la connexion entre deux ETTD par

un rseau Frame Relay.

Les circuits virtuels peuvent stablir de deux manires :


les circuits virtuels commuts (SVC) sont tablis de faon dynamique par
lenvoi de messages de signalisation au rseau
les circuits virtuels permanents (PVC) sont prconfigurs par loprateur
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

112

DLCI

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

113

DLCI

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

114

Topologies frame Relay

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

115

Topologies frame Relay

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

116

Configuration Frame Relay

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

117

ATM

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

118

Introduction ATM
ATM est n de lide de pouvoir transfrer diffrent types de

flux sur le mme rseaux de cble (voix, vido, donnes


scurises)
Dans le modle OSI, ATM pourrait tre plac au niveau 2

(Layer).
En ralit, ATM ne respecte pas tout fait la dcomposition

en 7 couches dOSI.
La connexion bout-en-bout, le contrle de flux ainsi que le

routage sont fait au niveau Cellule.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

119

Couche ATM
Le modle ATM considre 3 niveaux :
la couche physique : utilisation standards dj dploys

des couches physiques tels que la fibre optique et la paire


torsade ;
la couche ATM : construction de la cellule ATM,

multiplexage/dmultiplexage et communication des cellules


la couche AAL (ATM Adaptation Layer) : adaptation du

flux de donnes la structure des cellules.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

120

ATM et QoS
Qualit de service ( QoS) : 4 disponibles de 4 QoS

Lusager stipule la QoS


Transmission dbit constant (ex: tlphone)
Transmission dbit variable (ex: vidoconfrence, transfert de
document multimdia)
Transmission dbit possible (ex: surf sur le Web)
Transmission dbit non spcifi (ex: transfert de fichier)
Architecture en 3 couches
Couche physique :Transmet le signal sur le support physique
Couche ATM : Achemine les cellules sur le rseau ATM
Couche AAL (ATM Adapation Layer) : En fonction du QoS, adapte
le flux dinformation la structure des cellules
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

121

Couche AAL ATM et QoS


Pour affiner la qualit de service offerte aux applications, la

couche AAL (ATM Adaptation Layer) a t rajoute pour


rpondre aux 4 diffrentes classes dapplications:

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

122

Circuits virtuels ATM


Entre deux interfaces rseau, une connexion appele circuit

virtuel, est identifie par un nombre cod sur 3 octets.


Ce nombre est le VCN (virtual circuit number).
Il se dcompose en deux parties :
VPI (virtual path identifier)
et le VCI (virtual channel identifier)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

123

Table de routage ATM

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

124

Chapitre 4:
Mise en uvre de VLAN dans les rseaux de campus

Implmentation de technologies de Vlan

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

126

Virtual Local Area Network (VLAN)

Un VLAN est un rseau logique.


Les diffusions sont limits au VLAN.
Un VLAN = 1 de sous-rseau IP.
Les liaisons Trunks connectent les commutateurs afin de transporter

plusieurs VLAN.
Les dispositifs de couche 3 interconnectent les Vlans.
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

127

Configuration: Dsactiver la Ngotiation Trunk sur un


Port
To disable trunk negotiation on a switch port.
Switch(config-if)# switchport mode access

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

128

Configuration: Macro pour port dAccs


Switch(config-if)# switchport host

Cette commande optimise un port de couche 2 pour une

connexion hte:
Active le mode accs
Active spanning-tree portfast
Dsactive EtherChannel.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

129

Configuration: Assign Port to VLAN


Pour assigner un port un Vlan
Switch(config-if)# switchport access vlan vlan-id
Switch(config)# Vlan 200
Switch(config)# name RH
Switch(config)# interface FastEthernet 5/6
Switch(config-if)# description PC A
Switch(config-if)# switchport host
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled
Switch(config-if)# switchport access vlan 200
Switch(config-if)# no shutdown
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

130

Commandes de dpannage
Show Vlan
Show Vlan brief
Show interface switchport

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

131

Implmentation de lagrgation

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

132

VLAN Trunking
Trunk achemine le trafic de plusieurs VLAN sur une liaison physique

unique (multiplexage).
Le Trunking est utilis pour tendre les oprations de la couche 2

travers l'ensemble du rseau.


L'hte de la gauche dans VLAN 2 peut communiquer avec l'hte sur le

droit du VLAN 2 via le lien de trunk;


sur la mme liaison trunk, les htes du VLAN 1peuvent communiquer

simultanment .

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

133

VLAN Trunking
ISL est un protocole de trunk Cisco-proprietaire .
ISL est devenu obsolete.
802.1Q est le protocole standard d'aggrgation.
IEEE 802.1Q a des enttes infrieurs ISL.
802.1Q a un champs 802.1p pour supporter la QoS.

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

134

Native VLAN with IEEE 802.1Q

La norme 802.1Q spcifie comment le commutateur doit grer les trames non

marques envoys ou reus sur un port trunk 802.1Q.


Un accs trunk 802.1Q est affect un PVID par dfaut, qui est associ

l'ensemble du trafic non marqu sur le port.


Tout le trafic avec un ID de VLAN nulle est suppos appartenir au PVID par

dfaut du port. Un paquet avec un ID de VLAN gale au PVID par dfaut de


port sortant est envoy sans tiquetage. Tout autre trafic est envoy avec
tiquettage de VLAN.
La configuration de diffrents vlans natif sur la topologie rseaux est recomand
2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

135

Dynamic Trunking Protocol (DTP)

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

136

Design with VLAN Trunks

Trunks interconnectent les commutateurs de couche accs.


Trunks connectent les commutateurs de couche accs ceux de couche distribution.
Les liens de couche 3 interconnectent les commutateurs de coueur ceux de distribution

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

137

Configuring an Interface for Trunking


Select the encapsulation type:
Switch(config-if)# switchport trunk encapsulation {isl | dot1q |
negotiate}

Configure the interface as a Layer 2 trunk:


Switch(config-if)# switchport mode {dynamic {auto | desirable} |
trunk}

Specify the native VLAN:


Switch(config-if)# switchport trunk native vlan vlan-id

Configure the allowable VLANs for this trunk:


Switch(config-if)# switchport trunk allowed vlan {add | except |
all | remove} vlan-id[,vlan-id[,vlan-id[,...]]]

Switch(config)# interface FastEthernet 5/8


Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport nonegotiate
optional
Switch(config-if)# switchport trunk allowed vlan 1-100
Switch(config-if)# no shutdown
Switch(config-if)# end

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

138

Verifying Trunk Configuration


Switch# show running-config interface f5/8
Building configuration...
Current configuration:
!
interface FastEthernet5/8
switchport mode dynamic desirable
switchport trunk encapsulation dot1q
end
Switch# show interfaces f5/8 switchport
Name: Fa5/8
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Enabled
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Switch# show interfaces f5/8 trunk
Port
Mode
Encapsulation Status
Fa5/8
desirable
n-802.1q trunking 1
Port
Fa5/8

Native vlan

Vlans allowed on trunk


1-1005

2013 Cisco et/ou ses filiales. Tous droits rservs.

Document public de Cisco

139