You are on page 1of 48

Cisco SPIAD

Hands On Technical Training

Lab Guide

Table of Contents

TASK 1:

LAB TOPOLOGY

TASK 2:

LAB OVERVIEW

TASK 3:

NETWORK SETUP

TASK 4:

CONFIGURING CCME AS KEY SYSTEM

TASK 5:

VOICEMAIL & AUTO ATTENDANT

TASK 6:

ADVANCED FEATURES

Disclaimer
This lab is primarily intended to be a learning tool. In order to convey specific information,
the lab may not necessarily follow best practice recommendation at all times. This exercise
is intended to demonstrate one way to configure the network, servers and applications to
meet specified requirements for the lab environment. There are various ways that this can
be accomplished, depending on the situation and the customers goals/requirements. Please
ensure that you consult all current official Cisco documentation before proceeding with a
production/lab design or installation. By enrolling in this class or having access to this
document you acknowledge you are aware of this disclaimer and its implications.

TASK 1: LAB TOPOLOGY

In the lab document, xx refers to your Pod number. For example, if you are seated at
POD01, you would replace all instances of xx in the lab documents with 01.
In order to get PSTN access a SIP trunk was set up for each POD, this is to emulate a PSTN
connection for the lab environment. Normally, you would plug trunks from the PSTN into the
FXO ports or T1/E1 port.
Hardware and software requirements:
Cisco SPIAD running CME 10.5
LAN Switch (2900, 300 or 500 series, Meraki MS)
Serial Console Cable
Cisco Phone 78xx, 79xx or any other supported model
Windows PC
Cisco IP Communicator Client
SSH client and terminal emulator (putty client)
TFTP server software
FTP Server software

WAN IP addressing, Interface GigabitEthernet 0/0:


WAN IP Address
WAN Subnet Mask
WAN Default Router

DHCP
DHCP
DHCP

LAN IP addressing Interface GigabitEthernet 0/1:


LAN_DATA IP Address
LAN_DATA Subnet Mask
VLAN_DATA

192.168.10.1
255.255.255.0
VLAN 1

LAN_VOICE IP Address
LAN_VOICE Subnet Mask
VLAN_VOICE

10.1.1.1
255.255.255.0
VLAN 100

ISM Module0/0 IP addressing:


ISM IP Address
ISM Subnet Mask
ISM Default Router

10.1.10.1
255.255.255.252
10.1.10.2

Inbound SIP Trunk DID (PSTN Call in) Numbers (Use PSTN phone to test)
Auto attendant (200)
Extension 1 (201) Jim Smith
Extension 2 (202) Sara Noa
Extension 2 (203) Emma Smith
VoiceMail (399)

4085xx1200
4085xx1201
4085xx1202
4085xx1203
4085xx1209

Outbound Numbers to Call (From IP Phones on SPIAD to PSTN Phone)


Emergency Number
Local Call
Long Distance
International

9060
952671800
9018182212462
90014085256800

SPIAD user name and password


Username
Password

spiad
spiad

Cisco Unity Express user name and password


Username
Password

spiad
spiad

Cisco Communications Manager Express GUI user name and password


Username
Password

admin
spiad

TASK 2: LAB OVERVIEW


Lab Objective:
To gain experience configuring the Cisco SPIAD solution, configuring call processing, Key
System, PBX, Voicemail, Auto Attendant, hunt groups, and additional features of the Cisco
Communications Manager Express

Audience and Prerequisites


This document is intended to assist solution architects, sales engineers, field engineers, and
consultants in learning many of the features of Cisco Communications Manager Express 10
running on a bundled system (CISCO SPIAD). This document assumes the reader has an
architectural and administrative understanding of the CCME and has reviewed the latest
administration guide.
Basic knowledge of how to install and administer CCME and CUE is recommended however
not necessary.
All configurations are based on Command Line Interface (CLI) so is highly recommendable
that you were familiar with the IOS commands.
Please refer to the following links to get further information about operation of Cisco
Communications Manager Express and Cisco Unity Express:
Cisco CME main page:
http://www.cisco.com/go/ccme
Cisco CME Install Guides:
http://www.cisco.com/c/en/us/support/unified-communications/unified-communicationsmanager-express/products-installation-guides-list.html
Cisco Unity Express:
http://www.cisco.com/go/cue
Cisco Unity Express Maintain and Operate Guides:
http://www.cisco.com/c/en/us/support/unified-communications/unity-express/productsmaintenance-guides-list.html
Cisco IOS compatibility matrix
http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/requirements/guide/33matri
x.html

TASK 3: NETWORK SETUP


In order to get access to the SPIAD system a previous configuration for voice and data
VLAN was loaded, as well as DHCP pool for phones and users.

config terminal
hostname CISCO_SPIAD
ip dns server
username spiad privilege 15 secret spiad
ntp server 24.56.178.140
interface Vlan1
description DATA_VLAN
no ip address
interface Vlan100
description VOICE_VLAN
no ip address
interface GigabitEthernet 0/1
no ip address
no shutdown
interface GigabitEthernet0/1.1
description DATA_INTERFACE
encapsulation dot1Q 1 native
ip address 192.168.10.1 255.255.255.0
interface GigabitEthernet0/1.100
description VOICE_INTERFACE
encapsulation dot1Q 100
ip address 10.1.1.1 255.255.255.0

interface GigabitEthernet0/0
description WAN_INTERFACE
ip address dhcp

ip dhcp excluded-address 192.168.10.1 192.168.10.10


ip dhcp excluded-address 10.1.1.1 10.1.1.10
ip dhcp pool data
import all
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 192.168.10.1
option 150 ip 10.1.1.1
ip dhcp pool phone
import all
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
option 150 ip 10.1.1.1
Assuming that LAN switch has been configured and both VLANs (voice and data) were assigned on
designated ports, plug the interface Gigabit Ethernet 0/1 to the uplink switch trunk port.
Check that your PC is connected to one of the switch ports and validate DHCP assignment
C:\> ipconfig

Test connectivity to the default gateway assigned by SPIAD.


C:\> ping 192.168.10.1

ISM Module Configuration


On Cisco SPIAD Cisco Unity Express is loaded from factor in ISM 0/0, Voice Mail and Auto
attendant Ports licenses are loaded also, so in order to get access to CUE IP addressing;
configuration is needed, this section describes the configuration procedure.
Open SSH putty client and create a new session, use the IP address 192.168.10.1 click open
and accept the security alert.

When login prompt appears, type spiad for user and spiad for password.

Load the following configuration that is needed to get Internal Service Module reachable:

config terminal
! Create a loopback interface
interface Loopback0
ip address 10.1.10.2 255.255.255.252
ip virtual-reassembly in
! according to the lab topology assign the ip address 10.1.10.1/30 and default
gateway 10.1.10.2
interface ISM0/0
ip unnumbered Loopback0
ip nat inside
ip virtual-reassembly in
service-module ip address 10.1.10.1 255.255.255.252
!Application: CUE Running on ISM
service-module ip default-gateway 10.1.10.2
no shutdown
! add an static route in order to reach CUE via ISM0/0
ip route 10.1.10.1 255.255.255.255 ISM0/0

Validate that you can reach ISM IP address and its default gateway from the router pinging
both IP addresses 10.1.10.1 and 10.1.10.2

Do the same tests, now form your PC.

Cisco Unity Express will be configured later in this lab at this point you have done with ISM
configuration.

Internet Connection
PSTN access will be provided via SIP trunk in this case internet connection is needed, this
section will provide a basic configuration to gain internet access for voice, data VLAN and
ISM deploying NAT.

config terminal
! Define NAT inside interfaces
interface GigabitEthernet0/1.1
ip nat inside
interface GigabitEthernet0/1.100
ip nat inside
interface ISM0/0
ip nat inside
! Define NAT outside interfaces
interface GigabitEthernet0/0
ip nat outside
! Create an access list to allow Internet access to the following source subnets
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 1 permit 10.1.1.0 0.0.0.255
access-list 1 permit 10.1.10.0 0.0.0.3
! Packets received on inside interfaces and permitted on access list 1 will be
translated to the IP address assigned to interface Gigabit Ethernet 0/0
ip nat inside source list 1 interface GigabitEthernet0/0 overload
end
Dont forget to save your configuration copying running configuration to startup
configuration.

Validate that you can get internet access, open your browser and go to:
http://www.cisco.com.

Internet connection is done.

TASK 4: CONFIGURING CCME AS IPPBX SYSTEM


In this section CCME will be configured as key system, we will see a couple of examples
when CCME is enabled to register Cisco Proprietary Skinny Client Control Protocol (SCCP)
phones and Session Initiation Protocol (SIP) phones.
The simplest model is the PBX model, in which most of the IP phones in your system have a
single unique extension number. Incoming PSTN calls are routed to a receptionist at an
attendant console or to an automated attendant. Phone users may be in separate offices or
be geographically separated and therefore often use the telephone to contact each other.
For this model, is recommended that you configure directory numbers as dual-lines so that
each button that appears on an IP phone can handle two concurrent calls. Dual-line
directory numbers enable your configuration to support call waiting, call transfer with
consultation, and three-party conferencing.
This section contains a list of the types of files that must be downloaded and installed in the
router flash memory to use with Cisco Unified CME. The files listed in this section are
included in zipped or tar archives that are downloaded from the Cisco Unified CME software
download website at:
https://software.cisco.com/download/type.html?mdfid=277641082
To get software a valid CCO ID is needed with and partner level privileges for such section.
Now lets continue with the

Configure the Cisco Unified Communications Manager Express Parameters


The following configuration besides to start the telephony service will allow SCCP phones
registration.

configure terminal
! Enter the command telephonyservice in order to enter telephone configuration mode.

telephonyservice
! Enter the command maxephones maxnumphones in order to set the maximum
number of IP phones to be supported by this platform.

max-ephones 30
! Enter the command maxdn maxdirectorynumbers in order to set the maximum
number of extensions that can exist in this platform.

max-dn 200

! For security reasons enter the command no autoregephone in order to prevent the
connection of any phone to the system.

no auto-reg-ephone
! Enter the command load phonetype firmwarefile in order to identify the firmware
file that the IP phone uses to register in the system.

load 7975 SCCP75.9-2-1S


! Set time zone for Mexico Standard/Daylight, display time format as 24 hours and set
date format as dd-mm-yy

time-zone 9
time-format 24
date-format dd-mm-yy
! Assign the voice mail extension 399 according to the Lab Topology

voicemail 399
! Define the call forward and call park behavior

call-park system application


call-forward pattern .T
call-forward system redirecting-expanded
! Define the call transfer behavior allowing transfer to any number and call transfer
method

transfer-system full-consult dss


transfer-pattern 9.T
transfer-pattern .T
! Create another tone when you dial 9 to place an outside call.

secondary-dialtone 9
! Enter the command ip sourceaddress ipaddress in order to identify the IP address
and port number that the Cisco CallManager Express router uses for IP phone registration.
The default port is 2000.

ip source-address 10.1.1.1
! Set the interdigit timeout

timeouts interdigit 5

! Enter the command create cnffiles in order to build the XML configuration files.

create cnf-files
end
This is a generic phone template that will be used by SCCP phones load it.

configure terminal
ephone-template 16
url services 1 http://10.1.10.1/voiceview/common/login.do VoiceviewExpress
softkeys remote-in-use Newcall
softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
softkeys connected Hold Endcall Trnsfer TrnsfVM Confrn ConfList RmLstC Acct
Park Select Join
Dont forget to save your configuration copying running configuration to startup
configuration.

Configure the Cisco Unified Communications Manager Express to allow SIP


phones registration.
To enter voice register global configuration mode in order to set global parameters for all
supported Cisco SIP IP phones in a Cisco Unified CME or Cisco Unified Session Initiation
Protocol (SIP) Survivable Remote Site Telephony (SRST) environment, use the voice
register global command in global configuration mode. To automatically remove the existing
DNs, pools, and global dialplan patterns, use the no form of this command.

config terminal
voice register global
! Enables mode for provisioning SIP phones in Cisco Unified CME

mode cme
! Enter the command sourceaddress ipaddress in order to identify the IP address and
port number that the Cisco CallManager Express router uses for IP phone registration.

source-address 10.1.1.1 port 5060


! SIP Outbound Proxy wont be needed for SIP phones

no outbound-proxy
! Enter the command maxpool maxnumphones in order to set the maximum
number of IP phones to be supported by this platform.

max-pool 30
! Enter the command maxdn maxdirectorynumbers in order to set the maximum
number of extensions that can exist in this platform.

max-dn 200
! Enter the command load phonetype firmwarefile in order to identify the firmware
file that the IP phone uses to register in the system.

load 7841 sip78xx.10-2-1-12


! Registration requests from SIP phones in a Cisco Unified CME system must be
authenticated

authenticate register

! Assign the voice mail extension 399 to the message button according to the Lab
Topology

voicemail 399
! Set a repeating audible alert notification when a call is on hold on all supported SIP
phones directly connected in Cisco Unified CME

hold-alert
! Specify the directory to which the configuring files for SIP phones in Cisco Unified CME
are written

tftp-path flash:
! Set time zone for Mexico Standard/Daylight, display time format as 24 hours and set
date format as dd-mm-yy

timezone 9
time-format 24
date-format D/M/Y
! Enter the command create profile in order to build the XML configuration files.

create profile
exit

Configure voice service voip

! Create a SIP profile in order to normalize SIP signaling

voice class sip-profiles 1000


request ANY sdp-header Connection-Info remove
response ANY sdp-header Connection-Info remove
! Start voice service voip

voice service voip


! allow only trusted hosts or network

ip address trusted list


ipv4 10.1.1.0 255.255.255.0
ipv4 192.168.10.0 255.255.255.0
ipv4 10.1.10.0 255.255.255.252

! Allow interworking or leg to leg communication

allow-connections
allow-connections
allow-connections
allow-connections

h323 to h323
h323 to sip
sip to h323
sip to sip

! Disable SIP redirect response for call forwarding, Disable SIP REFER message for call
transfers and enable call-by-call detection of H.450 capabilities

supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
! FAX relay configuration

fax protocol none


no fax-relay sg3-to-g3
sip
! enable SIP registrar functionality

registrar server expires max 3600 min 120


no update-callerid
sip-profiles 1000
copy running-config startup-config

CCME is now ready to receive SCCP or SIP phones registration, but phone loads needs to be
uploaded into the flash directory and define the TFTP alias for such loads, the ones needed
for this lab are for Cisco Phones 7842 (SIP) and 7975 (SCCP).

Start TFTP server and set the root path as follows:

Phone loads compressed files for


Cisco Phones are:
7841 (SIP)
cmterm-78xx.10-2-1-12_REL.tar
7975 (SCCP)
cmterm-7975-sccp.9-2-1.tar

Open a SSH session to the SPIAD system if you are not logged in. And follow the next
procedure to upload and uncompress phones firmware files.
Create a directory to save the files
mkdir flash:phones
now create a directory for each model
mkdir flash:phones/7800
mkdir flash:phones/7975
validate that your directories were created
dir flash:phones

Proceed to download and extract files from TFTP server


archive tar /xtract tftp://192.168.10.11/cmterm-78xx.10-2-1-12_REL
archive tar /xtract tftp://192.168.10.11/cmterm-7975-sccp.9-2-1.tar flash:/phones/7975

Once all the files were extracted check that files are on the directories that were created
previously.

Now create the TFTP alias for each file that was uploaded in order to make the file reachable
when phone request it.

configure terminal
ip tftp source-interface Loopback0
tftp-server
tftp-server
tftp-server
tftp-server

flash:/phones/7800/kern78xx.10-2-1-12.sbn alias kern78xx.10-2-1-12.sbn


flash:/phones/7800/rootfs78xx.10-2-1-12.sbn alias rootfs78xx.10-2-1-12.sbn
flash:/phones/7800/sboot78xx.10-2-1-12.sbn alias sboot78xx.10-2-1-12.sbn
flash:/phones/7800/sip78xx.10-2-1-12.loads alias sip78xx.10-2-1-12.loads

tftp-server
tftp-server
tftp-server
tftp-server
tftp-server
tftp-server
tftp-server

flash:/phones/7975/apps75.9-2-1TH1-13.sbn alias apps75.9-2-1TH1-13.sbn


flash:/phones/7975/cnu75.9-2-1TH1-13.sbn alias cnu75.9-2-1TH1-13.sbn
flash:/phones/7975/cvm75sccp.9-2-1TH1-13.sbn alias cvm75sccp.9-2-1TH1-13.sbn
flash:/phones/7975/dsp75.9-2-1TH1-13.sbn alias dsp75.9-2-1TH1-13.sbn
flash:/phones/7975/jar75sccp.9-2-1TH1-13.sbn alias jar75sccp.9-2-1TH1-13.sbn
flash:/phones/7975/SCCP75.9-2-1S.loads alias SCCP75.9-2-1S.loads
flash:/phones/7975/term75.default.loads alias term75.default.loads

end
copy running-config startup-config

Phone firmware is now loaded and ready to upgrade phones if it is necessary.


In case you have a phone on a pre-8.3.2 firmware and can't do a direct upgrade to 9.2.1.
You should load an interim firmware for instance 8.4.4 on your flash and upgrade it to that
load first. Then upgrade to 9.1.2.

Cisco Unified Communications Manager Express Phone Provisioning


In order to start to make and receive calls, you need to register the specific IP phones that
you want on the CCME system. In this process you set up individual ephonedns or
register-dns and then associate each with a button or buttons on one or more ephones.
Each ephonedn or register-dn is a virtual line, or extension, on which call connections can
be made. Each physical phone must be configured as an ephone or register pool in the Cisco
CME router in order to receive support in the LAN environment. With the use of the
ephonedn command and dualline keyword you create an ephonedn in dualline
mode. The reason is to have one voice port and two channels in order to handle two
independent calls. This mode enables call transfer, call waiting, and conference options.

Registering Cisco SCCP phones to CCME


This procedure registers ephones and ephonesdns to Cisco SPIAD:

configure terminal
! Create the ephone directory number with dual-line mode for Jim Smith, in case that
phone is busy or no answer call will be forwarded to voice mail extension.

ephone-dn 1 dual-line
number 201 no-reg both
label 201
description Jim Smith
name Jim Smith
call-forward busy 399
call-forward noan 399 timeout 10
! Create the ephone directory number with dual-line mode for Sara Noa, in case that
phone is busy or no answer call will be forwarded to voice mail extension.

ephone-dn 2 dual-line
number 202 no-reg both
label 202
description Sara Noa
name Sara Noa
call-forward busy 399
call-forward noan 399 timeout 10

! Create the ephone for Jim Smith and assign the ephone-dn 1 to button 1
*replace mac-address for the one of your phone 7975 SCCP IP phone.

ephone 1
mac-address 0026.99EF.1DEB
type 7975
ephone-template 16
username "jsmith" password qwer201
button 1:1
! Create the ephone for Sara Noa and assign the ephone-dn 2 to button 1
*replace mac-address for the one of your Cisco IP Communicator Client (CIPC)

ephone 2
mac-address AAAA.BBBB.0001
type CIPC
ephone-template 16
username "snoa" password qwer202
button 1:2
! Go to telephony-service an create CNF files

telephony-service
create cnf-files
end
copy running-config startup-config

Connect your Cisco IP Phone 7975 to the switch, if your phone was upgraded you can see
on your console typing:
sh phone-load
Output shows something like this:

Cisco IP Communicator Client (CIPC) Configuration


Sara Noa has no a physical phone assigned, instead IT deparment has installed Cisco IP
communicator client which is a SCCP softphone that offers all features that you could find in
a Cisco phone 7975, an ephone and an ephone-dn have been configured previously.
IP Communicator Client is available on Cisco Download Software:
https://software.cisco.com/download/release.html?mdfid=278468661&catid=280789323&s
oftwareid=282074237&release=8.6(4)&relind=AVAILABLE&rellifecycle=&reltype=latest
When the software is installed, run the application and perform the audio test if needed.
On any place of the software interface right click and select menu preferences

On the new window opened go to network tab, click on use this device name option, if
you remember on the ephone 2 configuration, mac-address AAAA.BBBB.0001 was assigned
to this device for Sara Noa. The device name is composed by prefix SEP followed by the
mac address in this case is SEPAAAABBBB0001.
TFTP server is needed also to load CIPC parameters, TFTP server will be reached on IP
address 10.1.1.1.

Click OK and wait until CIPC is reloaded,


when finished you will see that it is
registered and extension 202 is
assigned on button one to Sara Noa.
Now Sara Noa should be able to call Jim
Smith on extension 201, and he can call
her back to extension 202.
Try a call from Jim to Sara and validate
that basic call between SCCP phones
are working.

Registering Cisco SIP phones to CCME


This procedure registers SIP phones and SIP DNs to CCME on Cisco SPIAD:

configure terminal
! Create Directory Number 203 associated to Emma Smith in case that no answer call will
be forwarded to voice mail extension 399

voice register dn 1
number 203
call-forward b2bua noan 399 timeout 20
name Emma Smith
label Emma Smith
! Prevent that this DN attempts to register to external SIP proxy

no-reg
! Create the voice register pool for the cisco phone 7841 associated to Emma Smith,
replace id mac with the mac address of your phone

voice register pool 1


id mac 2C3E.CF86.23C0
type 7841
! Assign voice register dn 1 to button 1

number 1 dn 1
! Set DTMF relay method

dtmf-relay rtp-nte
! set the username and password for this device

username esmith password qwer203


! force codec to G711ulaw

codec g711ulaw
! go to voice register global and create configuration files

voice register global


create profile
end
copy running-config startup-config
Connect your 7841 and place some calls to the other extensions.

Configuring PSTN access via SIP trunk


In order to gain PSTN access, in this section we will see the procedure to get a SIP Trunk
registered against a simulated Internet Telephony Service Provider.
This Are the requirements and SIP trunk information.
Inbound SIP Trunk DID (PSTN Call in) Numbers (Use PSTN phone to test)
Auto attendant (200)
Extension 1 (201) Jim Smith
Extension 2 (202) Sara Noa
Extension 3 (203) Emma Smith
VoiceMail (399)

4085xx1200
4085xx1201
4085xx1202
4085xx1203
4085xx1209

Outbound Numbers to Call (From IP Phones on SPIAD to PSTN Phone)


Emergency Number
Local Call
Long Distance
International

9060
952671800
9018182212462
90014085256800

SIP Trunk information; remember XX corresponds to your POD number


SIP Register Server
SIP Outbound Proxy
Username
Password

4.31.34.33
4.31.34.33
4085xx1200
4085xx1200

In this case SIP Trunk requires authentication for each number, follow the next steps to get
registration from ITSP

configure terminal
voice service voip
sip
outbound-proxy ipv4:4.31.34.33:5060
sip-ua
authentication username 4085011200 password 4085011200
credentials username 4085011200 password 4085011200 realm
credentials username 4085011201 password 4085011200 realm
credentials username 4085011202 password 4085011200 realm
credentials username 4085011203 password 4085011200 realm
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar ipv4:4.31.34.33:5060 expires 300
sip-server ipv4:4.31.34.33:5060
host-registrar

4.31.34.33
4.31.34.33
4.31.34.33
4.31.34.33

end
copy running start

Validate that SIP trunk was successfully registered, issue:


show sip-ua register status

In order to make and receive calls some translation rules and profiles are needed, follow
these steps to create translation rules for incoming and outgoing calls.
Allow sip server signaling IP address into the toll fraud prevention list

configure terminal
voice service voip
ip address trusted list
ipv4 4.31.34.33 255.255.255.255
end
copy running-config startup-config
Outgoing Calls Setup
configure terminal
! This service provider works only with codec G711u

voice class codec 1


codec preference 1 g711ulaw
! Following translation rules remove 9 prefix and translate source extensions and any
number into the main DID 4085011200

voice translation-rule 410


rule 1 /^9\(.*\)/ /\1/
rule 15 /^...$/ /4085011200/

voice translation-rule 1111


rule 15 /^.*/ /4085011200/
voice translation-rule 1112
rule 1 /^9/ //
! Following profiles translate calling or called number according to translation rules defined,
these profiles will be applied later on voice dial-peers

voice translation-profile CALLER_ID_TRANSLATION_PROFILE


translate calling 1111
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!

voice translation-profile PSTN_CallForwarding


translate redirect-target 410
translate redirect-called 410
voice translation-profile PSTN_Outgoing
translate calling 1111
translate called 1112
translate redirect-target 410
translate redirect-called 410

Translation rules were created, the next step is to create voip outgoing voice dial-peers,
notice that session pattern includes outgoing prefix 9, session target is pointing to SIP
server that was previously configured on SIP trunk section, class-codec and dtmf relay
method may vary from carrier to carrier.

!
dial-peer voice 1021 voip
description **Local Calls - 7, 8 or 10 digits**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9[1-9]T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip asymmetric payload full
dtmf-relay rtp-nte digit-drop
no vad

dial-peer voice 1023 voip


description ** International Calls**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 900T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1025 voip
description **National Long Distance**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 901..........
session protocol sipv2
session target sip-server
voice-class codec 1
no vad
!
dial-peer voice 1026 voip
description **CCA*Mexico*Emergency**
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 1
destination-pattern 060
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1027 voip
description **CCA*Mexico*Emergency**
translation-profile outgoing PSTN_Outgoing
preference 1
destination-pattern 9060
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad
end
write mem

Outgoing calls should be connecting now, test the numbers provided.

Incoming Calls Setup


To receive calls, voice translation rules and translation profiles are needed also; the next
procedure shows how to redirect an incoming call to an specific extension or application
(autoattendant).

configure terminal
! Sent DID 40850xx200 to AutoAttendant extension 200, *AA will be ready later on the lab,
just configure translations

voice translation-rule 6
rule 1 /4085011200/ /200/
voice translation-profile DID_AutoAtt
translate called 6
! Sent DIDs 40850xx201 to 203 to extensions 201 to 203

voice
rule
rule
rule

translation-rule 12
1 /4085011201/ /201/
2 /4085011202/ /202/
3 /4085011203/ /203/

voice translation-profile DIDs-SIP_trunk


translate called 12
! In order to get incoming calls properly routed add following voip dial-peers

dial-peer voice 1000 voip


permission term
description ** Incoming call from SIP trunk **
session protocol sipv2
session target sip-server
incoming called-number .%
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad

dial-peer voice 3012 voip


description ** DIDs from SIP_trunk **
translation-profile incoming DIDs-SIP_trunk
session protocol sipv2
session target sip-server
incoming called-number 408501120
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad
! dial-peer for incoming DIDs

dial-peer voice 3012 voip


description ** DIDs from SIP_trunk **
translation-profile incoming DIDs-SIP_trunk
session protocol sipv2
session target sip-server
incoming called-number 408501120[1-3]
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad
! AutoAttendant will be enabled later but this is the dial-peer needed

dial-peer voice 3002 voip


description DIDAutoAtt-AA
translation-profile incoming DID_AutoAtt
session protocol sipv2
session target sip-server
incoming called-number 4085011200
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
no vad

Now that you can place and receive calls your PBX is setup for basic calls in the next
sections we will cover Voice Mail and Autattendant integration, additionally some advanced
features will be covered.

TASK 5: DEPLOYING VOICEMAIL AND AUTOATTENDAT


Cisco Unified Communications Manager Express provides call processing for Cisco Unified IP
Phones. Cisco Unity Express offers voicemail and automated-attendant capabilities for IP
phone users connected to Cisco Unified Communications Manager Express. The voicemail
and automated-attendant capabilities are fully integrated into the Cisco access router using
a network module or services-ready engine (SRE). With this solution, the Cisco portfolio of
access routers delivers features similar to those of a key system or hybrid private branch
exchange (PBX) plus the rich data and routing capabilities expected on the award winning
Cisco integrated services routers(ISRs), Customers can now deliver unified communications
to their small sites and branch offices with a solution that is very simple to deploy,
administer, and maintain. Cisco Unified Communications Manager Express with Cisco Unity
Express offers customers a cost-effective, highly reliable, feature-rich solution for an office
deployment.
As was described on Internal Service Module network setup; Cisco Unity Express is loaded
from factor in ISM 0/0, Voice Mail and Auto attendant Ports licenses are loaded also on
Cisco SPIAD.
Cisco Unity Express GUI can read users and extension from Communications Manager
Express in order to do it graphical user interface for CCME should be loaded and configured,
follow this procedure to download GUI files from TFTP server and apply the CLI commands
to enable http access and create user and password for this task.
CCME GUI setup
Open a ssh connection to the SPIAD system, download and extract GUI files into flash:
Issue:
archive tar /xtract tftp://192.168.10.11/CME_GUI_10.5.tar flash:

Apply the following commands to create the GUI administrative user and password to grant
http access for such user.
GUI username:
GUI Password:

admin
spiad

aaa new-model
!
!
aaa authentication login default local
!

ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:/GUI
!
file privilege 0
!
telephony-service
web admin system name admin secret spiad
dn-webedit
time-webedit

Open your browser and test CCME GUI access, go to http://192.168.10.1/ccme.html


Type username: admin and password spiad

After a successful authentication you should be able to see the administrative web interface
for Cisco Unified Communications Manager Express, from here you can create SCCP phones,
SCCP extensions and configure some telephony-service parameters.
Note: SIP phones and extensions cannot be managed on this interface.

Voice Mail Message Waiting Indicator (MWI)


As we said before, Cisco Unity Express GUI reads configuration from CCME in order to have
all parameters ready for CUE is necessary to create MWI configuration, follow the next steps
to create indicator for ON and OFF and dial-peer to get a proper communication to CUE
system.

! Create ephone-dn for ON and OFF indicators

ephone-dn 199
number A801... no-reg primary
mwi off
!
!
ephone-dn 200
number A800... no-reg primary
mwi on

! Create voice voip dial-peer to Passthrough Inbound Calls for MWI from CUE

dial-peer voice 1005 voip


description ** Passthrough Inbound Calls for MWI from CUE **
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number A80T
dtmf-relay rtp-nte
codec g711ulaw
no vad

Cisco Unity Express Setup


With the previous steps done no we are ready to complete CUE setup.
Open your browser and go to http://10.1.10.1/ by default username and password are
cisco
When login, chose Communications Manager Express Integration.

This will trigger a system reload.

Wait for a few minutes until system goes up.

Click on Run Initialization Wizard.

Enter the username and password that was created previously to get access to CCME GUI.

If you dont see the next button click TAB several times until you see it and click on it.
CUE GUI has read users and extensions for CCME and can be imported; check the mailboxes
for the user to create a voice mail box, and choose jsmith as administrator, click next.
Left the default values for the mailboxes and click next.

Enter following values to complete setup:


Voice Mail Number:
399
Voice Mail Operator Extension:
200
Auto Attendant Access Number:
200 (if no VM box call will be redirected to AA)
Auto Attendant Operator Extension:
201 (this is usually reception extension)
Administration via Telephone Number:
397
SIP MWI Notification Mechanism:
by default outcalling
MWI ON Number (Outcalling mechanism): read from ccme A800
MWI OFF Number (Outcalling mechanism):read from ccme A801

Click next.

Review the values that you just entered and commit your setup, checking the box Finally,
save to startup configuration (will take a few minutes more) and click finish

Once system finish initialization you will see that voicemail boxes were created and
configuration was success.

Click logout.

Creating Mailbox for a SIP account


SIP users cannot be imported by CUE, so if you want to assign a voicemail box, this has to
be done manually, follow the next steps to add and create voice mail box for Emma Smith
(esmith) extension 203.
Login to CUE once again, use credentials username:
spiad password: spiad
Go to configure->users and click add.
Fill the new open window with the following mandatory
values
User ID:
esmith
First Name:
Emma
Last Name:
Smith
Nick Name:
(automatically filled with firstname lastname)
Display Name: (automatically filled with firstname lastname)
Associated Phone: none
Primary Extension: chose other and set it to 203

Left the rest of the parameters as default and scroll down to the button, mark the check box
to create mailbox
Click on the icon

located on the upper left corner to finishing user addition.


As mailbox creation was selected in a previous step a
new window is showed:

Left default values and click on the add icon


Now the new user esmith was created and a mailbox
was associated to it.
You can validate that user was added going to
configure->users

By default we have created user and extension that forward calls to voicemail if there is no
answer.
Before to test voicemail and auto attendant, go to the next section to configure VOIP
routing to Cisco Unity Express.

In order to get access to voicemail and basic auto attendant from SIP or SCCP clients some
dial peers are needed, add such dial-peers as follows:

conf t
dial-peer voice 2000 voip
description ** cue voicemail pilot number **
translation-profile outgoing XFER_TO_VM_PROFILE
destination-pattern 399
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2001 voip
description ** Passthrough Inbound Calls for Internal Extensions from CUE **
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
incoming called-number ^...$
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2002 voip
description ** cue auto attendant number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 200
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 2003 voip
description ** cue prompt manager number **
translation-profile outgoing PSTN_CallForwarding
destination-pattern 397
b2bua
session protocol sipv2
session target ipv4:10.1.10.1
voice-class sip outbound-proxy ipv4:10.1.10.1
dtmf-relay rtp-nte
codec g711ulaw
no vad

Save your configuration, issue:

copy running-config startup-config

Testing Voice Mail and Auto Attendant


Now you can test voicemail service dialing from extension 203 (Emma Smith) to 201 (Jim
Smith), left a short message and check that message indicator is turned on once you hang
up.
Retrive your messages pressing the message button you will be prompt for a password use
12345
Do the same test now dialing from Jim Smith (201) to Emma Smith (203).
To Validate Auto Attendant Operation dial from extension 202 (Sara Noa) to extension 200
you should be able to hear Auto Attendant prompt. Once you are connected chose 1 to dial
by telephone number and the dial 201 then # your call should be transferred to Jim Smith.
Repeat the test but this time dial to extension 203 then #
Whit these tests we have finished the Voice Mail and Basic Auto Attendant deployment, your
system is fully working as an IPPBX. You can place and receive call from SIP trunk directly
to a specific extension and to a basic auto attendant.

TASK 6: ADVANCED FEATURES


In this section we will cover some advance features that can be implemented on Cisco
SPIAD, we will cover following implementation:
Hunt Groups
Pickup Group
Call Park
Meetme Conference
Call restriction by user (pin before dial)
Extension Mobility

APPENDIX
A. Cisco Unity Express Factory Restart

CISCO_SPIAD# service-module ism0/0 session


Trying 10.1.10.2, 2067 ... Open
se-10-1-10-1#
se-10-1-10-1# offline
!!!WARNING!!!: If you are going offline to do a backup, it is recommended
that you save the current running configuration using the 'write' command,
prior to going to the offline state.
Putting the system offline will disable management interfaces.
Are you sure you want to go offline?[confirm]
se-10-1-10-1(offline)# restore factory default
!!!WARNING!!!: This operation will cause all configuration and data
on the system to be erased. This operation is not reversible.
Do you wish to continue?[confirm]
Restoring the system. Please wait ...
..done
System will be restored to factory default when it reloads.
Press any key to reload:
System reloading ....
MONITOR SHUTDOWN...
INIT: Sending processes the TERM signal
Sending an RBCP message to IOS notifying module reboot...
Rebooting ...
SNIP
INIT: Entering runlevel: 2
********** rc.post_install ****************
IMPORTANT::
IMPORTANT::
Welcome to Cisco Systems Service Engine
IMPORTANT::
post installation configuration tool.
IMPORTANT::
IMPORTANT:: This is a one time process which will guide
IMPORTANT:: you through initial setup of your Service Engine.
IMPORTANT:: Once run, this process will have configured
IMPORTANT:: the system for your location.
IMPORTANT::
IMPORTANT:: If you do not wish to continue, the system will be halted
IMPORTANT:: so it can be safely removed from the router.
IMPORTANT::
Do you wish to start configuration now (y,n)?

B. Cisco IP Phone Factory Reset


Follow the steps below to successfully Factory reset your Cisco IP phone:
1. Unplug the power cable from the ip phone and then plug it back in.
2. While the phone is powering up, and before the Speaker button flashes on and off, press and
hold the hash # key.
3. Continue to hold # until each line button (right of the LCD screen) flashes on and off in sequence
in orange color.
4. Now release the hash # key and type the following sequence 123456789*0#
After the sequence has been entered the line buttons on the phone flash orange, then green and the
phone goes through the factory reset process. This process can take several minutes and the firmware of
the IP Phone will be erased.
When complete, the IP phone will reboot and the bootloader will try to obtain an IP address via DHCP.
The IP phone also expects the IP address (option 150) or the name (option 66) of the TFTP server to be
delivered by the DHCP server. This is why these DHCP options are critical at this phase.
The phone then tries to obtain the appropriate termXX.default.loads file depending in its model:
This "loads" file indicates all the files the IP phone has to download from the TFTP server to make up the
device firmware. The IP phone should first obtain the loads file and then proceed with the individual
files. Once complete, the IP phone will install the files and finally reboot
C. How to Reset Cisco IP Communicator
Follow the steps below to successfully clear settings on Cisco IP Communicator Client:
Press Settings Button (looks like a check in a box)

Press**# (to unlock menu)


Press Erase

You might also like