You are on page 1of 4

ROUTER 0

Router>enable
Router#config
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter
Router(config)#interface fa0/0
Router(config-if)#ip add 192.168.10.254 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial2/0
Router(config-if)#ip add 10.1.0.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#clock rate 1000000
Router(config-if)#exit
Router(config)#interface serial3/0
Router(config-if)#ip add 10.2.0.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down


Router(config-if)#clock rate 1000000
Router(config-if)#exit

Set IP address for PC0 and PC1 by yourself

ROUTER1:
Router>enable
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter
Router(config)#interface fa0/0
Router(config-if)#ip add 192.168.20.54 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial2/0
Router(config-if)#ip add 10.1.0.2 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#clock rate 1000000
Router(config-if)#exit
Router(config)#interface serial3/0
Router(config-if)#ip add 10.3.0.1 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial3/0, changed state to down


Router(config-if)#clock rate 1000000
Router(config-if)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#

Set IP address for PC2 and PC3 by yourself

ROUTE3:
Router>enable
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#inter
Router(config)#interface fa0/0
Router(config-if)#ip add 192.168.30.254 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#exit
Router(config)#interface serial2/0
Router(config-if)#ip add 10.2.0.2 255.255.255.0
Router(config-if)#no shut

%LINK-5-CHANGED: Interface Serial2/0, changed state to down


Router(config-if)#clock rate 1000000
Router(config-if)#exit
Router(config)#interface serial3/0
Router(config-if)#ip add 10.3.0.2 255.255.255.0
Router(config-if)#no shut
%LINK-5-CHANGED: Interface Serial3/0, changed state to down
Router(config-if)#clock rate 1000000
Router(config-if)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#

Set IP address for PC4 and PC5 by yourself


Connect routers by red lines (attached with clock)

ROUTER 0:
Router>enable
Router#conf
Router#configure ter
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 100
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router(config-router)#network 10.1.0.0 0.0.0.255 area 0
Router(config-router)#network 10.2.0.0 0.0.0.255 area 0
Router(config-router)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#

ROUTER 1:
Router>enable
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 100
Router(config-router)#network 192.168.20.0 0.0.0.255 area 0
Router(config-router)#network 10.3.0.0 0.0.0.255 area 0
Router(config-router)#network 10.1.0.0 0.0.0.255 area 0
Router(config-router)#
00:24:44: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.10.254 on Serial2/0 from LOADING
to FULL, Loading Done
Router(config-router)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#

ROUTER 3:
Router#enable
Router#conf
Router#configure ter
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 100
Router(config-router)#network 192.168.30.0 255.255.255.0 area 0
Router(config-router)#network 10.2.0.0 0.0.0.255 area 0
Router(config-router)#network 10.2.0.0 0.0.0.255 area 0
00:12:55: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.10.254 on Serial2/0 from LOADING
to FULL, Loading Done
Router(config-router)#network 10.3.0.0 0.0.0.255 area 0
Router(config-router)#exit
Router(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router#
00:13:10: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.20.54 on Serial3/0 from EXCHANGE
to FULL, Exchange Done

DONE!

You might also like