P. 1
Huong Dan Cai Dat Va Su Dung Mplab

Huong Dan Cai Dat Va Su Dung Mplab

|Views: 5,708|Likes:
Được xuất bản bởitonybinh2011

More info:

Published by: tonybinh2011 on Mar 16, 2011
Bản quyền:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

07/25/2013

pdf

text

original

Chương 1 :Cài đặt và cấu hình software

Bài 1 : Cài đặt MPLAB IDE 8.36 1.1 Giới thiệu MPLAB IDE là phần mềm được hỗ trợ bởi Microchip, dùng để soạn thảo code cho các ứng dụng của PIC. Hiện tại, tháng 8/2010 MPLAB IDE đã có phiên bản 8.51. Trong tài liệu này tôi chọn phiên bản 8.36 vì nó có khá nhiều lỗi về cấu hình . Các phiên bản khác như 8.43, bạn có thể không chọn cấu hình ban đầu nhưng bản thân nó có thể tự động tìm kiếm các thư viện cần thiết trong quá trình biên dịch. Với phiên bản 8.36 chúng ta phải cấu hình toàn bộ cho IDE. 1.2 Cài đặt MPLAB IDE 8.36 Bước 1 : Double Click vào file setup trong thư mục MPLAB IDE 8.36. Màn hình Welcome sẽ hiện ra như sau. Bạn chọn Next để tiếp tục.

Bước 2 : Chọn I accept the term of the license agreement và chọn Next.

Bước 3 : Để chế độ mặc định là cài đặt Complete và chọn Next để tiếp tục.

Bước 4 : Chọn đường dẫn cài đặt, ta nên để mặc định là C:\Program

Bước 5 : Tiếp tục chọn I accept cho Maestro License và C32 License.

Bước 6 : Giao diện sau tổng kết lại các lựa chọn của bạn, nhấn Next để tiến hành cài đặt. Nếu muốn hiệu chỉnh bạn nhấn Back.

Bước 7 : Khi cài đặt xong MPLAB IDE sẽ hỏi bạn có cần cài Hi Tech không. Đây là compiler C hỗ trợ cho MPLAB IDE, tuy nhiên ta sẽ không dùng compiler này mà sẽ dùng MPLAB C18. Bạn chọn No nhấn Finish để hoàn tất việc cài đặt MPLAB IDE.

Thông báo dưới đâu xuất hiện, thống kê các tài liệu hướng dẫn đi kèm. Các tài liệu này đều nằm trong thư mục cài đặt C:\Program Files\Microchip\

Bài 2 : Cài đặt compiler MPLAB C18 MPLAB C18:http://rapidshare.com/files/410599146/MPLAB_c18.rar 2.1 Giới thiệu Khi cài đặt xong MPLAB IDE, compiler mặc định cho nó là MPASM, dùng để dịch project viết bằng ASM sang file HEX. Muốn viết chương trình bằng C, ta cần phải cài đặt thêm 1 compiler khác có hỗ trợ cho chip PIC đang dùng. Trong phần này, tôi thí nghiệm trên vi điều khiển PIC18F4520 và chọn compiler C18 để hỗ trợ cho lập trình C chuẩn. 2.2 Các bước cài đặt Bước 1 : Double Click vào file MPLAB C18 V1.0.exe để tiến hành cài đặt, màn hình welcome của MPLAB C18 sẽ hiện ra như sau :

Bước 2 : Chọn nơi lưu trữ cho các file biên dịch của MPLAB C18, ta có thể để mặc định là C:\mcc18 .

Bước 3 : Chọn lựa các thành phần của gói MCC18, thông thường ta sẽ chọn hết tất cả các gói trong compier C18.

Bước 4 : Nhấn Next để tiến hành cài đặt

Chờ cho đến khi cài đặt xong.

Bước 5 : Nhấn Finish để kết thúc cài đặt MPLAB C18.

2.3 Cập nhật lên C18 version 3.01 Phiên bản mà ta vừa cài đặt là C18 v1.0. Để cập nhật lên v3.01, ta sẽ double click và file MPLAB-C18pgrade-doc-v3_01.exe. Màn hình welcome sẽ hiện ra như sau:

Chọn I Accept và nhấn Next để tiếp tục cài đặt.

Các tài liệu hỗ trợ lập trình cho compiler C18 đi kèm.

Chọn thư mục mặc định cho việc update (giống với thư mục cài đặt C18)

Để mặc định các thành phần sẽ được cài đặt, không cần phải check thêm.

Check chọn thêm các option dưới đây để MPLAB IDE tự động cấu hình các thông số tương thích với phiên bản C18 v3.01

Chọn Next để tiến hành Update

Chờ cho đến khi hoàn tất.

Nhấn Finish để kết thúc.

Bài 3 : Tạo project trên MPLAB 8.36 và C18 3.01 Tạo 1 project lần đầu trên MPLAB khá phức tạp. Người sử dụng cần phải cấu hình cho MPLAB khá nhiều. Tuy nhiên hầu hết các thông số cấu hình này sẽ được lưu lại cho lần sau, chúng ta chỉ cần phải thiết lập 1 lần. Phần này hướng dẫn cách tạo 1 project đơn giản trên MPLAB cho chip 18F4520 và mạch nạp PICKit2 trên board BKIT PIC. 3.1 Tạo mới project Kích hoạt chương trình MPLAB IDE 8.36 từ biểu tượng Microchip trên màn hình Desktop, cửa sổ sau đây sẽ hiện ra.

Chọn menu Project và chọn New

Cửa sổ sau đây hiện ra, bạn đặt tên cho project ở khung Project Name và chọn đường dẫn cho nó ở khung Project Directory.

Cửa sổ làm việc của project sẽ hiện ra ở bên trái như hình dưới đây. Nếu cửa sổ project không hiện ra bạn sẽ chọn menu View và chọn Project.

Chọn compile C18 cho project này bằng cách chọn vào menu Project và chọn Select Language Toolsuite.

Chọn Active Toolsuite là Microchip C18 Toolsuite. Các đường dẫn của các chương trình trong gói compiler cho C18 đã được cấu hình trong lúc cài đặt C18 upgrade, bạn không cần phải chỉnh lại. Các gói này đều nằm trong thư mục C:\mcc18.

3.2 Cấu hình cho chip Phần này có ảnh hưởng đối với quá trình dịch và nạp cho chip. Chọn menu Configure và chọn Select Device… để chọn chip.

Giao diện dưới đây hiện ra và bạn chọn cho đúng chip mà mình đang dùng. Ở đây tôi chọn chip PIC18F4520.

Nhấn OK để đóng cửa sổ này lại. Tiếp theo đó là việc lựa chọn cấu hình thạch anh và 1 số cấu hình khác. Bạn vào lại menu Configure và chọn Configuration Bits…

Màn hình để bạn cấu hình cho chế độ hoạt động của chip dưới đây hiện ra. Check bỏ dấu chọn ở Configuration Bits set in code để bạn có thể thay đổi các thông số. Thông số đầu tiên là chế độ thạch anh, tùy vào mỗi loại chip và thạch anh mà chọn lựa khác nhau. Ở đây tôi sử dụng thạch anh ngoài 12MHz nên sẽ chọn chế độ thạch anh là HS (High Speed). Các chế độ thạch anh của PIC18F4520 sẽ được đề cập ở các bài sau. PORTB bit 4-0 ở chế độ mặt định là các chân analog. Khi không sử dụng analog bạn cần phải chỉnh sang chế độ Digital khi reset. Disable chức năng Low Voltage Programming (LVP - Nạp điện áp thấp), mạch PICKit2 không hỗ trợ chức năng này. Sau khi hoàn thành bạn check lại Configuration Bits set in code và đóng cửa sổ này lại.

3.3 Tạo mới file và add thư viện cho project Bước tiếp theo là tạo file source để viết code. Từ toolbar bạn có thể chọn New File hoặc và menu File và chọn New.

Một file mới được tạo ra với tên mặc định là Untitled như hình dưới đây.

Bạn nhấn vào menu File và chọn Save As… để lưu lại file này. Cửa số dưới đây hiện ra và bạn chọn đường dẫn để lưu cho chính xác. Thông thường ta sẽ lưu trong thư mục chứa project hiện tại cho dễ quản lý.

Nhấn Save để lưu file với tên mới là main.c và đóng cửa sổ trên lại. Bước tiếp theo là add file vừa mới lưu (main.c) và thư mục Source File của project. Click chuột phải vào Source File và chọn Add Files…

Chọn đường dẫn đến file main.c và nhấn Open.

File main.c sẽ được add vào mục Source File của project như hình bên dưới.

Tiếp theo ta sẽ add các thư viện cho project. Đầu tiên là Header Files. Cũng tương tự như khi add file vào Source File, click chuột phải và chọn Add Files. Browse đường dẫn đến C:\mcc18\h và chọn file p18f4520.h hoặc gõ tên file này vào mục File name rồi nhấn Open.

Add file vào mục Linker Script, browse đường dẫn đến C:\mcc18\lkr và chọn file 18f4520.lkr.

Add file lib vào mục Library Files, 18f4520.lib tại thư mục C:\mcc18\lib

3.4 Cấu hình cho quá trình dịch project Khi dịch project, compiler cần 1 số file object của nó (chẳng hạn như c018i.o), ta cần phải chỉ đường dẫn

tìm kiếm các file object này cho compiler. Đối với 1 số phiên bản MPLAB, nó tự động tìm đúng các file này. Tuy nhiên đối với phiên bản 8.36 ta cần phải chỉ định đường dẫn tìm kiếm. Từ menu Project, chọn Build Option và chọn Project.

Giao diện Build Option hiện ra, tại mục Show Directories for bạn chọn Include Search Path, chọn New và Browse đường dẫn đến C:\mcc18\h. Sau đó chỉnh sang Library Search Path và tạo mới 1 đường dẫn C:\mcc18\lib

Nhấn OK để hoàn tất việc cấu hình của quá trình dịch. 3.5 Viết code cho project Double Click vào file main.c và bắt đầu viết code cho project. Ta viết 1 đoạn code nhỏ để làm cho các led nối với PORTB của vi điều khiến sáng xen kẽ (PORTB = 0xAA) #include <p18f4520.h> void main() { TRISB = 0x00; PORTB = 0xAA; while(1); }

Để kiểm tra code viết có lỗi hay không bạn vào menu Project và chọn Build All hoặc nhấn tổ hợp phím nóng Ctrl F10. Nếu không có lỗi thông báo BUILD SUCCEEDED sẽ xuất hiện.

3.6 Kết nối với board Sau khi biên dịch thành công, bạn kết nối máy tính với board để nạp và chạy thử chương trình. Với mạch BKIT PIC bạn cắm dây USB vào chân mạch nạp, bật công tắt nguồn và gạt tất cả các switch của SW2 lên ON để kết nối mạch nạp PICKit2.

Gạt tất cả các switch của SW1 lên ON để enable nút Reset, Led ở PortB và chân thạch anh ngoài.

3.7 Cấu hình mạch nạp Từ menu Programmer chọn Select Programmer và chọn mạch nạp tương ứng là PICKit2. Muốn chọn mạch nạp khác hoặc kết nối với mạch nạp lỗi bạn phải chọn lại None rồi sau đó mới chọn lại mạch nạp.

Để thuận tiện cho quá trình lập trình, ta nên thiết lập thêm 1 số thông số cho mạch nạp để có thể tự động nạp và chạy chương trình khi biên dịch không có lỗi. Để làm được điều này ta sẽ chọn Programmer và chọn Settings.

Giao diện sau hiện ra và bạn check chọn Program after successful build (Nạp chương trình khi biên dịch thành công) và Run after a successful program (Chạy chương trình khi nạp thành công). Nhấn OK để kết thúc.

Bây giờ bạn nhấn lại tổ hợp phím Ctrl F10 (Build All), MPLAB sẽ làm 1 loạt các thao tác nếu không có lỗi : Dịch chương trình – Nạp chương trình – Kéo chân VDD lên mức cao để thả chân Reset và chương trình bắt đầu chạy trên board.

Hình ảnh chương trình chạy trên board BKIT PIC như sau :

You're Reading a Free Preview

Tải về
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->