P. 1
Su Dung SPSS

Su Dung SPSS

|Views: 1,115|Likes:
Được xuất bản bởiTrung Vo

More info:

Published by: Trung Vo on Aug 28, 2011
Bản quyền:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

07/20/2013

pdf

text

original

Chương trình Giảng dạy Kinh tế Fulbright Niên khóa 2007-2008

Các Phương Pháp Phân Tích

Tài liệu phát thêm

PHÂN TÍCH DỮ LIỆU BẰNG PHẦN MỀM SPSS 12.0∗ PHẦN 1
Các nội dung chính trong phần này: 1. 2. 3. 4. 5. 6. 7. 8. Khởi động SPSS Giới thiệu một số menu chính trong cửa sổ SPSS Mở dữ liệu từ tập tin của SPSS và của phần mềm EXCEL Nhập dữ liệu trực tiếp từ bàn phím và bằng Copy và Paste Vẽ đồ thị scatter Thống kê mô tả dữ liệu Kiểm tra sự tương quan Thêm biến và thêm quan sát

∗ SPSS là một nhãn hiệu đã đăng ký bản quyền của SPSS Inc.

File: Chứa nội dung về: Tạo mới dữ liệu. Lập bảng biểu. d. Sao chép và cắt dán dữ liệu. Mở dữ liệu từ các tập tin của SPSS và của các phần mềm khác. b. Program. Edit: Chứa nội dung về: Thực hiện lại hoặc hủy bỏ một thao tác vừa mới thực hiện.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm 1. Lưu trữ dữ liệu. Chỉnh sửa một số nội dung tùy chọn chung (Options). Help: Chứa nội dung về: Những trợ giúp cho người sử dụng. e. chạy các loại hồi quy. In ấn và Thoát khỏi SPSS. Analyze: Chứa nội dung về: Thống kê mô tả. Graph: Chứa nội dung về: Vẽ đồ thị. • • Khởi động SPSS Cách 1: Nhấp đúp vào biểu tượng SPSS trên màn hình. Giới thiệu một số menu chính trong cửa sổ SPSS File Edit View Data Transform Analyze Graphs Utilities Add-ons Windows Help a. Quoác Duy 2 . c. SPSS for Windows HÌNH 1 2. Cách 2: Vào Start.

Open. Sau đó.sav HÌNH 2 b. vào mục Files of type để chọn loại tập tin cần truy xuất dữ liệu. Mở dữ liệu từ tập tin của SPSS và của phần mềm EXCEL a. Data. chúng ta quan tâm đến tập tin của EXCEL. Sau đó chọn loại tập tin có phần mở rộng *. Từ tập tin của SPSS Vào Menu File.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm 3. Quoác Duy 3 . Data. Ở đây. Open. Từ tập tin của phần mềm EXCEL Vào Menu File.

Bây giờ chuyển nội dung của tập tin này sang SPSS. HÌNH 4 Quoác Duy 4 .Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm HÌNH 3 Ví dụ: Có 1 tập tin EXCEL chứa dữ liệu về giá nhà và diện tích như đã học. Nội dung của tập tin này bắt đầu từ A1 đến C15.

chọn File. Nếu chọn dòng chữ Read variable names from the fisrt row of data. • Nếu chúng ta lấy hết toàn bộ nội dung của file Excel thì nhấn OK. Data.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm Trước tiên. cần đóng tập tin này lại (nếu như đang mở ra xem nó trong EXCEL). Sau đó.xls). HÌNH 5 HÌNH 6 Dòng Worksheet cho biết là trong tập tin GIA NHA. thì SPSS sẽ lấy tên biến giống như tên đã được nhập sẵn trong Excel. vào SPSS. Open.XLS có bao nhiêu Sheet chứa dữ liệu và mức độ dàn trải của dữ liệu. Sau đó chọn Files of type và chọn Excel (*. Sau đó chọn tập tin Excel cần sử dụng. HÌNH 7 Quoác Duy 5 .

HÌNH 8 Quoác Duy 6 . Chẳng hạn. Tức là chúng ta chỉ lấy cột PRICE và SQFT.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm • Nếu chúng ta chỉ lấy một phần nội dung của file Excel thì nhập thông tin vào Range. nếu chúng ta không lấy cột STT trong file Excel thì gõ vào Range: B1:C15 rồi nhấn OK.

Sau đó chọn vị trí và Paste dữ liệu vừa Copy từ Excel vào. mở SPSS.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm 4. New. Nhập dữ liệu trực tiếp từ bàn phím và bằng Copy và Paste HÌNH 9 Từ tập tin trong Excel. HÌNH 10 Quoác Duy 7 . Data. Sau đó. chọn dòng và cột dữ liệu cần sao chép rồi Copy. vào File.

sau đó click chuột phải và chọn Clear. nhấp vào Variable View Quoác Duy 8 . chúng ta nháp vào dòng số 1. HÌNH 11 HÌNH 12 Để đổi tên biến. Mặc khác. tên biến được mặc định là VAR0001 và VAR0002. không phải là giá trị nên SPSS bỏ trống dòng đó.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm Do Copy trực tiếp nên dòng đầu tiên chứa tên biến. Để bỏ đi dòng đầu tiên.

HÌNH 14 Để trở lại sheet chứa dữ liệu. gõ tên mới rồi nhấn Enter.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm HÌNH 13 Nhấp vào các ô trong cột Name . nhấp vào Data View Quoác Duy 9 .

Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm 5. Sau đó nhấp vào nút này để đưa biến PRICE vào trục tung HÌNH 17 Quoác Duy 10 . Vẽ đồ thị scatter HÌNH 15 Vào Menu Graphs. chọn Scatter Ch n Simple Sau đó nh p Define HÌNH 16 Nhấp vào biến PRICE là biến phụ thuộc.

Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm Quoác Duy 11 .

HÌNH 18 Quoác Duy 12 . kết quả vẽ đồ thị sẽ hiện ra trong một cửa sổ mới có tên là Output1. Và kết quả của những lệnh khác cũng sẽ thể hiện trong cửa sổ này.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm Sau khi nhấp OK.

Thống kê mô tả dữ liệu HÌNH 19 Vào Menu Analyze. nhấp vào Options. Nếu muốn chọn chỉ tiêu nào thì nhấp vào ô trắng bên cạnh chỉ tiêu đó. Descriptive Statistics.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm 6. Quoác Duy 13 . và tương tự cho biến SQRT nút (chú ý: tùy theo nhu cầu mà chúng ta có thể chọn 1 hay nhiều biến) Để lựa chọn các chỉ tiêu cần quan tâm. Descriptives… Nhấp vào biến PRICE rồi sau đó nhấp vào .

Thêm quan sát Nối tiếp: Quan sát muốn thêm vào là nối tiếp theo các quan sát trước thì chúng ta nhấp vào ô cần thêm giá trị và gõ vào bình thường giống như Excel. 7. • Thêm bớt biến và quan sát a. bảng kết quả được bố trí nằm ngang. Kết quả thống kê mô tả sẽ hiện ra tại cửa sổ Output1 .Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm HÌNH 20 Sau khi chọn xong các chỉ tiêu cần xem xét. nhấp vào nút Continue để trở hộp thoại Descriptives rồi bấm OK. Quoác Duy 14 .

chọn Insert Cases.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm HÌNH 21 • Chèn: Quan sát muốn thêm vào là xen giữa các quan sát đã có thì chúng ta sẽ chọn dòng cần chèn rồi click chuột phải. HÌNH 22 Sau khi dòng đã được thêm vào thì chúng ta nhấp vào ô cần thêm giá trị và gõ vào bình thường Quoác Duy 15 .

HÌNH 23 Quoác Duy 16 .Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm giống như Excel.

Trong trường hợp này chúng ta thử chọn Pearson và Spearman. Kiểm tra sự tương quan Vào Menu Analyze. Thêm biến Thao tác để thêm biến cũng giống như trong Excel. chọn Correlate. Bivariate… Sau khi đưa hai biến cần xem xét tương quan vào ô Variables. chúng ta có thể gõ trực tiếp vào trong các ô của biến mới. chúng ta có thể tùy chọn các loại hệ số tương quan.Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm b. Sau đó vào Variable View để đặt tên cho biến mới đó. HÌNH 24 Quoác Duy 17 . 8.

Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm Sau khi bấm OK . HÌNH 25 Quoác Duy 18 . Đây là bảng kết quả của hệ số Pearson. kết quả sẽ được hiện ra trong cửa sổ Output 1.

Chương trình Giảng dạy Kinh tế Fulbright Các Phương Pháp Phân Tích Tài liệu phát thêm Còn đây là kết quả của hệ số Spearman. những giá trị có ý nghĩa thống kê được đánh dấu bằng ** Quoác Duy 19 . HÌNH 26 Trong cả 2 bảng trên.

You're Reading a Free Preview

Tải về
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->