P. 1
SPSS

SPSS

|Views: 638|Likes:
Được xuất bản bởiapeteka

More info:

Published by: apeteka on Jun 22, 2012
Bản quyền:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

11/17/2013

pdf

text

original

SPSS Là phần mềm chuyên dụng xử lý thông tin sơ cấp - thông tin được thu thập trực tiếp

từ đối tượng nghiên cứu. Thông tin được xử lý là thông tin định lượng (có ý nghĩa về mặt thống kê). SPSS là một bộ chương trình mà nhiều người sử dụng ưa thích do nó rất dễ sử dụng. SPSS có một giao diện giữa người và máy cho phép sử dụng các menu thả xuống để chọn các lệnh thực hiện. Khi thực hiện một phân tích chỉ đơn giản chọn thủ tục cần thiết và chọn các biến phân tích và bấm OK là có kết quả ngay trên màn hình để xem xét. SPSS cũng có một ngôn ngữ cú pháp có thể học bằng cách dán cú pháp lệnh vào cửa sổ cú pháp từ một lệnh vừa chọn và thực hiện, nhưng nói chung khá phức tạp và không trực giác. SPSS có một bộ soạn thảo dữ liệu tương tự như excel, bộ soạn thảo cho phép vào các dữ liệu và mô tả các thuộc tính của chúng, tuy nhiên SPSS không có những công cụ quản lý dữ liệu thật mạnh (mặc dù SPSS phiên bản 11 có thêm các lệnh chuyển cấu trúc dữ liệu theo chiều ngang thành cấu trúc dữ liệu theo chiều dọc và ngược lại....). SPSS xử lý mỗi file dữ liệu ở một thời điểm và không phải là rất mạnh khi thực hiện các nhiệm vụ phân tích cần làm việc với nhiều file dữ liệu cùng một lúc. Các file dữ liệu có thể có đến 4096 biến và số lượng bản ghi chỉ bị giới hạn trong dung lượng của đĩa cứng. Sức mạnh lớn nhất của SPSS là lĩnh vực phân tích phương sai (SPSS cho phép thực hiện nhiều loại kiểm định tác động riêng biệt) và phân tích nhiều chiều (thí dụ phân tích phương sai nhiều chiều, phân tích nhân tố, phân tích nhóm tổ). SPSS phiên bản 11 còn bổ sung thêm một số khả năng phân tích các mô hình hỗn hợp. Cái yếu nhất của SPSS là khả năng xử lý đối với những vấn đề ước lượng phức tạp và do đó khó đưa ra được các ước lượng sai số đối với các ước lượng này. SPSS cũng không hỗ trợ các công cụ phân tích dữ liệu theo lược đồ mẫu. SPSS có một giao diện giữa người và máy rất đơn giản để tạo ra các đồ thị và khi đã tạo được một đồ thị, nhờ giao diện này mà người sử dụng có thể tuỳ ý hiệu chỉnh đồ thị cũng như hoàn thiện chúng. Các đồ thị có chất lượng rất cao và có thể dán vào các tài liệu khác, thí dụ như Word hoặc Powerpoint. SPSS có ngôn ngữ cú pháp để tạo ra các đồ thị, nhưng nhiều điểm trong giao diện tạo đồ thị lại không sẵn sàng trong ngôn ngữ cú pháp. SPSS nhắm vào mục tiêu dễ sử dụng, khẩu hiệu của họ là thực sự làm, thực sự dễ, và mục tiêu này đã thành công. Nhưng nếu ta dự định sử dụng SPSS như một người sử dụng mạnh, thì nó có thể không đáp ứng được yêu cầu. SPSS mạnh về lĩnh vực đồ thị và lập biểu bảng, báo cáo tổng hợp số liệu, nhưng lại yếu hơn về một số thủ tục thống kê như phương pháp ước lượng mạnh và thiếu vắng phương pháp phân tích dữ liệu theo lược đồ mẫu. Phần mềm SPSS có tất cả 4 dạng màn hình: Data view : Màn hình quản lý dữ liệu Là nơi lưu trữ dữ liệu nghiên cứu với một cấu trúc cơ sở dữ liệu bao gồm cột, hàng và các ô giao nhau giữa cột và hàng Variables view : Màn hình quản lý biến. Là nơi quản lý các biến cùng với các thông số liên quan đến biến như: Name (Tên biến) : Là tên đại diện cho biến, tên biến này sẽ được hiễn thị trên đầu mỗi cột trong

màn hình dữ liệu Type (Loại biến ): Có dạng số và dạng chuỗi Label (Nhãn của biến): Tên biến chỉ được thể hiện tóm tắc bằng ký hiệu, nhãn của biến cho phép nêu rõ hơn về ý nghĩa của biến. Values (Giá trị trong biến ): Cho phép khai báo các giá trị trong biến với ý nghĩa cụ thể (nhãn giá trị) Missing (Giá trị khuyết): SPSS mặc định giá trị khuyến (system missing) là một dấu chấm và tự động loại bỏ các giá trị này ra khỏi các phân tích thống kê. Measures (Dạng thang đo): Hiễn thị dạng thang đo của giá trị trong biến Màn hình hiễn thị kết quả (output): Các phép phân tích thống kê sẽ cho ra các kết quả như bảng biểu, đồi thị và các kết quả kiểm nghiệm, các kết quả này sẽ được truy xuất ra một màn hình, và được lưu giữ dưới một tập tin khác (có đuôi là .SPO). Màn hình này cho phép ta xem và lưu giữ các kết quả phân tích. Màn hình cú pháp (syntax): Màn hình này cho phép ta xem và lưu trữ những cú pháp của một lệnh phân tích. Các cú pháp được lưu trữ sẽ được sử dụng lại mà không cần thao tác các lệnh phân tích lại. 1. Tạo biến và nhập dữ liệu trên SPSS Tạo biến trong màn hình quản lý biến : Nhấp vào Variables view Name: Gõ tên biến cần khai báo Type: Kiểu biến Variable Label: Đặt tên nhãn cho biến một cách đầy đủ hơn Value lables : Định tên cho các giá trị trong biến Missing Values: Được dùng để định ra các giá trị cụ thể cho các giá trị mà ta muốn loại bỏ ra khỏi các phân tích và xử lý thống kê Column: Định ra chiều rộng của cột đang khai báo biến Align: Canh lề Measurement: Chọn loại thang đo Nhập dữ liệu Nhập trực tiếp trên sps hay cũng có thể nhập liệu từ các phần mềm khác như Excel, Fox, … và sau đó chuyển vào trong SPSS thông qua Menu Fileàopen Công cụ tính toán giữa các biến (Compute) Công cụ compute được dùng để tính toán giữa các giá trị trong các biến và kết quả sẽ được lưu giữ trong một biến mới hoặc là một biến khác sẳn có hoặc biến chứa đựng giá trị đang tính toán. Để thực hiện công cụ này ta vào Menu Transform àCompute : Xuất hiện: Mục Target variable : Tên biến sẽ nhận giá trị được tính Ô Numeric Expressionn: chứa các biểu thức số được dùng để tính giá trị cho biến mới. Chúng ta có thể soạn các biểu thức tính toán vào thẳng ô Numeric Expression, và có thể sữ dụng các công

cụ được hiển thị trong hộp thoại như các phiếm (+), (-), Function,… Công cụ if : Dùng để định ra những điều kiện cần thiết kèm theo trong tính toán nếu có 2. Xử lý và phân tích dữ liệu Kiểm tra dữ liệu (Explore) SPSS cung cấp cho công cụ Explore để xem xét và kiểm tra dữ liệu: · Phát hiện các sai sót · Nhận dạng dữ liệu để tìm phương pháp phân tích thích hợp và chuẩn bị cho việc kiểm tra giả thuyết Để kiểm tra dữ liệu, chọn trên menu AnalyzeàDescriptiveStatisticà Explore… để mở hộp thoại Explore như hình sau: Dependent list: Đưa các biến cần kiểm tra vào đây. Display : Cho phép chúng ta chọn cách hiễn thị kết quả. Statistics : Cho phép ta lựa chọn các thống kê hiễn thị như : Descriptives : Hiễn thị các giá trị thống kê như giá trị trung bình, khoảng tin cậy, trung vị, trung bình giãn lược, giá trị nhỏ nhất, lớn nhất, khoảng biến thiên, các bách phân vị M-estimators: Hiễn thị các giá trị trung bình theo 4 loại trọng số Outliers: Hiễn thị các quan sát có 5 giá trị nhỏ nhất và 5 giá trị lớn nhất, gọi là Extreme Values Percentiles: Hiển thị các giá trí bách vị phân Kiểm nghiệm Kolmogorov-Smirnov (Lilliefors) Kiểm nghiệm Kolmogorov-Smirnov, dùng để kiểm nghiệm tính chuẩn tắc của một mẫu hay hai mẫu. Kiểm nghiệm Levene Kiểm nghiệm Levene là phép kiểm nghiệm tính đồng nhất của phương sai. Ở đây ta kiểm nghiệm giả thuyết cho rằng phương sai của giữa các mẫu quan sát là bằng nhauLập bảng phân bố tần suất cho biến một trả lời (Frequencies) 3. Kiểm Định Mối Liên Hệ a. Kiểm định mối liên hệ giữa hai biến Định danh-định danh,định danh-định thức (H o : hai biến không có liên hệ gì với nhau) Người ta dùng Kiểm định Chi-square để kiểm tra xem liệu một biến này có quan hệ hay không với một biến khác, tuy nhiên phương pháp kiểm nghiệm này không chỉ ra cường độ của mối quan hệ giữa hai biến mạnh hay yếu giữa 2 biến, các hệ số trong kiểm nghiệm Chi_square như sau: · Hệ số Pearson Chi-square và Likelihood Ratio cho biết có mối liên hệ giữa hai biến định tính hay không (sig rất nhỏ) · Hệ số Linear-by-linear association Đo lường mối liên hệ tuyến tính giữa hai biến.(hữu dụng khi

hàng cột xếp theo thứ tự tăng dần) · Chỉ số Continuity Correction đánh giá mối tương quan giữa hai biến (dạng 2 x 2)trong bảng. Cách thực hiện trong SPSS: vào AnalyzeàDescriptive Statiticsà Crosstab Hiện hộp thoại, trong đó ta đưa hai biến cần kiểm tra vào 2 ô : Row và Column sau đó nhấn ok là xong. Ta có thể vào trong phần Statistic để chọn các thông số thống kê: Nornimal: dùng cho 2 biến định danh. Ordinal : dùng cho 2 biến dạng thứ bậc. Trong phần Cells: tương tự, hãy vào mà khám phá nó. b. Kiểm định mối liên hệ giữa hai biến Thứ Bậc Phát biểu giả thuyết Ho : không có mối liên hệ nào giữa các biến trong tổng thể Thực hiện trong SPSS : AnalyzeàDescriptive Statiticsà Crosstab, Đưa biến vào 2 ô : Row và Column , nhấn vào Statistics và chọn : Chi square, correlation, gamma, somer’s , tau_b.. c. Kiểm định mẫu đang xét có là phân phối chuẩn không Phát biểu giả thuyết Ho : Độ sai lệch của tổng thể 2 giá bất động sản là phân phối chuẩn(tức giá trị dự báo đáng tin cậy). Ứng dụng : Kiểm định này dùng để kiểm định giả thuyết phân phối của dữ liệu có phù hợp với phân phối lý nthuyết .nó tiến hành xem xét các sai lệch giữa Giá trị cũ và giá trị mới của bất động sản, sai lệch tuyệt đối càng lớn ,giả thuyết Ho càng dễ bị bác bỏ. Cách thực hiện: Bước 1: TransformàCompute , hiện hộp thoại: Nhập tên biến mới vào khung : Target Variabel. Khung Numberic Expression : ta nhập : giáBĐS_dựBáo – Giá BĐScũ. Sau đó nhấn ok. Bước 2 : AnalyzeàNonparametric Testà1 _ sample K S xuất hiện hộp thoại sau: Đưa biến mới tạo bước 1 vao khung Test Variable List. Phần Test Distribution : ta chọn loại phân phối chuẩn ( Normal ) , nhấn OK là xong. 4. Tương Quan Ở phần trước chúng ta đã dùng một số công cụ để đo lường mối liên hệ giữa các biến với nhau. Tuy nhiên kỷ thuật đó chủ yếu dùng cho dữ liệu định tính.Còn đối với các dữ liệu định lượng ta thường dùng hệ số tương quan R., hay biểu đồ phân tán Scatter.

a. Xác định hệ số tương quan: Cách thực hiện trên SPSS : Vào menu Analyzeà chọn CorrelateàChọn Bivarlate , xuất hiện hộp thoại : Khung Variables : ta đưa các biến cần xét mối tương quan vào. Khung Correction Coefficients : chọn Person và Spearman Nhấn vào Option để giải quyết các trường hợp thiếu số liệu của biến đại khái như sau: Phần Statisc : khai báo có tính hay không tính Trung bình_độ lệch chuẩn và tổng tích các môdun chéo_hiệp phương sai. Phần Misssing Value : khai báo xử lý các trường hợp thiếu của biến Exclude case pairwise : xử lý từng cặp, loại giá trị thiếu ra khỏi cặp so sánh,nhưng vẫn dùng cho cặp khác nếu với cặp khác nó không thiếu. Exclude case listwise : mẫu nào thiếu giá trị sẽ bị SPSS loại hẳn ra khỏi cuộc chơi. b. Vẽ biểu đồ Scater Ý nghĩa của biểu đồ : Biểu đồ này cũng có mục đích giúp ta có cái nhìn trực quan về mối liên hệ giữa các biến.Nếu như Hệ số hồi quy R cho ta biết giữa hai biến đó có tương quan không, trường hợp các biến có tương quan thì không nói, nhưng nếu kết quả R cho thấy các biến không có liên hệ với nhau thì lúc này Biểu đồ Scatter sẽ cho ta biết "sự không có mối tương quan giữa các biến" là thật sự vì chúng hoàn toàn độc lập nhau, hay chúng không có mối liên quan bỡi vì chúng không có mối liên hệ tuyến tính mà chúng sẽ liên hệ theo một loại quan hệ nào đó, phi tuyến chẳng hạn. Cách thực hiện : Vào menu Graphs à chọn Scatter..--> Chọn simpleà Chọn Define , xuất hiện hộp thoại. Đưa 2 biến cần vẽ, một vào Y_axis, một vào X_axis Title : dùng để đặt tiêu đề, ghi chú cho biểu đồ Option : dùng để khai báo cách xử lý những giá trị thiếu của biến quan sát. 5. Hồi Quy Tuyến Tính Ý nghĩa : Qua một loạt các kiểm tra, nếu kết luận được các biến có liên quan tuyến tính hay có liên quan phi tuyến với nhau. Thì bước tiếp theo chúng ta tiến hành xây dựng hàm hồi quy. Hàm hồi quy này có ý nghĩa cho chúng ta biết sự đóng góp của từng biến trong biến phụ thuộc hay nói cách khác giá trị của biến phụ thuộc đóng góp bao nhiêu phần trăm trong tổng giá trị của biến phụ thuộc, và nó còn cho chúng ta biết sự thay đổi một đơn vị của nó,sẽ kéo theo sự thay đổi của biến phụ thuộc là bao nhiêu. Cách thực hiện : Vào menu Analyze à Regression à Linear…, hiện hộp thoại: · Khung Dependent : Đưa biến mà ta muốn nó làm biến phụ thuộc vào · Khung Independent : Đưa các biến độc lập vào đây.

· Phần method : lựa chọn phương pháp đưa biến vào: Enter : đưa một lượt các biến vào một lúc. Remove: loạt tất cả các biến ra khỏi hàm 1 lượt, tất nhiên đầu tiên phải đưa các biến vào trước mới có cái để gỡ ra chứ. Forward : Phương pháp đưa vào dần ,biến 1 được đưa vào là biến có tương quan lớn nhất,nếu thỏa tiêu chuẩn vào : FIN hay PIN, thì biến tiếp theo được đưa vào…..Quá trình này dừng lại khi không còn biến nào thỏa tiêu chuẩn vào. Backward : Loại trừ dần từng biến ra khỏi mô hình, đầu tiên biến ít liên quan nhất sẽ được đưa ra khỏi mô hình theo tiêu chuẩn "Loại Trừ: FOUT hay POUT".Quá trình này dừng lại khi giá trị F của biến có hệ số tương quan nhỏ nhất > FOUT. Stepwise : Chọn dần từng bước.Đây là phương pháp kết hợp của 2 phương pháp Forward và Backward (Điều kiện để cho các biến không bị đưa ra rồi đưa vào lập lại thì ta chọn :FIN>FOUT hay PIN<POUT) · Nút Statistics..: chọn các thông số thống kê như sau : Estimates: các ước lượng như: hệ số hồi quy(B),sai số chuẩn (B), giá trị t và Sig. Confidence interval : Khoảng tin cậy. Covariance Matrix : Ma trận hiệp phương sai. Mode Fix : Thể hiện các thống kê đánh giá mức độ phù hợp của mô hình : R, R2, R2 điều chỉnh,sai số chuẩn.. Descriptives : các thống kê mô tả như : trị trung bình, độ lệch chuẩn, ma trận tương quan. R squared chance : Xem xét mức độ tăng của R2 khi đưa thêm 1 biến độc lập vào mô hình. Colinearity diagnostics : Chuẩn đóan hiện tượng CỘNG TUYẾN · Nút Plots.. : Dùng để vẽ đồ thị hồi quy tuyến tính. Khung bên trái chứa : biến phụ thuộc, các dạng biến phần dư, các dạng biến dự đoán ý nghĩa của chúng : *ZPRED : Giá trị dự đoán chuẩn hóa *ZRESID : Phần dư chuẩn hóa *DRESID : phần dư loại bỏ quan sát đang xét *ADJPRED:Giá trị dự đóan điều chỉnh *SRESID : Phần dư student hóa *SDRESID : phần dư loại bỏ quan sát đang xét được student Produce all patial plots : biểu đồ phân tán từng phần. Histogram : biểu đồ tần số. Normal Probability plot: biểu đồ xác suất chuẩn. · Nút Save : Lưu một biến mới tự động tạo ra trong phân tích SPSS như các phần dư, giá trị dự đoán… Phần Predicted Value(các giá trị dự đoán như) : Giá trị dự đóan không chuẩn hóa,dự đóan chuẩn hóa, dự đóan điều chỉnh, sai số chuẩn của các giá trị dự đoán. Phần Distances( khoảng cách) : Dùng để nhận diện các quan sát có ảnh hưởng mạnh đến kết quả phân tích, nó là khoảng cách từ giá trị quan sát đến giá trị trung bình.

Prediction interval (khoảng dự đoán) : Mean : giới hạn trên dưới của khoảng dự đoán của trị trung bình. Individual : giới hạn trên dưới khoảng dự đoán của từng quan sát. Residual (phần dư) : Gồm phần dư không chuẩn hóa, có chuẩn hóa, student hóa, (detecd : phần dư loại bỏ quan sát đang xét).. Influence Statistics : các thông số thống kê ảnh hưởng DfBeta(s) : SPSS sẽ tính lại toàn bộ các hệ số hồi quy,khi loại bỏ 1 quan sát. Standardized DfBeta(s) : Tính các DfBeta(s) chuẩn hóa. DfFit : phản ánh thay đổi của giá trị dự đoán khi loại bỏ 1 quan sát. Standardized DfFit : tính các DfFit chuẩn hóa. Covariance ratio : tính tỷ số giữa các thành phần của ma trận hiệp phương sai sau và trước khi loại bỏ 1 quan sát.nếu tỷ số à1 ,quan sát bỏ không ảnh hưởng nhiều đến ma trận hiệp phương sai. · Nut Option : Thiết lập mặc định cho SPSS. Stepping Method Criteria : Tiêu chuẩn vào và ra áp dụng cho các phương pháp. Use probability of F : Sử dụng xác suất vào (PIN) và ra ( POUT). Use F value : sử dụng F làm tiêu chuẩn vào (FIN), ra (FOUT). Missing value : Lựa chọn cách xử lý các quan sát bị thiếu. Exclude case listwise : chỉ những biến đủ giá trị mới được xử lý. Exclude case pairwise Qastnào đủ gitrị trong 1 cặp đang nghiên cứu sẽ được xử lý để tính hệ số tương quan. Relace with mean : thay thế giá trị thiếu bằng trung bình của biến. Hộp kiểm Include constant in equation : xây dựng mô hình hồi quy có chứa hệ số hay không. 6 . Ứng Dụng Của Mô Hình Hồi Quy Một trong các ứng ụng của mô hình hồi quy đó là dự đóan ,chúng ta có thể dự đóan giá trị trung bình Y trong trường hợp biêt được các giá trị X, hay tiên đoán giá trị Y trong một trường hợp cụ thể tại giá trị Xo nào đó.(cả 2 trường hợp này kết quả dự đoán như nhau, tuy nhiên sai số chuẩn khác nhau). Cách thực hiện dự đóan trên SPSS : Vào menu Analyze à Regression à Linear , đưa các biến cần xây dựng vào mô hình, sau đó nhấn vào nút SAVE ,đánh dấu chọn vào cáo ô Unstandadized , standadized, Adjust. à nhấn Continue à nhấn OK. 7. Dò Tìm Sự Vi Phạm Các Giả Định Cần Thiết Trong Hồi Quy Việc chúng ta làm từ đầu đến giờ cũng thật sự chưa thuyết phục lắm, do đó để tạo sự tin tưởng hoàn toàn vào kết quả của hàm, ta lần lượt đi kiêm định, dò tìm thử có giả thuyết nào bị vi phạm trong mẫu của chúng ta không. Ta cần kiểm tra một số như : Giả định tuyến tính có phù hợp

không, giả định phương sai không đổi, giả định về phân phối chuẩn của phần dư, giả định về tính độc lập của sai số( không có sự tương tác giữa các phần dư),giả định không có sự tương quan giữa các biến độc lập( Đo lường Đa cộng tuyến), a. Kiểm Định Giả Thuyết Liên Hệ Tuyến Tính: Loại này Kiểm tra bằng cách vẽ đồ thị phân tán giưa các Phần Dư và Giá trị dự đoán đã chuẩn hóa. Bước 1 : tạo 2 biến Phần dư (standardized residual) và Giá trị dự đoán (Standardized predicted ) Bước 2 : Vẽ biểu đồ Scatter cho 2 biến này Bước 3 : kết luận như sau : Nếu giả định tuyến tính đúng thì phần dư rải ngẫu nhiên không theo một quy luật nào, ngược lại, giả định bị vi phạm. b. Kiểm Định Giả Thuyết Phương Sai Không Đổi :có thể dùng kiểm định White,Glesjer, tuơng quan hạng Speaman. Nếu phương sai thay đổi sẽ tạo ra rất nhiều hậu quả tai hại,nó làm cho các ước lượng của các hệ số hồi quy không chệch,nhưng không hiệu quả (tức chưa phải là tốt nhất), dẫn đến ước lượng của các phương sai bị chệch, nên kiểm định các giả thuyết bị mất hiệu lực àđánh giá nhầm chất lượng mô hình. Thưc hiện Bước 1 : Tạo 2 biến Phần dư và Giá trị dự đoán. Bước 2 : Lấy trị tuyệt đối của phần dư bằng lệnh compute, đặt tên là TTĐ Bước 3 : Phát biểu giả thuyết Ho: hệ số tương quan hạng của tổng thể = 0 Bước 4 : Kiểm định tương quan hạng cho 2 biến TTĐ và Biến Phụ thuộc Bước 5 : KL nếu không bác bỏ được Ho (sig > >), thì Phương sai không đổi. c. Kiểm Định Giả Thuyết Về Phân Phối Chuẩn Của Phần Dư Thực hiện : (dùng history hay Q_Qplots dều được) Bước 1 : thực hiện hồi quy và lưu lại biến phần dư chuẩn hóa Bước 2 : vẽ biểu đồ History : Graph à History à đưa biến phần dư vào ô Variable, nhấp chọn ô Display normal curve. Bước 4 : kết luận, nếu Mean= 0,00 và Std.Dovà 1 thì kết luận là PPC. d. Kiểm Định Giả Thuyết Về Tính ĐA CỘNG TUYẾN Thực hiện : Bước 1 : Chạy hàm hồi quy ,nhưng trước khi nhấn OK, hãy nhấn vào Nút Statistics và chọn COLLINEARITY DIAGNOSTICS

Bước 2 : Kết luận : Nếu Độ chấp nhận nhỏ hay VIF > 10 thì có đa cộng tuyến. Summary: Các xử lý thống kê thông dụng trong SPSS SPSS. SPSS (Statistical Package for Social Sciences) là phần mềm xử lý thống kê dùng trong các ngành khoa học xã hội, được phát triển dựa trên phần mềm của Apache Software Foundation. Đây là phần mềm chuyên dụng, do vậy mà việc sử dụng cũng đòi hỏi sự chuyên nghiệp. Phải mua và cài đặt chương trình, khai báo biến. Thích hợp cho xử lý các biến định tính. * Khởi động SPSS tương tự các chương trình trong windows, Programs\SPSS for Windows\ SPSS for Windows Sau khi khởi động sẽ thấy màn hình nhập dữ liệu tương tự như Excel nhưng chỉ có 2 sheet (data view và variable view). * Trước khi tiến hành phân tích cần nhập dữ liệu, có 3 cách: Mở data file đã có (*.sav). Đọc từ bảng tính (*.xls), từ CSDL(*.mdb), từ Text file (*.txt). Nhập trực tiếp. Trước khi nhập cần xác định các trường dữ liệu như các CSDL, vào variable view để khai báo, đã có sẵn các trường (name, type, width, decimals, label, values, missing, columns, align(left, right, center), measure (scaler- số đếm- thang đo định lượng, ordinal- thang đo thứ bậc, nominalthang đo danh nghĩa, vùng, khu vực)) tùy yêu cầu khai báo cho phù hợp. Sau khi đã khai báo, nhập tương tự Excel. * Tutorial Chứa trong Help, hướng dẫn đầy đủ các bước sử dụng SPSS với bộ dữ liệu demo. Để biết nội dung chi tiết của các tham số trong mỗi tùy chọn, nhấn help * Một số phân tích thống kê thông dụng của SPSS Analyze\ Descriptive Statistics\... Frequencies... (tần suất)

Đây là công cụ thường được dùng tóm lược thông tin về phạm vi và cấp độ của biến tại 1 thời điểm; dùng tóm lược thông tin và chuẩn hóa về phạm vi của biến Dùng Frequencies có thể là một lựa chọn để tóm tắt phạm vi biến; cung cấp thống kê để tóm tắt cấp độ của biến Descriptives: tập trung vào phạm vi của biến và cung cấp việc lưu giữ giá trị chuẩn hóa (z scores) của biến. Crosstabs: cho phép có được thông tin tóm tắt về mối liên hệ giữa 2 biến. Means: cung cấp thống kê mô tả và bảng ANOVA để nghiên cứu mối liên hệ giữa phạm vi và cấp độ của các biến. Summarize: cung cấp thống kê mô tả và thông tin tóm tắt của sự kiện để nghiên cứu mối liên hệ giữa phạm vi và cấp độ của các biến. OLAP cubes: cung cấp thống kê mô tả để nghiên cứu mối liên hệ giữa phạm vi và cấp độ của các biến. Correlations: cung cấp mô tả tóm tắt mối liên hệ giữa phạm vi 2 biến Khi thực hiện phân tích, nếu dữ liệu chưa được mở, SPSS yêu cầu mở, chọn CSDLcần phân tích, Hình 1 Phân tích tần xuất: chọn các biến cần phân tích chuyển vào Variable. Hình 2 Statistics... Hình 3

Hình 4 Chọn các tham số thống kê tùy yêu cầu, bằng cách đánh dấu vào ô chọn. gồm 4 nhóm: + Giá trị phân vị (điểm tứ phân vị, điểm cắt chia khoảng, phân vị ); + Độ phân tán (độ lệch chuẩn, phương sai, khoảng biến thiên, max, min);

+ Xu hướng trung tâm (kỳ vọng, trung vị, mod, tổng); + Sự phân bố (độ nghiêng (hệ số bất đối xứng), độ nhọn). Continue Chart\ Chọn đồ thị thể hiện (dạng, giá trị thể hiện). Continue Format\ Định dạng báo cáo (sắp xếp dữ liệu, nhiều biến). Continue, OK. Descriptives...(thống kê mô tả) Hình 5

Hình 6 chọn các biến và tham số trong option tương tự như phần trên.

Explore (khảo sát, thăm dò): thường dùng trong ước lượng khoảng tin cậy của kỳ vọng, nhận biết các dữ liệu ngoài nhóm; kiểm tra giả thuyết; đặc điểm khác biệt trong nhóm các biến cố. Chọn các biến vào danh sách phù hợp (bảng phụ thuộc, bảng nhân tố, nhãn trường hợp),

Hình 7 Trong thống kê chọn (khoảng tin cậy (%), ước lượng Mean, giá trị ngoại lệ, phân vị). Hình 8 Hình 9 Trong biểu đồ chọn (biểu đồ khối, mô tả, biểu đồ kiểm định). Tuỳ chọn báo cáo.

Crosstabs (bảng tra chéo): là kỹ thuật cơ bản để nghiên cứu mối liên hệ giữa hai cấp độ của biến. Thường dùng để kiểm tra sự độc lập và đo lường về sự liên hệ và chấp thuận của các dữ liệu.

Chọn dòng, cột.

Hình 10 Exact: Kiểm định đúng(tiệm cận, mức tin cậy Monte Carlo (99%), đúng - thời gian kiểm định). Thống kê gồm nhiều tham số thông thường ít dùng. - Ratio: tỷ lệ. Chọn tử số và mẫu số từ các biến. Thường ít dùng. Analyze\ Compare Means\... -Mean\ chọn các biến phụ thuộc và độc lập . Hình 11 Trong option chọn các tham số thống kê theo yêu cầu, continue\OK .

3 dạng t-Test. Hình 12

Hình 13

Hình 14

Hình 15 Tùy yêu cầu chọn biến thích hợp chuyển vào test variable, chọn option và OK.

Phân tích phương sai (ANOVA) Hình 16

Chọn contrast (đối chiếu), dạng đa thức, hệ số tương quan, continue . Post hoc: chọn với giả thiết cùng (hoặc khác) phương sai, continue.. Hình 17

- LSD (Least Significant Difference): dùng kiểm định t để thực hiện tất cả các so sánh cặp giữa các trung bình nhóm, tương đương với việc thực hiện tất cả các kiểm định bội t giữa các cặp nhóm. Không có điều chỉnh tỷ lệ sai số khi so sánh bội. - Bonferroni: loại kiểm định LSD cải tiến, có sự kiểm tra tất cả các tỷ lệ sai số bằng cách cho trước sai số tỷ lệ cho mỗi kiểm định. - Sidak: kiểm định so sánh nhiều cặp, sử dụng t statistic, giới hạn chặt hơn so với Bonferroni. - Scheffe: so sánh cặp cùng lúc cho tất cả các kết hợp theo cặp có thể có của các trị trung bình. Dùng thống kê mẫu F. kém nhạy trong so sánh trung bình của các cặp biến. - R-E-G-W F (Ryan-Einot-Gabriel-Welsch): thủ tục giảm áp dùng F test. -R-E-G-W Q (Ryan-Einot-Gabriel-Welsch) thủ tục giảm áp dùng Studentized range. - S-N-K (Student-Newman-Keuls): thực hiện tất cả các so sánh cặp giữa các trung bình. Nếu cỡ mẫu bằng nhau hoặc trung bình các nhóm được chọn thì so sánh cặp trung bình trong nội bộ các nhóm cùng loại. Trị trung bình được xếp giảm dần, các sai khác lớn sẽ được kiểm định trước. -Tukey( Tukey's honestly Significant Difference): dùng Studentized range statistic để tiến hành các so sánh cặp giữa các nhóm. Thiết lập các tỷ lệ sai số thử nghiệm cho việc tập hợp các so sánh cặp. - Tukey's b: thủ tục thay thế của Tukey, giá trị tối ưu là trung bình của giá trị thích hợp cho kiểm định Tukey và kiểm định S-N-K. - Duncan : tạo các so sánh cặp tương tự S-N-K, thiết lập mức bảo vệ cho tỷ lệ sai số của kiểm định lựa chọn. Dùng Studentized range statistic. - Hochberg's GT2: sa sánh bội tương tự. - Gabriel: kiểm định so sánh cặp dùng Studentized modulus tổng quát hơn Hochberg's GT2 khi kích thước mẫu khác nhau. - Waller-Duncan: kiểm định so sánh bội dùng t statistic; sử dụng ước lượng Bayes. - Dunnett: kiểm định t so sánh nhiều cặp. - Tamhane's T2: kiểm định so sánh cặp thận trọng dùng t test. - Dunnett's T3: kiểm định so sánh cặp dùng Studentized modulus - Games-Howell: kiểm định so sánh cặp đầy đủ. - Dunnett's C: kiểm định so sánh cặp dùng Studentized range.

Option: chọn các tham số thống kê, continue . Hình 18 Analyze\ nonparametric tests\... Các kiểm định phi tham số ChiSquare... Hình 19 Hình 20

Hình 21 Kiểm định pháp tuyến (binominal test) tương tự Chi-Square Comments, questions, feedback, criticisms? SPSS Là phần mềm chuyên dụng xử lý thông tin sơ cấp - thông tin được thu thập trực tiếp từ đối tượng nghiên cứu. Thông tin được xử lý là thông tin định lượng (có ý nghĩa về mặt thống kê).Phần mềm SPSS có tất cả 4 dạng màn hình: Data view : Màn hình quản lý dữ liệu Là nơi lưu trữ dữ liệu nghiên cứu với một cấu trúc cơ sở dữ liệu bao gồm cột, hàng và các ô giao nhau giữa cột và hàng Variables view : Màn hình quản lý biến Là nơi quản lý các biến cùng với các thông số liên quan đến biến như: Name (Tên biến) : Là tên đại diện cho biến, tên biến này sẽ được hiễn thị trên đầu mỗi cột trong màn hình dữ liệu Type (Loại biến ): Có dạng số và dạng chuỗi Label (Nhãn của biến): Tên biến chỉ được thể hiện tóm tắc bằng ký hiệu, nhãn của biến cho phép nêu rõ hơn về ý nghĩa của biến. Values (Giá trị trong biến ): Cho phép khai báo các giá trị trong biến với ý nghĩa cụ thể (nhãn giá trị)

Missing (Giá trị khuyết): SPSS mặc định giá trị khuyến (system missing) là một dấu chấm và tự động loại bỏ các giá trị này ra khỏi các phân tích thống kê. Measures (Dạng thang đo): Hiễn thị dạng thang đo của giá trị trong biến Màn hình hiễn thị kết quả (output): Các phép phân tích thống kê sẽ cho ra các kết quả như bảng biểu, đồi thị và các kết quả kiểm nghiệm, các kết quả này sẽ được truy xuất ra một màn hình, và được lưu giữ dưới một tập tin khác (có đuôi là .SPO). Màn hình này cho phép ta xem và lưu giữ các kết quả phân tích. Màn hình cú pháp (syntax): Màn hình này cho phép ta xem và lưu trữ những cú pháp của một lệnh phân tích. Các cú pháp được lưu trữ sẽ được sử dụng lại mà không cần thao tác các lệnh phân tích lại. 1. Tạo biến và nhập dữ liệu trên SPSS Tạo biến trong màn hình quản lý biến : Nhấp vào Variables view Name: Gõ tên biến cần khai báo Type: Kiểu biến Variable Label: Đặt tên nhãn cho biến một cách đầy đủ hơn Value lables : Định tên cho các giá trị trong biến Missing Values: Được dùng để định ra các giá trị cụ thể cho các giá trị mà ta muốn loại bỏ ra khỏi các phân tích và xử lý thống kê Column: Định ra chiều rộng của cột đang khai báo biến Align: Canh lề Measurement: Chọn loại thang đo Nhập dữ liệu Nhập trực tiếp trên sps hay cũng có thể nhập liệu từ các phần mềm khác như Excel, Fox, … và sau đó chuyển vào trong SPSS thông qua Menu openFile Công cụ tính toán giữa các biến (Compute)

Công cụ compute được dùng để tính toán giữa các giá trị trong các biến và kết quả sẽ được lưu giữ trong một biến mới hoặc là một biến khác sẳn có hoặc biến chứa đựng giá trị đang tính toán. Để thực hiện công cụ Compute : Xuất hiện:này ta vào Menu Transform Mục Target variable : Tên biến sẽ nhận giá trị được tính Ô Numeric Expressionn: chứa các biểu thức số được dùng để tính giá trị cho biến mới. Chúng ta có thể soạn các biểu thức tính toán vào thẳng ô Numeric Expression, và có thể sữ dụng các công cụ được hiển thị trong hộp thoại như các phiếm (+), (-), Function,… Công cụ if : Dùng để định ra những điều kiện cần thiết kèm theo trong tính toán nếu có 2. Xử lý và phân tích dữ liệu Kiểm tra dữ liệu (Explore) SPSS cung cấp cho công cụ Explore để xem xét và kiểm tra dữ liệu: Phát hiện các sai sót Nhận dạng dữ liệu để tìm phương pháp phân tích thích hợp và chuẩn bị cho việc kiểm tra giả thuyết Explore… để mở hộp thoại Explore như hình sau:DescriptiveStatisticĐể kiểm tra dữ liệu, chọn trên menu Analyze Dependent list: Đưa các biến cần kiểm tra vào đây. Display : Cho phép chúng ta chọn cách hiễn thị kết quả. Statistics : Cho phép ta lựa chọn các thống kê hiễn thị như : Descriptives : Hiễn thị các giá trị thống kê như giá trị trung bình, khoảng tin cậy, trung vị, trung bình giãn lược, giá trị nhỏ nhất, lớn nhất, khoảng biến thiên, các bách phân vị M-estimators: Hiễn thị các giá trị trung bình theo 4 loại trọng số Outliers: Hiễn thị các quan sát có 5 giá trị nhỏ nhất và 5 giá trị lớn nhất, gọi là Extreme Values Percentiles: Hiển thị các giá trí bách vị phân Kiểm nghiệm Kolmogorov-Smirnov (Lilliefors) Kiểm nghiệm Kolmogorov-Smirnov, dùng để kiểm nghiệm tính chuẩn tắc của một mẫu hay hai mẫu.

Kiểm nghiệm Levene Kiểm nghiệm Levene là phép kiểm nghiệm tính đồng nhất của phương sai. Ở đây ta kiểm nghiệm giả thuyết cho rằng phương sai của giữa các mẫu quan sát là bằng nhauLập bảng phân bố tần suất cho biến một trả lời (Frequencies) 3. Kiểm Định Mối Liên Hệ a. Kiểm định mối liên hệ giữa hai biến Định danh-định danh,định danh-định thức (H o : hai biến không có liên hệ gì với nhau) Người ta dùng Kiểm định Chi-square để kiểm tra xem liệu một biến này có quan hệ hay không với một biến khác, tuy nhiên phương pháp kiểm nghiệm này không chỉ ra cường độ của mối quan hệ giữa hai biến mạnh hay yếu giữa 2 biến, các hệ số trong kiểm nghiệm Chi_square như sau: Hệ số Pearson Chi-square và Likelihood Ratio cho biết có mối liên hệ giữa hai biến định tính hay không (sig rất nhỏ) Hệ số Linear-by-linear association Đo lường mối liên hệ tuyến tính giữa hai biến.(hữu dụng khi hàng cột xếp theo thứ tự tăng dần) Chỉ số Continuity Correction đánh giá mối tương quan giữa hai biến (dạng 2 x 2)trong bảng. Cách thực hiện CrosstabDescriptive Statiticstrong SPSS: vào Analyze Hiện hộp thoại, trong đó ta đưa hai biến cần kiểm tra vào 2 ô : Row và Column sau đó nhấn ok là xong. Ta có thể vào trong phần Statistic để chọn các thông số thống kê: Nornimal: dùng cho 2 biến định danh. Ordinal : dùng cho 2 biến dạng thứ bậc. Trong phần Cells: tương tự, hãy vào mà khám phá nó. b. Kiểm định mối liên hệ giữa hai biến Thứ Bậc Phát biểu giả thuyết Ho : không có mối liên hệ nào giữa các biến trong tổng thể Crosstab,Descriptive StatiticsThực hiện trong SPSS : Analyze Đưa biến vào 2 ô : Row và Column , nhấn vào Statistics và chọn : Chi square, correlation, gamma, somer’s , tau_b..

c. Kiểm định mẫu đang xét có là phân phối chuẩn không Phát biểu giả thuyết Ho : Độ sai lệch của tổng thể 2 giá bất động sản là phân phối chuẩn(tức giá trị dự báo đáng tin cậy). Ứng dụng : Kiểm định này dùng để kiểm định giả thuyết phân phối của dữ liệu có phù hợp với phân phối lý nthuyết .nó tiến hành xem xét các sai lệch giữa Giá trị cũ và giá trị mới của bất động sản, sai lệch tuyệt đối càng lớn ,giả thuyết Ho càng dễ bị bác bỏ. Cách thực hiện: Compute , hiện hộp thoại:Bước 1: Transform Nhập tên biến mới vào khung : Target Variabel Khung Numberic Expression : ta nhập : giáBĐS_dựBáo – Giá BĐScũ Sau đó nhấn ok. 1 _ sample K S xuất hiện hộp thoại sau:Nonparametric TestBước 2 : Analyze Đưa biến mới tạo bước 1 vao khung Test Variable List Phần Test Distribution : ta chọn loại phân phối chuẩn ( Normal ) , nhấn OK là xong. 4. Tương Quan Ở phần trước chúng ta đã dùng một số công cụ để đo lường mối liên hệ giữa các biến với nhau. Tuy nhiên kỷ thuật đó chủ yếu dùng cho dữ liệu định tính.Còn đối với các dữ liệu định lượng ta thường dùng hệ số tương quan R., hay biểu đồ phân tán Scatter. a. Xác định hệ số tương quan: Chọn Bivarlate , xuất hiện hộp thoại : chọn CorrelateCách thực hiện trên SPSS : Vào menu Analyze Khung Variables : ta đưa các biến cần xét mối tương quan vào. Khung Correction Coefficients : chọn Person và Spearman Nhấn vào Option để giải quyết các trường hợp thiếu số liệu của biến đại khái như sau: Phần Statisc : khai báo có tính hay không tính Trung bình_độ lệch chuẩn và tổng tích các môdun chéo_hiệp phương sai. Phần Misssing Value : khai báo xử lý các trường hợp thiếu của biến

Exclude case pairwise : xử lý từng cặp, loại giá trị thiếu ra khỏi cặp so sánh,nhưng vẫn dùng cho cặp khác nếu với cặp khác nó không thiếu. Exclude case listwise : mẫu nào thiếu giá trị sẽ bị SPSS loại hẳn ra khỏi cuộc chơi. b. Vẽ biểu đồ Scater Ý nghĩa của biểu đồ : Biểu đồ này cũng có mục đích giúp ta có cái nhìn trực quan về mối liên hệ giữa các biến.Nếu như Hệ số hồi quy R cho ta biết giữa hai biến đó có tương quan không, trường hợp các biến có tương quan thì không nói, nhưng nếu kết quả R cho thấy các biến không có liên hệ với nhau thì lúc này Biểu đồ Scatter sẽ cho ta biết "sự không có mối tương quan giữa các biến" là thật sự vì chúng hoàn toàn độc lập nhau, hay chúng không có mối liên quan bỡi vì chúng không có mối liên hệ tuyến tính mà chúng sẽ liên hệ theo một loại quan hệ nào đó, phi tuyến chẳng hạn. Cách thực hiện : chọn Scatter..--Vào menu Graphs > Chọn Define , xuất hiện hộp thoạiChọn simple Đưa 2 biến cần vẽ, một vào Y_axis, một vào X_axis Title : dùng để đặt tiêu đề, ghi chú cho biểu đồ Option : dùng để khai báo cách xử lý những giá trị thiếu của biến quan sát. 5. Hồi Quy Tuyến Tính Ý nghĩa : Qua một loạt các kiểm tra, nếu kết luận được các biến có liên quan tuyến tính hay có liên quan phi tuyến với nhau. Thì bước tiếp theo chúng ta tiến hành xây dựng hàm hồi quy. Hàm hồi quy này có ý nghĩa cho chúng ta biết sự đóng góp của từng biến trong biến phụ thuộc hay nói cách khác giá trị của biến phụ thuộc đóng góp bao nhiêu phần trăm trong tổng giá trị của biến phụ thuộc, và nó còn cho chúng ta biết sự thay đổi một đơn vị của nó,sẽ kéo theo sự thay đổi của biến phụ thuộc là bao nhiêu. Cách thực hiện : Linear…, hiện hộp thoại: Regression Vào menu Analyze Khung Dependent : Đưa biến mà ta muốn nó làm biến phụ thuộc vào Khung Independent : Đưa các biến độc lập vào đây. Phần method : lựa chọn phương pháp đưa biến vào: Enter : đưa một lượt các biến vào một lúc.

Remove: loạt tất cả các biến ra khỏi hàm 1 lượt, tất nhiên đầu tiên phải đưa các biến vào trước mới có cái để gỡ ra chứ. Forward : Phương pháp đưa vào dần ,biến 1 được đưa vào là biến có tương quan lớn nhất,nếu thỏa tiêu chuẩn vào : FIN hay PIN, thì biến tiếp theo được đưa vào…..Quá trình này dừng lại khi không còn biến nào thỏa tiêu chuẩn vào. Backward : Loại trừ dần từng biến ra khỏi mô hình, đầu tiên biến ít liên quan nhất sẽ được đưa ra khỏi mô hình theo tiêu chuẩn "Loại Trừ: FOUT hay POUT".Quá trình này dừng lại khi giá trị F của biến có hệ số tương quan nhỏ nhất > FOUT. Stepwise : Chọn dần từng bước.Đây là phương pháp kết hợp của 2 phương pháp Forward và Backward (Điều kiện để cho các biến không bị đưa ra rồi đưa vào lập lại thì ta chọn :FIN>FOUT hay PIN<POUT) Nút Statistics..: chọn các thông số thống kê như sau : Estimates: các ước lượng như: hệ số hồi quy(B),sai số chuẩn (B), giá trị t và Sig. Confidence interval : Khoảng tin cậy. Covariance Matrix : Ma trận hiệp phương sai. Mode Fix : Thể hiện các thống kê đánh giá mức độ phù hợp của mô hình : R, R2, R2 điều chỉnh,sai số chuẩn.. Descriptives : các thống kê mô tả như : trị trung bình, độ lệch chuẩn, ma trận tương quan. R squared chance : Xem xét mức độ tăng của R2 khi đưa thêm 1 biến độc lập vào mô hình. Colinearity diagnostics : Chuẩn đóan hiện tượng CỘNG TUYẾN Nút Plots.. : Dùng để vẽ đồ thị hồi quy tuyến tính. Khung bên trái chứa : biến phụ thuộc, các dạng biến phần dư, các dạng biến dự đoán ý nghĩa của chúng : *ZPRED : Giá trị dự đoán chuẩn hóa *ZRESID : Phần dư chuẩn hóa *DRESID : phần dư loại bỏ quan sát đang xét *ADJPRED:Giá trị dự đóan điều chỉnh *SRESID : Phần dư student hóa

*SDRESID : phần dư loại bỏ quan sát đang xét được student Produce all patial plots : biểu đồ phân tán từng phần. Histogram : biểu đồ tần số. Normal Probability plot: biểu đồ xác suất chuẩn. Nút Save : Lưu một biến mới tự động tạo ra trong phân tích SPSS như các phần dư, giá trị dự đoán… Phần Predicted Value(các giá trị dự đoán như) : Giá trị dự đóan không chuẩn hóa,dự đóan chuẩn hóa, dự đóan điều chỉnh, sai số chuẩn của các giá trị dự đoán. Phần Distances( khoảng cách) : Dùng để nhận diện các quan sát có ảnh hưởng mạnh đến kết quả phân tích, nó là khoảng cách từ giá trị quan sát đến giá trị trung bình. Prediction interval (khoảng dự đoán) : Mean : giới hạn trên dưới của khoảng dự đoán của trị trung bình. Individual : giới hạn trên dưới khoảng dự đoán của từng quan sát. Residual (phần dư) : Gồm phần dư không chuẩn hóa, có chuẩn hóa, student hóa, (detecd : phần dư loại bỏ quan sát đang xét).. Influence Statistics : các thông số thống kê ảnh hưởng DfBeta(s) : SPSS sẽ tính lại toàn bộ các hệ số hồi quy,khi loại bỏ 1 quan sát. Standardized DfBeta(s) : Tính các DfBeta(s) chuẩn hóa. DfFit : phản ánh thay đổi của giá trị dự đoán khi loại bỏ 1 quan sát. Standardized DfFit : tính các DfFit chuẩn hóa. Covariance ratio : tính tỷ số giữa các thành phần của ma trận hiệp phương sai sau và trước khi loại bỏ 1 quan sát.nếu 1 ,quan sát bỏ không ảnh hưởng nhiều đến ma trận hiệp phươngtỷ số sai. Nut Option : Thiết lập mặc định cho SPSS. Stepping Method Criteria : Tiêu chuẩn vào và ra áp dụng cho các phương pháp. Use probability of F : Sử dụng xác suất vào (PIN) và ra ( POUT).

Use F value : sử dụng F làm tiêu chuẩn vào (FIN), ra (FOUT). Missing value : Lựa chọn cách xử lý các quan sát bị thiếu. Exclude case listwise : chỉ những biến đủ giá trị mới được xử lý. Exclude case pairwise Qastnào đủ gitrị trong 1 cặp đang nghiên cứu sẽ được xử lý để tính hệ số tương quan. Relace with mean : thay thế giá trị thiếu bằng trung bình của biến. Hộp kiểm Include constant in equation : xây dựng mô hình hồi quy có chứa hệ số hay không. 6 . Ứng Dụng Của Mô Hình Hồi Quy Một trong các ứng ụng của mô hình hồi quy đó là dự đóan ,chúng ta có thể dự đóan giá trị trung bình Y trong trường hợp biêt được các giá trị X, hay tiên đoán giá trị Y trong một trường hợp cụ thể tại giá trị Xo nào đó.(cả 2 trường hợp này kết quả dự đoán như nhau, tuy nhiên sai số chuẩn khác nhau). Cách thực hiện dự đóan trên SPSS : Linear , đưa các biến cần xây dựng Regression Vào menu Analyze vào mô hình, sau đó nhấn vào nút SAVE ,đánh dấu chọn vào cáo ô nhấn OK. nhấn Continue Unstandadized , standadized, Adjust. 7. Dò Tìm Sự Vi Phạm Các Giả Định Cần Thiết Trong Hồi Quy Việc chúng ta làm từ đầu đến giờ cũng thật sự chưa thuyết phục lắm, do đó để tạo sự tin tưởng hoàn toàn vào kết quả của hàm, ta lần lượt đi kiêm định, dò tìm thử có giả thuyết nào bị vi phạm trong mẫu của chúng ta không. Ta cần kiểm tra một số như : Giả định tuyến tính có phù hợp không, giả định phương sai không đổi, giả định về phân phối chuẩn của phần dư, giả định về tính độc lập của sai số( không có sự tương tác giữa các phần dư),giả định không có sự tương quan giữa các biến độc lập( Đo lường Đa cộng tuyến), a. Kiểm Định Giả Thuyết Liên Hệ Tuyến Tính: Loại này Kiểm tra bằng cách vẽ đồ thị phân tán giưa các Phần Dư và Giá trị dự đoán đã chuẩn hóa. Bước 1 : tạo 2 biến Phần dư (standardized residual) và Giá trị dự đoán (Standardized predicted ) Bước 2 : Vẽ biểu đồ Scatter cho 2 biến này Bước 3 : kết luận như sau : Nếu giả định tuyến tính đúng thì phần dư rải ngẫu nhiên không theo một quy luật nào, ngược lại, giả định bị vi phạm.

b. Kiểm Định Giả Thuyết Phương Sai Không Đổi :có thể dùng kiểm định White,Glesjer, tuơng quan hạng Speaman. Nếu phương sai thay đổi sẽ tạo ra rất nhiều hậu quả tai hại,nó làm cho các ước lượng của các hệ số hồi quy không chệch,nhưng không hiệu quả (tức chưa phải là tốt nhất), dẫn đến ước lượng của các phương sai bị chệch, nên kiểm định các giả thuyết bị mất hiệu lực đánh giá nhầm chất lượng mô hình. Thưc hiện Bước 1 : Tạo 2 biến Phần dư và Giá trị dự đoán. Bước 2 : Lấy trị tuyệt đối của phần dư bằng lệnh compute, đặt tên là TTĐ Bước 3 : Phát biểu giả thuyết Ho: hệ số tương quan hạng của tổng thể = 0 Bước 4 : Kiểm định tương quan hạng cho 2 biến TTĐ và Biến Phụ thuộc Bước 5 : KL nếu không bác bỏ được Ho (sig > >), thì Phương sai không đổi. c. Kiểm Định Giả Thuyết Về Phân Phối Chuẩn Của Phần Dư Thực hiện : (dùng history hay Q_Qplots dều được) Bước 1 : thực hiện hồi quy và lưu lại biến phần dư chuẩn hóa đưa biến phần dư vào ô Variable, nhấp chọn ô Display normal curve. History Bước 2 : vẽ biểu đồ History : Graph 1 thì kết luận là PPC.Bước 4 : kết luận, nếu Mean= 0,00 và Std.Dov d. Kiểm Định Giả Thuyết Về Tính ĐA CỘNG TUYẾN Thực hiện : Bước 1 : Chạy hàm hồi quy ,nhưng trước khi nhấn OK, hãy nhấn vào Nút Statistics và chọn COLLINEARITY DIAGNOSTICS Bước 2 : Kết luận : Nếu Độ chấp nhận nhỏ hay VIF > 10 thì có đa cộng tuyến.

You're Reading a Free Preview

Tải về
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->