You are on page 1of 4

The School of

Computing
Engineering and
Information Sciences

EN0717
Laboratory 5

Configuration of a Campus Network

Objective
In this lab, each group of four students will work to create one section of a larger campus-style network. VLANs, VTP,
Etherchannel and InterVLAN routing using MLS will all be incorporated. By configuring a larger network in sections
you will learn more about how a real-life network is configured, and explore the differences between a traditional
routed network and a network using MLS devices.

Scenario
Each team will configure one-fifth of the network as shown in Figure 1 below.

VLAN10

VLAN100

ROW 1

VLAN20

VLAN100

ROW 2

VLAN30

VLAN100

VLAN40

ROW 3

VLAN100

ROW 4

VLAN50

VLAN100

ROW 5

Figure 1
The core-layer switch at the top of the diagram is under common administration.

Step 1 Initialisation and Switch Naming


Configure your rows network as shown in the diagram above. The access layer switch should be a 2950 and the
distribution layer switch MUST be a 3550. Connect PC1 (on VLAN 10/20/30/40/50 depending on your row) to Fa0/1
on the 2950 switch, and PC2 to Fa0/2. There are two trunk connections between the 2950 and 3550, you should connect
these to Fa0/11 and Fa0/12 on both sides of the two trunks. The connections between the 3550 and the core switch
should be connected to Fa0/9 and Fa0/10 on the 3550, and to two adjacent ports on the core switch.
Remember to erase all config from your 2950 and 3550 before you start.
The 2950 and 3550 switches are to be named as follows:
2950: alsX, where X is the row number.
3550: mlsX, where X is the row number.

Step 2 VLAN Assignment / VTP Configuration

/var/www/apps/conversion/tmp/scratch_1/153903752.doc

Page 1 of 4

The School of
Computing
Engineering and
Information Sciences

EN0717
Laboratory 5

Configuration of a Campus Network


Configure the VLANs for your row only on the MLS (3550) switch.
Set up a VTP domain on your row called rowX. The MLS should be set as the VTP server, with the ALS being the
client. For row 3 this would be:
ml3(config)#vtp mode server
ml3(config)#vtp domain row3
al3(config)#vtp mode client
al3(config)#vtp domain row3
Where X is the row number.
Verify that each switch can now see both VLANs for your row with show vlan brief. Verify the VTP
configuration with show vtp status.
Place your two PCs in the correct VLANs on the ALS switch.

Step 3 IP Addressing
The IP configuration details are as follows.
PC: IP address 192.168.V.100+X, Subnet Mask 255.255.255.0, Default Gateway 192.168.V.200+X
MLS: IP address 192.168.V.200+X, Subnet Mask 255.255.255.0 for EACH VLAN you have configured on your
row (so row 1 has VLANs 10 and 100, row 2 has VLANs 20 and 100 and so on).
Where: V is the VLAN ID, and X is the row number.
So for row 2, you have VLANs 20 and 100 set up. Your PCs will be set up as follows.
Device
PC1
PC2
MLS

IP Address
192.168.20.102
192.168.100.102
192.168.20.202 (VLAN 20)
192.168.100.202 (VLAN 100)

Subnet Mask
255.255.255.0
255.255.255.0
255.255.255.0

Default Gateway
192.168.20.202
192.168.100.202

Step 4 Inter-VLAN Routing


Configure the MLS to allow inter-VLAN routing. For the MLS on Row 2, this configuration would be:
interface vlan 20
ip address 192.168.20.202 255.255.255.0
no shut
interface vlan 100
ip address 192.168.100.202 255.255.255.0
no shut
ip routing
Configure RIP on the MLS, to allow routing to other local VLANs. Use RIP version 2. E.g. On Row 2,

/var/www/apps/conversion/tmp/scratch_1/153903752.doc

Page 2 of 4

The School of
Computing
Engineering and
Information Sciences

EN0717
Laboratory 5

Configuration of a Campus Network


router rip
version 2
network 192.168.100.0
network 192.168.20.0
This will advertise the end-to-end VLAN 100, and also the local VLAN 20. For other rows, use your own local VLAN.

Step 5 Etherchannel Setup


Configure Etherchannel on the two switches. The connection between the ALS and the MLS should be an LACP
Etherchannel, and should the connection should be set to active on the MLS and passive on the ALS. I.e. if you have set
up the Etherchannel between the ALS and MLS on ports fa0/11 and fa0/12 on both sides, enter:
als1(config)#interface range fa0/11 12
als1(config-if)#switchport mode trunk
als1(config-if)#channel-group 1 mode passive
mls1(config)#interface range fa0/11 12
mls1(config-if)#switchport trunk encapsulation dot1q
mls1(config-if)#switchport mode trunk
mls1(config-if)#channel-group 1 mode active
Verify that the Etherchannel is configured with show etherchannel summary on both sides of the link. What is
the Etherchannel called? What are the letters in parentheses (brackets)? What do they mean?
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
Now configure the connection between the core switch and your MLS. This should be a PAGP Etherchannel, and the
MLS should be set to dynamic auto mode with the core switch set to dynamic desirable. Replace 1-2 on the core switch
with the ports on the core switch that your MLS is connected to.
mls1(config)#interface range fa0/9 10
mls1(config-if)#switchport trunk encapsulation dot1q
mls1(config-if)#switchport mode trunk
mls1(config-if)#channel-group 2 mode auto
core(config)#interface range fa0/Y Z
core(config-if)#switchport mode trunk
core(config-if)#channel-group X mode desirable
(Where X is your row number, Y is the first connection you are using for the Etherchannel on the core switch, and Z is
the second note that the channel group number does not need to match on either side of the Etherchannel).
Verify the configuration using show etherchannel summary on both sides of the link. What is this second
Etherchannel called? What are the letters in parentheses (brackets)? What do they mean?
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________

/var/www/apps/conversion/tmp/scratch_1/153903752.doc

Page 3 of 4

The School of
Computing
Engineering and
Information Sciences

EN0717
Laboratory 5

Configuration of a Campus Network

Step 6 Testing the Network


Ensure that you can ping PC1 from PC2.
When another group has completed the configuration, you will see their VLAN information in the routing table using
show ip route RIP should learn about the other VLANs.
What is the common interface connecting all the MLS switches?
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
When you run a trace between your PC1 and another teams PC2 (VLAN 100), how many hops do you think will be
required to get to the other PC (there are two routing devices between your PC1 and their PC2)?
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
When you run a trace between your PC1 and another teams PC1, how many hops do you think will be required to get
to the other PC (again there are two routing devices between your PC1 and their PC1)?
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
Try to run the traces. What happens?
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
Can you explain why there are sometimes fewer hops than would be expected with a router-based network?
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________
________________________________________________________________________________________________

/var/www/apps/conversion/tmp/scratch_1/153903752.doc

Page 4 of 4

You might also like