You are on page 1of 9

1/20/14

LVM (Logical Volume Manager): LVM manages the storage to have a structured overview of it.

AIX for System Administrators

/var/adm/ras/lvmcfg.log lvm log file shows what lvm commands were used (alog -ot lvmcfg) alog -ot lvmt shows lvm commands and libs The LVM consists of: -high level commands: can be used by users, e.g.: mklv (this can call an intermediate level command) -intermediate level commands: these are used by high-level commands, e.g. lcreatelv (users should not use these) -LVM subroutine interface library: it contains routines used by commands, e.g. lvm_createlv -Logical Volume Device Driver (LVDD): manages and processes all I/O; it is called by jfs or lvm library routines -Disk Device Driver: It is called by LVDD -Adapter Device Driver: it provides an interface to the physical disk This shows how the execution of a high level command goes through the different layers of LVM :

LOGICAL VOLUME After you create a volume group, you can create logical volumes within that volume group. Logical partitions and logical volumes make up the logical view. Logical partitions map to and are identical in size to the physical partitions. A physical partition is the smallest unit of allocation of disk where the data is actually stored. A logical volume is a group of one or more logical partitions that can span multiple physical volumes. All the physical volumes it spans must be in the same volume group. A logical volume consists of a sequence of one or more logical partititons. Each logical partition has at least one and a maximum of three corresponding physical partitions that can be located on different physical volumes. When you first define a logical volume, the characteristics of its state (LV STATE) will be closed. It will become open when, for example, a file system has been created in the logical volume and mounted. It is also possible that you might want to create a logical volume and put nothing on it. This is known as a raw logical volume. Databases frequently use raw devices Logical Volume types: - log logical volume: used by jfs/jfs2 - dump logical volume: used by system dump, to copy selected areas of kernel data when a unexpected syszem halt occurs - boot logical volume: contains the initial information required to start the system - paging logical volume: used by the virtual memory manager to swap out pages of memory users and appl.-s will use these lvs: - raw logical volumes: these will be controlled by the appl. (it will nit use jfs/jfs2) - journaled filesystems:

S triped logical volumes: Striping is a technique spreading the data in a logical volume across several physical volumes in such a way that the I/O capacity of the physical volumes can be used in parallel to access the data.

LVCB (Logical Volume Control Block) First 512 byte of each logical volume in normal VGs (In big VGs it moved partially into the VGDA, and for scalable VGs completely.)(traditionally it was the fs boot block) The LVCB stores the attributes of the LV. Jfs does not access this area. # getlvcb -AT <lvname> <--shows the LVCB of the lv -------------------LOGICAL VOLUM E: hd2 VOLUM E GROUP: rootvg LV IDENTIFIER: 0051f2ba00004c00000000f91d51e08b.5 PERM ISSION: VG STATE: active/complete LV STATE: opened/syncd TYPE: jfs WRITE VERIFY: off M AX LPs: 512 PP SIZE: 32 megabyte(s) COPIES: 2 S CHED POLICY: parallel LPs: 73 PPs: 146 STALE PPs: 0 BB POLICY: relocatable INTER-POLICY: minimum RELOCATABLE: yes INTRA-POLICY: center UPPER BOUND: 32 M OUNT POINT: /usr LABEL: /usr MIRROR WRITE CONS IS TENCY: on/ACTIVE EACH LP COPY ON A S EPARATE PV ?: yes Serialize IO ?: NO

read/write

inter-policy

inter-physical volume allocation policy, can be minimum or maximum

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

1/9

1/20/14

AIX for System Administrators


minimum: to allocate pp's the minimum pv will be used (not spreading to all pv's tha data if possible) maximum: to spread the physical partitions of this logical volume over as many physical volumes as possible.

This illustration shows 2 physical volumes. One contains partition 1 and a copy of partition 2. The other contains partition 2 with a copy of partition 1. The formula for allocation is M aximum Inter-Disk Policy (Range=maximum) with a Single Logical Volume Copy per Disk (Strict=y).

each lp copy on separate pv The strictness value. Current state of allocation, strict, nonstrict, or superstrict. A strict allocation states that no copies for a logical partition are allocated on the same physical volume. If the allocation does not follow the strict criteria, it is called nonstrict. A nonstrict allocation states that copies of a logical partition can share the same physical volume. A superstrict allocation states that no partition from one mirror copy may reside the same disk as another mirror copy. (mirror 2 and mirror 3 cannot be on the sam edisk) (So inter-policy and strictness have effect together how many disks are used: spreading to maximum disks (1st lps) then mirroring them we need another bunch of disks; however spreading to minimum disks and mirroring, we need less disks.)

intra-policy intra-physical volume allocation policy, it specifies what startegy should be used for choosing pp's on a pv. it can be: edge (outer edge), middle (outer middle), center, inner middle, inner edge

If you specify a region, but it gets full, further partitions are allocated from near as possible to far away. The more i/o-s used, the pp's should be allocate to the outer edge. mirror write consistency If turned on LVM keeps additional information to allow recovery of inconsistent mirrors. M irror write consistency recovery should be performed for most mirrored logical volumes M WC is necessary to mirror lvs with parallel scheduling policies. sched policy how reads and writes are handled to mirrorred logical volumes parallel (default): read from least busy disk, write to all copies concurrently (at the same time) sequential: read from primary copy only (if not available then next copy). write sequential (one after another) (1 book suggests sequential because it works with M WC) Write verify BB policy Relocatable Upper Bound -----------------# lslv -l pdwhdatlv PV COPIES IN BAND hdiskpower5 125:000:000 3% Copies In Band Distribution -----------------DISTRIBUTION 000:004:000:076:045 If turned on, all writes will be verified with a follow-up read. This will negatively impact performace but useful. Bad block relocation policy. (bad blocks are relocatable or not) Indicates whether the partitions can be relocated if a reorganization of partition allocation takes place. what is the maximum number of physical volumes a logical volume can use for allocation

shows information of each copies (separated by :) on the disks (125 first copy and no other mirrors are on the disk) the percentage of pps on the disk which were allocated within the region specified by Intra-physical allocation policy how many pps are allocated in: outer edge, outer middle, center, inner middle, and inner edge (125=4+76+45)

lslv lvname displays information about the logical volume lslv -m lvname displays the logical partitions (LP) and their corresponding physical partititons (PP) lslv -l lvname displays on which physical volumes is the lv resides lslv -p <hdisk> displays the logical volume allocation map for the disk (shows used, free, stale for each physical partition) lslv -p <hdisk> <lv> displays the same as above, just the given lv's partitions will be showed by numbers Open Closed Indicates active if LV contains a file system Indicates inactive if LV contains a file system

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

2/9

1/20/14
S yncd S tale Indicates that all copies are identical Indicates that copies are not identical

AIX for System Administrators

mklv -y newlv1 datavg 1 create logical volumes (mklv -y'testlv' -t'jfs' rootvg 100 <--creates jfs with 100 lp) -y newlv1 name of the lv datavg in which vg the lv will reside 1 how many logical partitions add to the lv mklv -t jfs2log -y <lvname> <vgname> 1 <pvname> creates a jfs2log lv (after creation format it: logform -V jfs2 <loglvname>) rmlv removes a logical volume rmlv -f loglv removes without confirmation mklvcopy bblv 2 hdisk2 make a 2nd copy (1LP=2PP) of bblv to hdisk2 (synchronization will be needed: syncvg -p hdisk2 hdisk3) rmlvcopy bblv 1 hdisk3 leave 1 copy (1LP=1PP) only and remove those from hdisk3 getlvcb extendlv cplv chlv display the LVCB (Logical Volume Control Block) of a logical volume increasing the size of a logical volume copying a logical volume changes the characteristic of a logical volume

migratelp testlv/1/2 hdisk5/123 migrates testlv's data from the 1st lp's second copy to hdisk5 on pp 123 (output of lspv -M hdiskx can be used:lvname:lpnumber:copy, this sequence is needed) (if it is not mirrorred than easier this way: migratelp testlv/1 hdisk3) (if it is mirrorres and we use the above commande, than 1st copy will be used: testlv/1/1...) migratelp in for cycle: for i in $(lslv -m p1db2lv | grep hdiskpower11 | tail -50 | cut -c 2-4); do migratelp p1db2lv/$i hdiskpower3; done lresynclv resync a logical volume (???maybe if mirrorred???

-----------------Creating a new log logical volume:

1. mklv -t jfs2log -y lvname vgname 1 pvname <-- creates the log lv 2. logform -V jfs2 /dev/lvname 3. chfs -a log=/dev/lvname /fsname <--changes the log lv (it can be checked in /etc/filesystems) -----------------Resynchronizing a logical volume: 1. root@aix16: / # lslv hd6 | grep IDENTIFIER LV IDENTIFIER: 00c2a5b400004c0000000128f907d534.2 2. lresynclv -l 00c2a5b400004c0000000128f907d534.2 -----------------S triped lv extending problems: extending is only possible by the stripe width (if it is 2, the extended lp should be 2,4,6...) if lv can't be extended upper bound can cause this: lslv P02ctmbackuplv | grep UPPER UPPER BOUND: 2 It means that the lv can only be on 2 disks, but if on those 2 disks has no more space it can't be extebded to other disks. upper bound should be changed: chlv -u 4 P02ctmbackuplv

After this extension should be possible . -----------------Unable to find lv in the define configuration database 1. synclvodm <vgname> <-- rebuild the volume group descriptors on the physical volume. Enter: 2. rmlv <lvname> <-- remove the unwanted logical volume. -----------------Migrating PPs between disks: checking the PPs of test1lv: lslv -m test1lv test1lv:/home/test1fs LP PP1 PV1 PP2 PV2 0001 0001 hdisk6 0002 0002 hdisk6

PP3 PV3

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

3/9

1/20/14
0003 ... 0057 0058 0059 0003 hdisk6 0057 hdisk6 0058 hdisk6 0059 hdisk6

AIX for System Administrators

the command: migratelp test1lv/59 hdisk7 (it wil migrate LP #59 to hdisk7) in a for cycle: for i in $(lslv -m shadowlv | grep hdisk1 | tail -10 | cut -c 2-4); do migratelp shadowlv/${i} hdisk0 done -----------------Once had a problem with an lv and its mirror copies: root@bb_lpar: / # lsvg -l bbvg bbvg: LV NAM E TYPE LPs PPs PVs LV STATE M OUNT POINT 0516-1147 : Warning - logical volume bblv may be partially mirrored. bblv jfs2 16 20 3 closed/syncd /bb

root@bb_lpar: / # mirrorvg bbvg 0516-1509 mklvcopy: VGDA corruption: physical partition info for this LV is invalid. 0516-842 mklvcopy: Unable to make logical partition copies for logical volume. 0516-1199 mirrorvg: Failed to create logical partition copies for logical volume bblv. 0516-1200 mirrorvg: Failed to mirror the volume group.

root@bb_lpar: / # lslv -l bblv 0516-1939 : PV identifier not found in VGDA.

root@bb_lpar: / # rmlvcopy bblv 1 hdisk2 0516-1939 lquerypv: PV identifier not found in VGDA. 0516-304 getlvodm: Unable to find device id 0000000000000000 in the Device Configuration Database. 0516-848 rmlvcopy: Failure on physical volume 0000000000000000, it may be missing or removed.

The partial mirrored lps caused a big mess in VGDA and LVM , so the solution was the removal of these lps with a low-level command: lreducelv 1. checking the problematic lps: root@bb_lpar: / # lslv -m bblv bblv:/bb LP PP1 PV1 PP2 PV2 0001 0008 hdisk2 0002 0009 hdisk2 0003 0010 hdisk2 0004 0011 hdisk2 0005 0012 hdisk2 0006 0013 hdisk2 0007 0014 hdisk2 0008 0015 hdisk2 0009 0008 hdisk3 0016 hdisk2 0010 0009 hdisk3 0017 hdisk2 0011 0010 hdisk3 0018 hdisk2 0012 0012 hdisk3 0019 hdisk2 0013 0001 hdisk2 0014 0002 hdisk2 0015 0003 hdisk2 0016 0004 hdisk2

PP3 PV3

2. creating a text file with these wrong lps which will be used by lreducelv: 1st column: PVID of the disk with wrong lps (lspv hdisk2: 00080e82dfab25bc) 2nd column: PP# of the wrong lps (lslv -m bblv: PP2 column) 3rd column: LP# of the wrong lps (lslv -m bblv: LP column) root@bb_lpar: / # vi partial_mir.txt 00080e82dfab25bc 0016 0009 00080e82dfab25bc 0017 0010 00080e82dfab25bc 0018 0011 00080e82dfab25bc 0019 0012

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

4/9

1/20/14
3. removing the partial mirror copies: lreducelv -l <LV ID> -s <NUM BER of LPs> <TEXT FILE> LV ID: 00080e820000d900000001334c11e0de.1 (lslv bblv) NUMBER of LPs: 4 (wc -l partial_mir.txt) TEXT FILE: partial_mir.txt

AIX for System Administrators

root@bb_lpar: / # lreducelv -l 00080e820000d900000001334c11e0de.1 -s 4 partial_mir.txt Now the lvm deallocates all PP's of your partially mirror.

4. After these, lslv -m will show correct output, but LVCB or VGDA could still show we have 2 copies root@bb_lpar: /tmp/bb # odmget -q name=bblv CuAt | grep -p copies CuAt: name = "bblv" attribute = "copies" value = "2" type = "R" generic = "DU" (We can see this paragraph only if there is mirroring, otherwise there will be no output of odmget command)

root@bb_lpar: /tmp/bb # getlvcb -AT bblv AIX LVCB intrapolicy = m copies = 1 (odmget shows we have 2 copies and getlvcb shows we have only 1 copy.) Probably it is safer if we update both with the correct value: putlvodm -c <COPYNUM > <LV ID> putlvcb -c <COPYNUM > <LV NAM E> COPYNUM: 1 LV ID: 00080e820000d900000001334c11e0de.1 (lslv bblv) root@bb_lpar: /tmp/bb # putlvodm -c 1 00080e820000d900000001334c11e0de.1 root@bb_lpar: /tmp/bb # putlvcb -c 1 bblv source of this solution: http://archive.rootvg.net/cgi-bin/anyboard.cgi/aix?cmd=get&cG=73337333&zu=37333733&v=2&gV=0&p= ------------------

Labels: LVM

34 comments:
A n o n y m o u sJ u l y2 0 ,2 0 1 2a t4 : 4 6P M V e r yg o o ds t u f f s R e p l y

n a r a y a n aA u g u s t7 ,2 0 1 2a t5 : 1 0P M y e p ,V e r yg o o dS t u f f R e p l y R e p l i e s a i xA u g u s t7 ,2 0 1 2a t1 0 : 5 7P M t h a n k s: ) R e p l y

A n o n y m o u sD e c e m b e r2 8 ,2 0 1 2a t5 : 4 7P M e x c e l l e n ti n f o . . . k e e pu pt h eg u dw o r k . . . . . R e p l y R e p l i e s

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

5/9

1/20/14
a i xD e c e m b e r2 8 ,2 0 1 2a t9 : 2 0P M : ) R e p l y

AIX for System Administrators

n a r e s hJ a n u a r y3 0 ,2 0 1 3a t9 : 4 6A M a m a z i n gw o r kw h a tud o n eb o s s R e p l y R e p l i e s a i xJ a n u a r y3 0 ,2 0 1 3a t1 0 : 4 3A M : ) R e p l y

V a s a n t hG o v i n d a r a j uF e b r u a r y8 ,2 0 1 3a t1 0 : 4 6A M H I . . ( A I X6 . 1 ) R o o t v g h a v e 2 d i s k s ( h d i s k 0 a n d h d i s k 1 ) . c u r r e n t b o o t i s h d i s k 0 . o n l y h d 1 1 a d m i n a n d l i v e d u m p r e s i d e s i n h d i s k 1 . . c a n i m o v e i t t o h d i s k 0 ? b y"m i g r a t e p vlh d 1 1 a d m i nh d i s k 1h d i s k 0 "a n d" m i g r a t e p vll i v e d u m ph d i s k 1h d i s k 0 "w i l li tw o r k s ? ? I fp o s s i b l ec a nup l ze x p l a i nu s eo fb o t hL V ' s . . R e p l y R e p l i e s V a s a n t hG o v i n d a r a j uF e b r u a r y8 ,2 0 1 3a t1 0 : 5 6A M S e n a r i o i st h a t . . Ia m s u p p o s e dt o d oT L u p g r a d ef o r A I X6 . 1 s e r v e r . .R o o t v g w a sm i r r o r e d w i t hh d i s k 0 a n dh d i s k 1 . . c u r r e n t b o o ti sh d i s k 0 . . L V ' s h d 1 1 a d m i n a n d l i v e d u m p w a s n o t m i r r o r e d . I u n m i r r o r e d r o o t v g ( u n m i r r o r v g r o o t v g h d i s k 0 - s u c c e s s ) . t h e n t r y i n g t o r e d u c er o o t v gh d i s k 1( r e d u c e v gr o o t v gh d i s k 1 ) . . W a r n i n g:h d 1 1 a d m i na n dl i v e d u m pw i l lb ed e l e t e d . . .( Y / N ) . . .N t h e nl a t e rit r i e dm em i r r o rb a c k . . .b u tn o th a p p e n i n g . .t h r o u g h i n ge r r o r . . . s ol a t e rid o n em u l t i b o sa n dc o m p l e t e dT Lu p g r a d e . . . . . B u tn o wm i r r o rn o th a p p e n i n g . .s oi w a n tt om o v eh d 1 1 a d m i na n dl i v e d u m pt oh d i s k 0 . .a n dr e d u c eh d i s k 1/ a d dt or o o t v ga n dw a n t t om i r r o ri ta g a i n . . . . . A l s oyt h o s et w oL V ' sn o tm i r r o r e db e f o r eIu n m i r r o r e di t . . . .Ih o p eo n l ys y s d u mi nr o o t v gw o n tg e tm i r r o r e d ? ? ? ? ? c a nup l ze x p l a i no nt h i si s s u e . .w h e r eiw e n tw r o n g ? ? ? ? A d v a n c eT h a n k s . . ! !

a i xF e b r u a r y1 0 ,2 0 1 3a t1 0 : 3 2P M H i , Ic h e c k e d1A I Xs e r v e ra n dt h e s eL V s( h d 1 1 a d m i na n dl i v e d u m p )a r em i r r o r e di nt h a ts e r v e r . h d 1 1 a d m i n :p r i v i l e g e dp r o c e s s e sc a ns e c u r e l yc r e a t et e m p o r a r yf i l e st h e r e l i v e d u m p :t h i si st h ep l a c ew h e r ey o uc a nc r e a t ead u m po nal i v es y s t e m ,w i t h o u tr e b o o t i n gi t . T h ec o m m a n d sw h a ty o us e n ts h o u l dw o r ka n dId o n ' tk n o ww h yt h e s eL V sw e r en o tm i r r o r r e de a r l i e r . H o p et h i sh e l p s , B a l a z s R e p l y

J u r a jB o c i n e cF e b r u a r y2 7 ,2 0 1 3a t3 : 0 0P M H e l l o ,h a v ey o uc o m ea c r o s sa ni s s u ew h e nl s l vr e p o r t e do n l ys o m eo ft h ei n f o r m a t i o n ?I fir u ni tu n d e rr o o tig e ta l lt h ei n f o r m a t i o n b u to t h e ru s e rh a ss o m ei n f o r m a t i o nm i s s i n g ,f o re x a m p l e : T Y P E :s y s d u m pW R I T EV E R I F Y :? M A XL P s :?P PS I Z E :?

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

6/9

1/20/14
C O P I E S :?S C H E DP O L I C Y :? L P s :?P P s :? S T A L EP P s :?B BP O L I C Y :? I N T E R P O L I C Y :m i n i m u mR E L O C A T A B L E :y e s I N T R A P O L I C Y :m i d d l eU P P E RB O U N D :3 2

AIX for System Administrators

o no t h e rs y s t e m st h i sw o r k sf i n e ,e v e no n2 n dn o d eo ft h ec l u s t e r .M a yt h i sb es o m es e c u r i t ys e t t i n gi nt h eA I X ?B u tw ed i d n ' tc h a n g e a n y t h i n g i n t h e e n v i r o n m e n ts e t t i n g s . I h a v e a l s o c h e c k e d L V C B a n d V G D Aa n d t h e y s e e m c o r r e c t . A l s o O D M m u s tb e c o r r e c t b e c a u s e i w o u l d n ' tg e tt h i si n f of o rr o o t . R e p l y R e p l i e s a i xF e b r u a r y2 7 ,2 0 1 3a t5 : 0 8P M H i ,s t r a n g e ,I ' v en e v e rs e e nt h i sb e f o r e . . . f i r s ti d e a s : d oy o ue x p e r i e n c et h i sw i t ho t h e rl v mc o m m a n d s ?( i . e .l s v g ) d oy o ue x p e r i e n c et h i sf o re v e r yl v ?( i fn o td oy o us e es o m el o g i c ? ) d oy o ue x p e r i e n c et h i sw i t hs m i t t ya sw e l l ? I ' l lt h i n ka b o u tt h a t .

J u r a jB o c i n e cF e b r u a r y2 8 ,2 0 1 3a t1 0 : 1 7A M H e l l o ,w i t ho t h e rc o m m a n d s( l s v g ,l s p v )ig e to u t p u t ,i to n l yd o e s n ' tw o r kf o rl s l vc o m m a n da n df o ra l lL V s ,e v e ni nd i f f e r e n t V G st h a nr o o t v g .T h i sb e h a v i o u ri st h es a m ew i t hs m i t . Iw i l lt r yt oa r r a n g ef o rr e b o o ta n ds e ei fi th e l p s ,i tm a ya sw e l lb e ab u gi nA I X .

a i xF e b r u a r y2 8 ,2 0 1 3a t1 2 : 5 9P M H i ,2t h i n g s: ) 1 .T h i si sw r i t t e ni nm a nl s l v : " I ft h el s l vc o m m a n dc a n n o tf i n di n f o r m a t i o nf o ra f i e l di nt h eD e v i c eC o n f i g u r a t i o nD a t a b a s e ,i tw i l li n s e r t aq u e s t i o nm a r k ( ? )i nt h ev a l u ef i e l d .. . . " S ol s l vw i l lg e ti n f of r o mO D M .I fy o uc h e c k" l sl/ e t c / o b j r e p o s " ,y o uc o u l ds e ei fo t h e ru s e rh a sr e a da c c e s st ot h o s ef i l e s o rn o t . 2 .T h i si sw r i t t e ni nm a nl s l v : " T h ec o m m a n d a t t e m p t st oo b t a i na s m u c hi n f o r m a t i o na sp o s s i b l e f r o mt h ed e s c r i p t i o na r e a w h e ni ti sg i v e n al o g i c a lv o l u m e i d e n t i f i e r . " I ' mn o ts u r ea b o u tt h a t ,b u ti ts e e m st h a t ,i fl vi d e i n t i f i e ri su s e di tw i l lg e ti n f of r o mV G D A ? ? ? P r o b a b l yy o uc a ng i v eat r yt oi t : #l q u e r y v gt A ph d i s k X>i tw i l ll i s tl vi d e n t i f i e r sa sw e l l #l s l v>f o re x a m p l e" l s l v0 0 c e b f f e 0 0 0 0 4 c 0 0 0 0 0 0 0 1 0 3 6 3 f 5 0 a c 5 . 2 " P l e a s es e n ds o m ef e e d b a c ki fy o uc o u l df i g u r eo u ts o m e t h i n g . R e p l y

J u r a jB o c i n e cM a r c h1 ,2 0 1 3a t5 : 0 8P M H e l l o ,t h e s ed a t aa r en o tt a k e nf r o mO D M ,b e c a u s ei fir e a dd a t af r o mV G D Aw i t hr e a d v g d alh d i s k 0ig e tt h i si n f o : = = = = = = = = = = = = =B :L Vl v d u m p 1= = = = = = = = = = = = = L O G I C A LV O L U M E :l v d u m p 1V O L U M EG R O U P :O D M L VI D E N T I F I E R :0 0 f 6 2 0 a 4 0 0 0 0 4 c 0 0 0 0 0 0 0 1 3 6 5 4 4 0 2 4 b d . 1 8P E R M I S S I O N :r e a d / w r i t e V GS T A T E :L V D DL VS T A T E :L V D D T Y P E :O D MW R I T EV E R I F Y :o f f M A XL P s :5 1 2P PS I Z E :2 5 6m e g a b y t e ( s ) C O P I E S :C A L CS C H E DP O L I C Y :p a r a l l e l L P s :3 0P P s :C A L C S T A L EP P s :C A L CB BP O L I C Y :r e l o c a t a b l e I N T E R P O L I C Y :O D MR E L O C A T A B L E :O D M I N T R A P O L I C Y :O D MU P P E RB O U N D :O D M M O U N TP O I N T :D E VL A B E L :O D M M I R R O RW R I T EC O N S I S T E N C Y :o n / A C T I V E E A C HL PC O P YO NAS E P A R A T EP V? :O D M S e r i a l i z eI O? :N O a sy o uc a ns e ed a t at h a ta r em i s s i n ga r en o tt h o s et h a ta r es t o r e di nO D Mb u tr a t h e ri nV G D Aa n dt h i ss e e m st ob ec o r r e c t .E v e nL V C B i sc o r r e c ti fic h e c kw i t hg e t l v c bA Tl v d u m p 1 . A sf o rp o i n t1-ic h e c k e dc o n t e n t so f/ e t c / o b j r e p o so nb o t hc l u s t e rn o d e sa n di t ' st h es a m er e g a r d i n gp e r m i s s i o n sa n do w n e r s h i p A sf o rp o i n t2-i fiu s eL Vi d e n t i f i e rw i t hl s l vis t i l lg e tq u e s t i o nm a r k si n s t e a do ff u l li n f o r m a t i o n . Ih a v eo p e n e dP M Rt oI B Ma s k i n gi ft h i si s ak n o w nb u g .I t ' s ap o s s i b i l i t yb e c a u s eh e r ew eu s eo s l e v e l6 1 0 0 0 6 0 6 1 1 4 0w i t hq u i t ew i l d c o m b i n a t i o no fe f i x e s . I ' l ll e ty o uk n o ww h e nih a v es o m ei n f of r o mt h e m . R e p l y

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

7/9

1/20/14
R e p l i e s J u r a jB o c i n e cM a r c h1 ,2 0 1 3a t5 : 1 0P M

AIX for System Administrators

O o p s ,s e e m sip o s t e dt h i sa sac o m m e n tr a t h e rt h a nr e p l yt op r o p e rt h r e a d ,s o r r yf o rt h a t .

J u r a jB o c i n e cM a r c h1 4 ,2 0 1 3a t2 : 3 3P M H e l l o a g a i n , w e h a v e s o l v e d t h i s p r o b l e m . I t t u r n e d o u t t h e r e h a v e b e e n w r o n g o w n e r s h i p s o n s e v e r a l d i r e c t o r i e s i n / f i l e s y s t e m .S oi nc a s ey o uc o m ea c r o s st h i sp r o b l e m ,c h e c ki fy o u r/ u s ro r/ e t ci so w n e db yc o r r e c tu s e ra n dn o tb ys o m es a p o ro r a c l eu s e r .

a i xM a r c h1 4 ,2 0 1 3a t7 : 0 8P M T h a n k sf o rt h ef e e d b a c k . . . t h i sw a sas t r a n g ei s s u e ,g o o dt ok n o wt h i ss o l u t i o n: )

A n o n y m o u sM a r c h2 0 ,2 0 1 3a t9 : 1 1P M Ih a v eas c e n a r i ow h e r eih a v ed e l e t e daf i l ef r o mt h ed i r e c t o r y ,b u ts t i l lt h es p a c ew a sr e c l a i m e dt ot h ef i l es y s t e m . N e e dy o u ri n p u t sa b o u tw h a tm i g h tb et h ec a s eo ft h i s .

a i xM a r c h2 0 ,2 0 1 3a t9 : 4 9P M H i ,i fy o ud e l e t eaf i l e ,w h i l ei ti so p e n e db yap r o c e s si t ss p a c ew i l ln o tf r e eu p . T r yt h i sc o m m a n d :" f u s e rd V" I t w i l l s h o w s d e l e t e d f i l e s ( i n o d e ) w i t h p r o c e s s i d s w h i c h a r e o p e n b y a p r o c e s s ( s o i t s s p a c e c o u l d n o t b e f r e e d u p ) . S o l u t i o n :k i l lt h ep r o c e s s ,w a i tf o rt h ep r o c e s st of i n i s ho rr e b o o tt h es y s t e m . R e p l y

S a t i s hC hA p r i l5 ,2 0 1 3a t4 : 1 7A M H i ,t h eL Vi nt h er o o t v gh d 5i si nc l o s e d / s y n c ds t a t ew h y ? A l lo t h e rL V sa r ei no p e n / s y n c di n c l u d i n gp a g i n g ( h d 6 )a l s o . I fw ed o n ' th a v em o u n tt ob o t hL V s ,b u to n ei si nC l o s e d / s y n c ds t a t ea n dt h eo t h e ri sO p e n / S y n c ds t a t e . C o u l ey o uP l e a s ee x p l a i n . R e p l y R e p l i e s a i xA p r i l5 ,2 0 1 3a t9 : 2 5A M h d 5i st h eb o o tl o g i c a lv o l u m e .I ts h o u l dn o tb ei no p e ns t a t ea sy o ua r en o tw r i t ei ni tr e g u l a r l y .I ti su s e da tb o o tt i m e ( o rp r o b a b l yw h e ny o uc r e a t et h eb o o t i m a g ew i t hb o s b o o tc o m m a n d ) . h d 6i st h ep a g i n gs p a c e .I t i si no p e ns t a t e ,b e c a u s es y s t e mi su s i n gi t ,i nc a s eo f m e m o r ys h o r t a g e .I fy o uc r e a t ea n o t h e r p a g i n gs p a c e ,y o uc a np l a yt oa c t i v a t eo rt u r ni to f f( s w a p o n / s p a p o f fc o m m a n d ) ,s oi tc a nb ei nc l o s e ds t a t ei fn e e d e d . R e p l y

A n o n y m o u sM a y1 6 ,2 0 1 3a t4 : 1 7P M H i ,Ia l w a y su s ey o u rb l o g .I t svh e l p f u l .Iw a n tt or e d u c et h es i z eo fd u m p l v .H o wd oId ot h a t ?r e d u c e l vd u m p l v6 ? T h a n k s , A t i f R e p l y R e p l i e s a i xM a y1 6 ,2 0 1 3a t4 : 2 4P M H i ,t h a n k s .Iw o u l dd e l e t et h a tl va n dr e c r e a t ean e wo n e . M o r ei n f o :h t t p : / / a i x 4 a d m i n s . b l o g s p o t . h u / 2 0 1 1 / 0 6 / a i x g e n e r a t e s s y s t e m d u m p w h e n s e v e r e . h t m l ( I ' v en e v e rh e a r da b o u tt h a tc o m m a n d :r e d u c e l v . . . ) R e p l y

A n o n y m o u sJ u n e1 9 ,2 0 1 3a t9 : 1 2A M e x c e l l e n ti n f o r m a t i o n . . .i ts a v e sm et i m eal o tw h i l eIw o r ka tm ye n v i r o n m e n t . . . R e p l y

V i d y a s a g a rR a oO c t o b e r2 7 ,2 0 1 3a t8 : 1 8P M

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

8/9

1/20/14
H iIh a v ep r o b l e mi no n em yv o l u m eg r o u p s .

AIX for System Administrators

Ih a v e5 d i s k si nt h ev g .a f t e rar e b o o tI c o u l dn o tm o u n tt h ef i l e s y s t e m s .i ti st h r o w i n gt h ee r r o rs u p e r b l o c kd i r t y .I h a v er a nf s c k o nt h eL Vb u ts t i l ln ol u c k . c o m p a r e db o t h t h es e c o n d a r ys u p e r b l o c ka n d p r i m a r yb o t ha r e s a m e .I st h e r ea n y i s s u ew i t hl o g l o g i c a lv o l u m e .I fl o g l o g i c a lv o l u m e c o r r u p t sw i l li te f f e c tm yo t h e rL V ' s Ih a v e t r i e dt o r u nl o g f o r m o nl o gL V b u ti t i st h r o w i n gm e e r r o r " f a i l u r ei n l o g f o r m a t " .M y q u e s t i o ni sc a n Ir e c r e a t e l o gl o g i c a l v o l u m ean e wo n e . R e p l y

a i xO c t o b e r2 7 ,2 0 1 3a t9 : 2 4P M H i ,i nt h ef o l l o w i n gl i n ki ti sw r i t t e n ,l o g f o r ms h o u l db ed o n eo nc l o s e dL V s : h t t p : / / w w w 0 1 . i b m . c o m / s u p p o r t / d o c v i e w . w s s ? u i d = i s g 3 T 1 0 0 0 1 5 6 h t t p : / / w w w 0 1 . i b m . c o m / s u p p o r t / d o c v i e w . w s s ? u i d = i s g 3 T 1 0 1 1 0 5 4 A s i t i s w r i t t e n a b o v e , i f f s c k w a s s u c c e s s f u l , t h e n y o u a r e s a f e t o d o l o g f o r m , o r c r e a t e a n e w l o g l o g i c a l v o l u m e , o t h e r w i s e f i l e s y s t e m sc a nb ec o r r u p t e d .( A n dt h e s ea c t i o n sc a nb ed o n ew h i l ef i l e s y s t e m sa r eu m o u n t e d . ) R e p l y

J a v e e dB u t tO c t o b e r3 1 ,2 0 1 3a t7 : 0 3P M T h i sc o m m e n th a sb e e nr e m o v e db yt h ea u t h o r . R e p l y

J a v e e dB u t tN o v e m b e r1 ,2 0 1 3a t6 : 1 2P M i nV I Os e r v e ri a mf a c i n gp r o b l e mw i t hL V si no n eo fv ga sb e l l o wa n dn e e d sh e l pt h e r eh o w ic a nc h a n g eL VS T A T Ef r o mc l o s e d / s y n c dt o o p e n / s y n c d ,w i l lb et h a n k f u lf o ra n ys u g g e s t i o n #l s v gld i s k v g d i s k v g : L VN A M ET Y P EL P sP P sP V sL VS T A T EM O U N TP O I N T d i s k l v 0j f s 22 7 32 7 31o p e n / s y n c dN / A d i s k l v 1j f s 22 7 32 7 31c l o s e d / s y n c dN / A d i s k l v 2j f s 22 7 32 7 31o p e n / s y n c dN / A d i s k l v 3j f s 22 7 32 7 31c l o s e d / s y n c dN / A d i s k l v 4j f s2 7 32 7 31c l o s e d / s y n c dN / A d i s k l v 5j f s2 7 32 7 31c l o s e d / s y n c dN / A d i s k l v 6j f s2 7 32 7 31c l o s e d / s y n c dN / A d i s k l v 7j f s2 7 32 7 31c l o s e d / s y n c dN / A d i s k l v 8j f s 21 5 01 5 01c l o s e d / s y n c dN / A d i s k l v 9j f s 21 5 01 5 01c l o s e d / s y n c dN / A d i s k l v 1 0j f s 21 5 01 5 01c l o s e d / s y n c dN / A R e p l y

A n o n y m o u sN o v e m b e r1 3 ,2 0 1 3a t1 1 : 2 5A M w h a ti st h eu s eo fj f s 2l o g ? R e p l y R e p l i e s A n o n y m o u sN o v e m b e r1 7 ,2 0 1 3a t2 : 4 9P M a sf a ra sik n o wt h ej f s 2l o gp a r t i t i o nh o s td i s kc h a n g e s( i tu s ead bf o rt h a t )b e f o r ep h y s i c a l l yw r i t ei tn ot h ed i s k s . R e p l y

A n o n y m o u sN o v e m b e r2 7 ,2 0 1 3a t1 2 : 1 9A M T h a n k se x c e l l e n ti n f o . .Ih a v ef i x e dt h ei s s u e R e p l y

c h a n d r aJ a n u a r y7 ,2 0 1 4a t4 : 3 2P M T h i sc o m m e n th a sb e e nr e m o v e db yt h ea u t h o r . R e p l y

c h a n d r aJ a n u a r y7 ,2 0 1 4a t4 : 3 5P M H ic a nw er e d u c es t r i p e dl v? c a ny o up l e a s ee x p l a i nt h ep r o c e s s R e p l y

aix4admins.blogspot.in/2011/05/lvm-logical-volume-manager-lvm-manages.html

9/9

You might also like