You are on page 1of 5

ALGORITMOS

1. Calcule el promedio final de un alumno en funcin de sus 4 notas en un


determinado curso, si se sabe que la Nota 1 tiene peso 2, la Nota 2 tiene peso
3, la Nota 3 tiene peso 1 y la Nota 4 tiene peso 2.
2. Se desea saber el neto a pagar de un obrero por su trabajo en la semana, si
se sabe que trabaja los das lunes, mircoles, viernes y domingos. La hora de
trabajo se cotiza en 30 soles y los domingos es del doble. El algoritmo debe
leer las horas trabajadas en cada da, as como leer la cantidad de minutos de
tardanza durante la semana. Se sabe que cada 10 minutos equivale a 20
soles de descuento. Se debe imprimir el total de ingresos (por concepto de
horas trabajadas), el total de descuentos (por las tardanzas) y el neto a pagar
(ingresos menos descuentos).
3. Un profesor desea registrar las notas del examen final de sus 10 alumnos de
un saln de clase. Al terminar de registrar las notas, el programa deber
mostrar los siguientes datos:

La cantidad total de aprobados considerando que la nota mnima


aprobatoria es 14 (contador).
La cantidad total de desaprobados (contador).
La suma total de las notas ingresadas (acumulador).
El promedio de todas las notas.

SOLUCIN
Pregunta 1:
// *** Declaramos Variables. Indicamos Tipo y Nombres *** //
// Se colocan prefijos para indicar el tipo de Dato de la variable.
// int proviene del Tipo de Dato .NET Integer(Entero)
// sng proviene del Tipo de Dato .NET Single (Real Simple)
Enteras: intNota1, intNota2, intNota3, intNota4
Real
: sngPromedio
// Dentro de VS.NET, en VB iniciaremos con Begin; en C# con {
// *** Inicio del Algoritmo *** //
Inicio
// En algunos lenguajes de programacin esta asignacin (CERO) es por
defecto para un valor numrico
// En otros lenguajes se asigna el valor NULL (Nulo)
// El smbolo <-indica asignacin. Ejemplo: variable1 <- 15.78 se lee as:
se asigna el valor 15.78 a la variable "variable1"
// *** Inicializacin de Variables *** //
intNota1
intNota2
intNota3

<- 0
<- 0
<- 0

intNota4
<- 0
sngPromedio <-0
// En la mayora de los programas cuenta con interfaces para interactuar con el
computador donde se
// ingresan o se leen datos;
// *** Entrada de Datos *** //
Leer intNota1, intNota2, intNota3, intNota4
// *** Proceso *** //
sngPromedio <- ( 2*intNota1 + 3*intNota2 + intNota3 + 2*intNota4) / 8
// *** Salida de Datos *** //
// El Smbolo & sirve para concatenar.
Imprimir "El Promedio es: " & sngPromedio
// *** Fin del Algoritmo *** //
// Dentro de VS.NET, en VB finalizaremos con End; en C# con }
Fin
Pregunta 2:
// Declarar Variables
Variables
Reales: sngHorasLun, sngHorasMie, sngHorasVie, sngHorasDom,
sngTardanzas, sngHorasTotal,
sngPagoBruto, sngDescuento, sngPagoNeto
// Inicio del Algoritmo
Inicio
// Inicializar Variables
sngHorasLun
sngHorasMie
sngHorasVie
sngHorasDom
sngTardanzas
sngHorasTotal
sngPagoBruto
sngDescuento
sngPagoNeto

<<<<<<<<<-

0
0
0
0
0
0
0
0
0

// Leer Datos
Leer sngHorasLun, sngHorasMie, sngHorasVie, sngHorasDom, sngTardanzas
// Procesar, Realizar Clculos

sngHorasTotal <- sngHorasLun + sngHorasMie + sngHorasVie +


sngHorasDom * 2
sngPagoBruto <- sngHorasTotal * 30
sngDescuento <- sngTardanzas / 10 * 20
sngPagoNeto <- sngPagoBruto - sngDescuento
// Escribir Resultados
Imprimir "El Pago Por Horas Trabajadas Es: " & sngPagoBruto
Imprimir "El Descuento Por Tardanzas Es: " & sngDescuento
Imprimir "El Pago Neto Es: " & sngPagoNeto
// Finaliza el Algoritmo
Fin
Pregunta 3:
// Utilizando Notacin de Tipo de Dato a un prefijo de un Solo Digito.
// i: integer, d: double, real de doble precisin.
// Declaracin de Variables.
Variables
Enteras:
iN01, iN02, iN03, iN04, iN05, iN06, iN07, iN08, iN09, iN10, iContAprob,
iContDesap, iSumaTotal
Reales:
dPromedio
Inicio
// Inicializacin de las Variables.
iN01 <- 0
iN02 <- 0
iN03 <- 0
iN04 <- 0
iN05 <- 0
iN06 <- 0
iN07 <- 0
iN08 <- 0
iN09 <- 0
iN10 <- 0
dPromedio <- 0
iContAprob <- 0
iContDesap <- 0
// Lectura de Datos
// Visualizacin de iSumaTotal como Acumulador.
Leer iN01
iSumaTotal = iSumaTotal + iN01
Leer iN02
iSumaTotal = iSumaTotal + iN02
Leer iN03

iSumaTotal
Leer iN04
iSumaTotal
Leer iN05
iSumaTotal
Leer iN06
iSumaTotal
Leer iN07
iSumaTotal
Leer iN08
iSumaTotal
Leer iN09
iSumaTotal
Leer iN10
iSumaTotal

= iSumaTotal + iN03
= iSumaTotal + iN04
= iSumaTotal + iN05
= iSumaTotal + iN06
= iSumaTotal + iN07
= iSumaTotal + iN08
= iSumaTotal + iN09
= iSumaTotal + iN10

// Introduciendo algoritmos de condicionamiento, comparacin


// Se consulta por el valor de cada Nota, para contabilizar si es mayor
o igual de 14 cuantos aprobados hay y si es menor de 14, cuantos
desaprobados.
Si iN01 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN02 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN03 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN04 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN05 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN06 >= 14 Entonces

iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN07 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN08 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN09 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
Si iN10 >= 14 Entonces
iContAprob = iContAprob + 1
Sino
iContDesap = iContDesap + 1
Fin Si
// Calculando el Promedio y presentado los datos
dPromedio = iSumaTotal / 20
Imprimir
Imprimir
Imprimir
Imprimir
Fin

'La cantidad de aprobados es: ' + iContAprob


'La cantidad de desaprobados es: ' + iContDesap
'La suma de notas es: ' + iSumaTotal
'El promedio de notas es: ' + dPromedio