You are on page 1of 14

Lab ID: 8.8K1112A186.SWP.

SWITCH Lab: Layer 2 EtherChannel


Objective
You will plan, implement, and verify Layer 2 EtherChannel congurations in this lab by conguring EtherChannel
between two switches without using an aggregation protocol.

Lab Topology
The Topology diagram below represents the NetMap in the Simulator:
1

ASW1

1
2

3 4

3
1

ASW2

5 6 7

10

CSW1

R1

5 6
34 2

34 2
5 6

8
7

DSW2

5 6 7 8

1
2

10

DSW1

3 4

PC1

CSW2

R2

PC2

Command Summary
Command

Description

channel-group port-channel-number mode


{on | auto [non-silent] | desirable [nonsilent] on | active | passive}

assigns an Ethernet interface to an EtherChannel group

interface range fastethernet slot/startingport - ending-port

congures a range of interfaces

interface type number

changes from global conguration mode to interface


conguration mode

show cdp neighbors

displays information about directly connected neighbors

show etherchannel [channel-group-number]


{detail | load-balance | port | port-channel |
summary | protocol}

displays EtherChannel information for a channel

show interfaces [type number]

displays the interfaces Data Link layer status; when the


type and number parameters are included, displays detailed
information about the specied interface

show interfaces trunk

displays port and module interface-trunk information

show ip interface brief

displays a brief summary of interface status and conguration

show running-cong

displays the active conguration le

show spanning-tree vlan vlan-id

shows whether spanning tree is running for a virtual LAN


(VLAN)

Boson NetSim Lab Manual

Command

Description

shutdown; no shutdown

enables an interface; disables an interface

switchport mode {access | dynamic {auto |


desirable} | trunk}

congures the VLAN membership mode of a port

switchport trunk encapsulation dot1q

congures trunk for 802.1Q encapsulation

Lab Tasks
Task 1: Plan EtherChannel Congurations
This task involves planning Layer 2 EtherChannel congurations. You will be creating a port channel between
DSW1 and DSW2 in this lab.

1.

What show command can you issue to determine the number of links that can be congured as part of
the port-channel group between DSW1 and DSW2? ________________________________________

2.

What show command can you issue to verify the line and protocol state of an interface? ____________

3.

What show command can you issue to observe the trunk state of a port? ________________________

4.

Switch ports congured to be a member of a channel group must be congured the same way in order
for the port channel to operate correctly. What command can you use to verify that the interfaces are
congured correctly? _________________________________________________________________

5.

What command can you issue to congure an interface to be a member of a port-channel group? _____
__________________________________________________________________________________

6.

What command can you issue to observe spanning tree output for VLAN 1? _____________________

7.

In this lab, how much bandwidth is available using the 2 links between DSW1 and DSW2? __________

8.

Why is the full amount of bandwidth not available on the link between FastEthernet 0/5 and FastEthernet
0/6? ______________________________________________________________________________
__________________________________________________________________________________

9.

How does EtherChannel increase the amount of available bandwidth between DSW1 and DSW2? ____
__________________________________________________________________________________

10.

How many switch ports can be congured to be a member of a port-channel group? _______________

Boson NetSim Lab Manual

Task 2: Review Initial Congurations


This task involves performing Layer 2 EtherChannel congurations.
1.

Determine the number of links that can be congured as part of the port-channel group.

2.

Observe the line and protocol state of each interface on DSW1 and DSW2.

3.

Verify that an active trunk link exists between DSW1 and DSW2. What trunking protocol are both
switches using? _____________________________________________________________________

4.

Observe the spanning tree output on DSW1 and DSW2. Which ports are participating in spanning tree,
and what is the status of each port? _____________________________________________________

5.

Issue the appropriate commands to verify that all the ports are identically congured.

6.

Congure the FastEthernet 0/5 and FastEthernet 0/6 interfaces on DSW1 and DSW2 as members of
channel-group 1 by using the on mode.

7.

Verify that the new, automatically created port-channel 1 interfaces exist on DSW1 and DSW2.

8.

EtherChannel will support trafc for only a single VLAN unless trunking is enabled. With the current
conguration, will trunking be enabled? Why or why not? _____________________________________
__________________________________________________________________________________

9.

Now that the port-channel group has been created and all member interfaces have been appropriately
congured, congure the Port-Channel 1 interface to trunk unconditionally.

10.

Verify that an active trunk link exists on the Port-Channel 1 interface of both DSW1 and DSW2.

11.

Observe the ports that are participating in spanning tree and their status.

12.

Verify that the correct amount of bandwidth (200 Mbps) is available between DSW1 and DSW2.

Task 3: Verify Congurations


This task involves verifying that EtherChannel is functioning properly.
1.

To verify your conguration, you can issue the show etherchannel port-channel command and the
show etherchannel summary command on both DSW1 and DSW2.

Boson NetSim Lab Manual

Lab Solutions
Task 1: Plan Ethernet Congurations
This task involves planning Layer 2 EtherChannel congurations. You will be creating a port channel between
DSW1 and DSW2 in this lab.
1.

You can issue the show cdp neighbors command to determine the two links that can be congured as
part of the port-channel group between DSW1 and DSW2. The following is sample output from DSW1:
DSW1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S -Switch, H - Host, i - IGMP, r - Repeater
Device ID
Local Intrfce
Holdtme
Capability Platform Port ID
DSW2
Fas0/5
128
T S
3550
Fas 0/5
DSW2
Fas0/6
128
T S
3550
Fas 0/6
CSW1
Fas0/9
128
T S
3550
Fas 0/7
CSW1
Fas0/10
128
T S
3550
Fas 0/8
ASW1
Fas0/1
128
T S
2960-8TC-LFas 0/1
ASW1
Fas0/2
128
T S
2960-8TC-LFas 0/2
ASW2
Fas0/3
128
T S
2960-8TC-LFas 0/3
ASW2
Fas0/4
128
T S
2960-8TC-LFas 0/4
CSW2
Fas0/7
128
T S
3550
Fas 0/5
CSW2
Fas0/8
128
T S
3550
Fas 0/6

2.

You can issue the show ip interface brief command to verify the line and protocol state of each
interface. The following is sample output from DSW1:
DSW1#show ip interface
Interface
Vlan 1
FastEthernet0/1
FastEthernet0/2
FastEthernet0/3
FastEthernet0/4
FastEthernet0/5
FastEthernet0/6
FastEthernet0/7
FastEthernet0/8
FastEthernet0/9
FastEthernet0/10
FastEthernet0/11
FastEthernet0/12
GigabitEthernet0/1
GigabitEthernet0/2

brief
IP-Address
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned
unassigned

OK?
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES

Method
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset

Status
up
up
up
up
up
up
up
up
up
up
up
down
down
down
down

Protocol
up
up
up
up
up
up
up
up
up
up
up
down
down
down
down

Boson NetSim Lab Manual

3.

You can issue the show interfaces trunk command to observe the trunk state of each port. The following
is sample output from DSW1:
DSW1#show interfaces trunk
Port
Mode
Encapsulation
Fa0/1
desirable
802.1q
Fa0/2
desirable
802.1q
Fa0/3
desirable
802.1q
Fa0/4
desirable
802.1q
Fa0/5
desirable
802.1q
Fa0/6
desirable
802.1q
Fa0/7
desirable
802.1q
Fa0/8
desirable
802.1q
Fa0/9
desirable
802.1q
Fa0/10
desirable
802.1q
<output omitted>

Status
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking

Native vlan
1
1
1
1
1
1
1
1
1
1

4.

Switch ports congured to be a member of a channel group must be congured the same way in order
for the port channel to operate correctly. In this lab, you can issue the show running-cong command to
verify that the interfaces are congured correctly.

5.

You can issue the channel-group command to congure an interface to be a member of a port-channel
group. The channel-group 1 on command is used in interface conguration mode to enable Layer 2
EtherChannel on an interface and make it a member of channel-group 1. In this lab, you will use the on
mode with the channel-group 1 mode command to enable Layer 2 EtherChannel. On mode forces the
bundling of the interface on a channel without using the Port Aggregation Protocol (PAgP) or the Link
Aggregation Control Protocol (LACP). When the port-channel group is congured by using the on mode,
both ends of the links must be congured to use the on mode.

Boson NetSim Lab Manual

6.

You can issue the show spanning-tree vlan 1 command to observe spanning tree output for VLAN 1.
The output from the show spanning-tree vlan 1 command indicates that the FastEthernet 0/6 interface
on DSW2 is in a blocking (BLK) state:
DSW2#show spanning-tree vlan 1
VLAN0001
Spanning tree enabled protocol pvst
Root ID
Priority
24576
Address
000C.1380.3538
Cost
19
Hello Time
2 sec Max Age 20 sec
Bridge ID

Priority
28672
Address
000C.2449.5119
Hello Time
2 sec Max Age 20 sec
Aging Time 15

Interface
------------------Fa0/1
Fa0/2
Fa0/3
Fa0/4
Fa0/5
Fa0/6
Fa0/7
Fa0/8
Fa0/9
Fa0/10

7.

Role
---Desg
Desg
Desg
Desg
Root
Desg
Desg
Desg
Desg
Desg

Sts
--BLK
BLK
BLK
BLK
FWD
BLK
BLK
BLK
BLK
BLK

Cost
--------38
38
38
38
19
19
38
38
38
38

Prio.Nbr
-------128.1
128.2
128.3
128.4
128.5
128.6
128.7
128.8
128.9
128.10

Forward Delay 15 sec

Forward Delay 15 sec


Type
---------------------------P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p

In this lab, each link between DSW1 and DSW2 capable of moving data at 100 Mbps for a total of 200
Mbps. You can verify this by issuing the show interfaces fastethernet 0/5 command and the show
interfaces fastethernet 0/6 command on both DSW1 and DSW2. The following is sample output from
DSW2:
DSW2#show interfaces fastethernet 0/5
FastEthernet0/5 is up, line protocol is up
Hardware is Fast Ethernet, address is 000C.3583.6535 (bia 000C.3583.6535)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Auto-duplex, Auto-speed
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 02:29:44, output never, output hang never
Last clearing of show interface counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queuing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
269 packets input, 71059 bytes, 0 no buffer
Received 6 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
7290 packets output, 429075 bytes, 0 underruns
0 output errors, 3 interface resets
0 output buffer failures, 0 output buffers swapped out

Boson NetSim Lab Manual

8.

As you saw in the output of the show spanning-tree vlan 1 command, FastEthernet 0/6 on DSW2 is in a
blocking (BLK) state, which prevents the full amount of bandwidth from being used.

9.

EtherChannel addresses the unused bandwidth between DSW1 and DSW2 by enabling the two links
between the distribution switches to send and receive simultaneously. Spanning tree will treat the
bundled interfaces as a single interface and, thus, will not transition any of the ports to the blocking state.

10.

Up to eight individual interfaces (eight links to a neighbor switch) on a 3550 switch can be active
members of a port-channel group. In this lab, there are two links between the distribution switches;
therefore, two interfaces on each switch will be congured as a port-channel group.

Task 2: Review Initial Congurations


This task involves performing Layer 2 EtherChannel congurations.
1.

Output from the show cdp neighbors command shows that there are two links between the switches
that can be congured as a port-channel group. Below is sample output from DSW2:
DSW2#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, i - IGMP, r - Repeater
Device ID
Local Intrfce
<output omitted>
DSW1
Fas0/5
DSW1
Fas0/6
<output omitted>

2.

Capability

Platform

146
146

T S
T S

3550
3550

Port ID
Fas 0/5
Fas 0/6

Output from the show ip interface brief command veries that each port can participate in the
EtherChannel conguration. You should see that the line and protocol states of DSW1s and DSW2s
FastEthernet 0/5 and FastEthernet 0/6 interfaces are both up. Below is sample output from DSW2:
DSW2#show ip interface brief
Interface
IP-Address
Vlan1
unassigned
FastEthernet0/1
unassigned
FastEthernet0/2
unassigned
FastEthernet0/3
unassigned
FastEthernet0/4
unassigned
FastEthernet0/5
unassigned
FastEthernet0/6
unassigned
<output omitted>

Holdtme

OK?
YES
YES
YES
YES
YES
YES
YES

Method
NVRAM
unset
unset
unset
unset
unset
unset

Status
up
up
up
up
up
up
up

Protocol
up
up
up
up
up
up
up

Boson NetSim Lab Manual

3.

Output from the show interfaces trunk command shows that an active trunk link exists between DSW1
and DSW2. The link between DSW1 and DSW2, using FastEthernet 0/5 and FastEthernet 0/6, is trunking
using 802.1Q encapsulation. Below is sample output from DSW1:
DSW1#show interfaces trunk
Port
Mode
Fa0/1
desirable
Fa0/2
desirable
Fa0/3
desirable
Fa0/4
desirable
Fa0/5
desirable
Fa0/6
desirable
<output omitted>

4.

Encapsulation
802.1q
802.1q
802.1q
802.1q
802.1q
802.1q

Status
trunking
trunking
trunking
trunking
trunking
trunking

Native vlan
1
1
1
1
1
1

Output from the show spanning-tree vlan 1 command shows the participating ports and the status
of each port. On DSW1, both FastEthernet 0/5 and FastEthernet 0/6 are forwarding (FWD). On DSW2,
only one interface is forwarding and the other is blocking (BLK). Below is sample output from DSW1 and
DSW2:
DSW1#show spanning-tree vlan 1
VLAN0001
Spanning tree enabled protocol pvst
Root ID
Priority
24576
Address
000C.1380.3538
This bridge is the root
Hello Time
2 sec Max Age 20 sec
Bridge ID

Priority
24576
Address
000C.1380.3538
Hello Time
2 sec Max Age 20 sec
Aging Time 15

Interface
------------------Fa0/1
Fa0/2
Fa0/3
Fa0/4
Fa0/5
Fa0/6
Fa0/7
Fa0/8
Fa0/9
Fa0/10

Role
---Desg
Desg
Desg
Desg
Desg
Desg
Desg
Desg
Desg
Desg

Sts
--FWD
FWD
FWD
FWD
FWD
FWD
FWD
FWD
FWD
FWD

Cost
--------0
0
0
0
0
0
0
0
0
0

Prio.Nbr
-------128.1
128.2
128.3
128.4
128.5
128.6
128.7
128.8
128.9
128.10

Forward Delay 15 sec

Forward Delay 15 sec

Type
-----------------------------P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p

(continued on next page)

Boson NetSim Lab Manual

(continued from previous page)


DSW2#show spanning-tree vlan 1
VLAN0001
Spanning tree enabled protocol pvst
Root ID
Priority
24576
Address
000C.1380.3538
Cost
19
Hello Time
2 sec Max Age 20 sec
Bridge ID

Forward Delay 15 sec

Priority
28672
Address
000C.2449.5119
Hello Time
2 sec Max Age 20 sec
Aging Time 15

Interface
------------------Fa0/1
Fa0/2
Fa0/3
Fa0/4
Fa0/5
Fa0/6
Fa0/7
Fa0/8
Fa0/9
Fa0/10

Role
---Desg
Desg
Desg
Desg
Root
Desg
Desg
Desg
Desg
Desg

Sts
--BLK
BLK
BLK
BLK
FWD
BLK
BLK
BLK
BLK
BLK

Cost
--------38
38
38
38
19
19
38
38
38
38

Prio.Nbr
-------128.1
128.2
128.3
128.4
128.5
128.6
128.7
128.8
128.9
128.10

Forward Delay 15 sec


Type
-----------------------------P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p

5.

A requirement of EtherChannel is that all ports must be identically congured before a port-channel group
can be created. The interface congurations on DSW1 and DSW2 have default congurations when the
lab was loaded. In this lab, you can verify the congurations on DSW1 and DSW2 by issuing the show
running-cong command.

6.

EtherChannel mode on will bundle interfaces irrespective of the conguration of the interfaces on the
opposite side of the link. Once interfaces are up and bundled, the port-channel interface will change to
an up state and is added to the spanning tree as a single logical link, replacing the bundled member
interfaces. You should shut down the interfaces before conguring Etherchannel on mode to prevent a
spanning tree loop. Issue the following commands to congure the FastEthernet 0/5 and FastEthernet
0/6 interfaces on DSW1 and DSW2 as members of port-channel group 1 by using the on mode; this will
enable Layer 2 EtherChannel, which does not use an aggregation protocol.
DSW1(config)#interface range fastethernet 0/5 - 6
DSW1(config-if-range)#shutdown
DSW1(config-if-range)#channel-group 1 mode on
DSW2(config)#interface range fastethernet 0/5 - 6
DSW2(config-if-range)#shutdown
DSW2(config-if-range)#channel-group 1 mode on
DSW1(config-if-range)#no shutdown
DSW2(config-if-range)#no shutdown

Boson NetSim Lab Manual

7.

You should issue the show ip interface brief command on each switch to verify that the new,
automatically created port-channel 1 interfaces exist on both switches. Below is sample output from
DSW1:
DSW1#show ip interface brief
Interface
IP-Address
Vlan1
unassigned
FastEthernet0/1
unassigned
FastEthernet0/2
unassigned
FastEthernet0/3
unassigned
FastEthernet0/4
unassigned
FastEthernet0/5
unassigned
FastEthernet0/6
unassigned
FastEthernet0/7
unassigned
FastEthernet0/8
unassigned
FastEthernet0/9
unassigned
FastEthernet0/10
unassigned
FastEthernet0/11
unassigned
FastEthernet0/12
unassigned
GigabitEthernet0/1 unassigned
GigabitEthernet0/2 unassigned
Port-channel1
unassigned

8.

OK?
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES
YES

Method
NVRAM
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset
unset

Status
up
up
up
up
up
up
up
up
up
up
up
down
down
down
down
up

Protocol
up
up
up
up
up
up
up
up
up
up
up
down
down
down
down
up

EtherChannel will support trafc for only a single VLAN unless trunking is enabled. Because this lab uses
3550 switches, the default trunking mode is set to dynamic desirable and the trunk encapsulation is set
to auto. This means that a trunk will automatically form.
You should issue the show interfaces trunk command on each switch to observe that an active trunk
link exists between the two switches. Below is sample output from DSW2:
DSW2#show interfaces trunk
Port
Mode
Encapsulation
Fa0/1
desirable
802.1q
Fa0/2
desirable
802.1q
Fa0/3
desirable
802.1q
Fa0/4
desirable
802.1q
Fa0/5
desirable
802.1q
Fa0/6
desirable
802.1q
Fa0/7
desirable
802.1q
Fa0/8
desirable
802.1q
Fa0/9
desirable
802.1q
Fa0/10
desirable
802.1q
Po1
desirable
802.1q
<output omitted>

10

Status
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking

Native vlan
1
1
1
1
1
1
1
1
1
1
1

Boson NetSim Lab Manual

9.

Once you create a port-channel group, all interfaces in the group are congured from the port-channel
interface for the group. You should issue the following commands to change the trunking mode to form
a trunk unconditionally and force the encapsulation to 802.1Q on the port-channel 1 interface of the
switches:
DSW1(config)#interface port-channel 1
DSW1(config-if)#switchport trunk encapsulation dot1q
DSW1(config-if)#switchport mode trunk
DSW2(config)#interface port-channel 1
DSW2(config-if)#switchport trunk encapsulation dot1q
DSW2(config-if)#switchport mode trunk

10.

You should issue the show interfaces trunk command on each switch to observe that an active trunk
link now exists on the port-channel 1 interface of both of the switches. You should also notice that Fa0/5
and Fa0/6 are not listed in the output because they are members of the port channel. Below is sample
output from DSW1:
DSW2#show interfaces trunk
Port
Mode
Encapsulation
Fa0/1
desirable
802.1q
Fa0/2
desirable
802.1q
Fa0/3
desirable
802.1q
Fa0/4
desirable
802.1q
Fa0/7
desirable
802.1q
Fa0/8
desirable
802.1q
Fa0/9
desirable
802.1q
Fa0/10
desirable
802.1q
Po1
on
802.1q
<output omitted>

11

Status
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking
trunking

Native vlan
1
1
1
1
1
1
1
1
1

Boson NetSim Lab Manual

11.

You should issue the show spanning-tree vlan 1 command on each switch to observe the participating
ports and their status. As you can see, the Port-Channel 1 interface on both switches is in the Forwarding
state. You should also notice that Fa0/5 and Fa0/6 are not listed in the output because they are members
of the port channel. Below is sample output from DSW2:
DSW2#show spanning-tree vlan 1
VLAN0001
Spanning tree enabled protocol pvst
Root ID
Priority
24576
Address
000C.1380.3538
Cost
19
Hello Time
2 sec Max Age 20 sec
Bridge ID

Priority
28672
Address
000C.2449.5119
Hello Time
2 sec Max Age 20 sec
Aging Time 15

Interface
------------------Fa0/1
Fa0/2
Fa0/3
Fa0/4
Fa0/7
Fa0/8
Fa0/9
Fa0/10
Po1

12.

Role
---Desg
Desg
Desg
Desg
Desg
Desg
Desg
Desg
Root

Sts
--BLK
BLK
BLK
BLK
BLK
BLK
BLK
BLK
FWD

Cost
--------38
38
38
38
38
38
38
38
19

Prio.Nbr
-------128.1
128.2
128.3
128.4
128.7
128.8
128.9
128.10
128.16

Forward Delay 15 sec

Forward Delay 15 sec


Type
---------------------------P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p
P2p

Now that EtherChannel is operational, you should issue the show interfaces port-channel 1 command.
The output shows that a bandwidth of 200 Mbps is now available between DSW1 and DSW2. Below is
sample output from DSW1:
DSW1#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is EtherChannel, address is 000C.4122.3594 (bia 000C.4122.3594)
MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Auto-duplex, Auto-speed
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 02:29:44, output never, output hang never
Last clearing of show interface counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queuing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
269 packets input, 71059 bytes, 0 no buffer
Received 6 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
7290 packets output, 429075 bytes, 0 underruns
0 output errors, 3 interface resets
0 output buffer failures, 0 output buffers swapped out

12

Boson NetSim Lab Manual

Task 3: Verify Congurations


This task involves verifying that EtherChannel is functioning properly.
1.

To verify your conguration, you can issue the show etherchannel port-channel command and the
show etherchannel summary command on both DSW1 and DSW2. You should note in the following
sample output from DSW1 that an aggregation protocol is not in use (Port-channel Ag-Not-Inuse)
and that Port-Channel 1 is in use operating in Layer 2 mode (US); sample output from both devices is
shown below:
DSW1#show etherchannel port-channel
Channel-group listing:
---------------------Group: 1
---------Port-channels in the group:
--------------------------Port-channel: Po1
-----------Age of the Port-channel
= 00h:12m:07s
Logical slot/port
= 2/1
Number of ports = 2
GC
= 0x00000101
HotStandBy port = null
Port State
= Port-channel Ag-Not-Inuse
Protocol
=
Port security
= Disabled
Time since last port bundled:
00h:12m:07s
Fa0/6

DSW1#show
Flags: D
I
H
R
U
M
u
w
d

etherchannel summary
- down
P - bundled in port-channel
- stand-along s - suspended
- Hot-standby (LACP only)
- Layer3
S - Layer2
- in use
f - failed to allocate aggregator
-

not in use, minimum links not met


unsuitable for bundling
waiting to be aggregated
default port

Number of channel-groups in use: 1


Number of aggregators:
1
Group Port-channel Protocol
Ports
--------------------------------------------------------------1
Po1(US)
Fa0/5(P)
Fa0/6(P)

13

Boson NetSim Lab Manual

Sample Conguration Scripts


DSW1
DSW1#show running-config
Building configuration...
Current configuration : 1204 bytes
!
Version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSW1
ip cef
!
ip subnet-zero
!
no ip domain-lookup
spanning-tree mode pvst
spanning-tree vlan 1 priority 24576
spanning-tree extend system-id
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on

DSW1 (continued)
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan 1
no ip address
no ip route-cache
!
ip classless
no ip http server
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Copyright 19962012 Boson Software, LLC. All rights reserved. NetSim software and documentation are protected by copyright law.

14

Boson NetSim Lab Manual

You might also like