You are on page 1of 4

BGP is recommend to run b/n AS. This is considered as EGP protocol.

This BGP
works on top of TCP. In BGP we do not use multicast for discovering neighbor since
its works on TCP. BGP works on TCP 179.Because it is TCP ,we need to statitically
configure. The neighbor will not be seen unless we issue the neighbor command
because of this TCP.
BGP b/n AS is called eBGP. A BGP session in an AS is called iBGP.
Peer relationship is established using IP address of interface closest to the peer
router.
When using the loopback address, we need to use neighbor update-source.
Loopback interface is logical interface and it will go down only if the router goes
down.
BGP depends MPLS VPNs for load balancing. BGP alone cannot do load balancing.
Part 2
Protocol designed for internet. There is no as such metric (hop count for RIP, bw and
dealy for EIGRP, cost for OSPF ) for BGP , but there is attributes. Neighbors are not
dynamically discovered.
iBGP AD is 200 and eBGP AD is 20.
BGP is connection oriented protocol.
For eBGP ,the neighbor need to be directly connected. The packet is send with
TTL 1
For iBGP, the neighbor need not be directly connected. The packet is send with
TTL 255.
Once the neighbor is established, it sends keepalive every 60 seconds.
Commands like ebgp-multihop and TTL security can be used to alter the TTL values
The command neighbor 4.4.4.4 ebgp-multihop 2 (This increases the TTL value
to 2 , when trying to form neighborship between loopbacks of eBGP peers). In iBGP
we dont need to use ebgp-multihop.
PART 4
BGP has loop prevention mechanism.
In iBGP , loop prevention is called split horizon. This is different from that of RIP.
Split horizon in iBGP Route learned from an iBGP should not be given to other iBGP
, eventhough it can give to eBGP.
The fully mesh topology can resolve the looping issue, when u dont have layer 2
switch in the middle.
This can be done by giving logical connection ,by saying the neighbor command of
loopback interface.
IBGP should be provided in all the routers.
eBGPs address will be carried when it is advertised to another iBGP, the source
address will not be changed. When a route is learned from eBGP , the eBGPs
address is carried inside the iBGP.

The path should be valid and best to be in the routing table.


Solution is next hop self.
Neighbor 23.0.0.2 next-hop-self
neighbor 12.0.0.1 next-hop-self
..then it becomes valid and best , and hence it will be seen in the routing table.

BGP Authentication
router bgp
neighbor 11.0.0.2 remote 20
neighbor 11.0.0.2 password 1234
Same has to be done in other router as well and the password should be same. The
passwords are not send in clear text , but in MD5
When we want to advertise network which is subnetted, we have to say the mask
command.
network 1.1.1.0 mask 255.255.255.0
if the class is not subnetted(if it is default mask), we just say network 111.0.0.0

PART 6 Attributes
They are rich metric. RIP (hop count) EIGRP(bandwidth and delay) OSPF (cost). In
BGP we dont have metric, we have attributes.
Attributes are like plug and play.
There are 0-11 attributes.
Multihoming means, one AS is connected to 2 or more Ass
0 (Valid reachable next hop)
1 weight , cisco proprietory. By default the weightage will be 0 for all the routers.
The highest
weightage will win. If one router needs to go through one path,
we can say increased weight on that router.
2- Local preference , by default is 100. Higher no is preferred. This is local to AS.
Every router in the AS takes the increased local preference. It is not transited to the
next AS
3-Origin , Locally originated is more preferred than other AS.
4- AS path , shortest AS path is preferred.
5- I > ? internal (network command) , > ? (re distributed )
6 MED MultiExitDiscriminator , by default MED is 0 , Lower is perfered. MED is
affecting the neighbor autonomous system. It is transited to the next AS
The above attributes we can adjust, the below attributes we cant make any control.
7 eBGP > iBGP

8- lowest IGP cost


9- It prefers earliest neighbor the first neighbor
10-neighbor with the smallest router ID
11- smallest neighbor IP address.

PART 7
If there is no mesh connectivity, there will be split horizon issue. To solve split
horizon issue without making fully mesh is BGP confideration and Route
Reflector.
Instead of having many neighbor, the routers will have only directly connected
neighbors.
To overwrite splithorizon issue, we have Route Reflector. We are going to reflect the
routes.
neighbor 3.3.3.3 route-reflector-client to be said on R5 and neighbor 5.5.5.5 routereflector client onR3
BGP confideration
This is done by creating sub autonomous system within the autonomous system
and then making eBGP relation b/n two sub autonomous system.
Attributes
Well known attribute AS path, Next hop, Origin,
Optional Local preference, MED, Others
Route map the map that we write to use to decide the route
First say access list and then give the route map
access-list 1 deny 46.0.0.0 0.0.255.255.255 ---- > add this on route map
route map FILTER
match ip address 1
..now redistributing via route map, redistribute connected route-map FILTER
Whenever we do attribute we need to make reset. There is hard reset and soft reset.
hard reset clear ip bgp * disconnect the neighbor and re establish the neibhor
soft reset clear ip bgp * soft this will not terminate the neighbor, and restablish
Weight is non transitive, ie it will not be send to next router. By default is 0
neighbor 12.0.0.2 weight 100
end
clear ip bgp * soft
Local Preference is flooded to all routers in the same autonomous system ,but not
to other AS.
Hence it is transitive but partial. Default is 100

router bgp 10
bgp default local-preference 200
MED is for chosing the path b/n AS. Smaller is preferred. MED is affecting other AS
path selection.
router bgp 10
default-metric

You might also like