You are on page 1of 26

Introduction System administrator tasks A system administrator is responsible for the following : Installing and configuring Establishing security

y enforcements Applying updates and configuration changes Troubleshooting reported errors Performance monitoring and tuning User handling Activities before putting a server in production such as erection, installation, configuration, hardening, etc will be done by Project Management team. Activities to maintain the server after handing over to production such as applying updates, troubleshooting, performance issues and user issues are taken care by breakfix or Incident Management team. Operating system An operating system is an interface between user and the hardware. A Kernel is the layer of operating system that takes commands from user, converts it as machine understandable form to execute and provide the result in user understandable form. UNIX flavours Unix is a multiuser, multitasking operating system. Unix is a filebased operating system It was developed initially by AT&T. IBM, HP and SUN modified unix according to their hardware to provide more robust and reliable system. Unix from different vendors are called as flavours. HP-UX, Solaris and AIX (Advanced Interactive eXecutive) are the three prominent flavours of UNIX. Other than these SCO (Santa Cruz Operations) unix and LINUX (from Red Hat) are also popular flavours. Basic UNIX Tree structure Unix follows the inverted tree structure. The top level being the root directory having various levels of subdirectories. Files could be added at any level of subdirectory.

/ |_ <etc> => startup files |_ <dev> => devices |_ /home => home directories |_ /usr => system files | |_ <bin> => basic commands | |_ <sbin> => admin commands |_ /tmp => temporary filesystem |_ /boot => boot data |_ /paging => virtual memory |_ /var => Maintains log details |_ /opt => Optional filesystem Directories and files Unix is case sensitive and all commands should be typed in lowercase. pwd print working directory or present working directory, displays the current directory. mkdir test make directory, makes a subdirectory with the name test under current directory. cd test change directory, changes present directory to test. cd .. changes the present directory to the parent directory. cd changes to home directory. Absolute and relative path An absolute path starts with the root directory and a relative path is with reference to present working directory. cd /usr/bin changes working directory from anywhere in the tree. cd ../sbin changes working directory related to the current working directory. Absolute paths can be used with any command

mkdir /tmp/class creates a subdirectory class under existing tmp directory. rmdir /tmp/class remove directory, deletes the directory at the end of the given path. The directory to be removed should be empty. Directory cannot be deleted if it is the current working directory. ls list, lists the files in the current directory. ls sam* lists files whose names are starting with sam in the current directory. ls /home lists files in the directory home. Options are available for many commands which will modify the output of the command providing additional information. They are also called as flags. ls a lists hidden files. Any file starting with a period (.) is a hidden file. ls t sorts the list by time with the latest file at the top. ls tr displays the sorted list with the oldest file at the top. ls l lists in long format. Type, permissions, owner, size, etc., are displayed. Information provided are :Type and permission No. of links Owner Group File size in bytes Date Time (year is displayed for older files) Filename File permissions The first character of the permission column indicates the type of the file. Heifen (-) indicates a file

d indicates a directory l indicates a link. Next nine characters gives the permission, grouped as user, group and others, having 3 charecters in each group. Characters 2 to 4 gives permission to users (owner of the file) Characters 5 to 7 gives permission to group Characters 8 to 10 gives permission to others Read, write and execute permissions are denoted by presence of r, w and x in the respective positions for each group. Absence of the letter indicates that permission is not given. Permission and ownership could be changed chmod 764 /opt/newpass changes the permission of the file as rwxrw-r-r =4; w=2; x=1 are the weightages for read, write and execute. 774 is the permission for all 3 groups, digits indiacating the permission for user, group and others respectively. To give full access of read, write and execute to user 4+2+1=7 is placed as the first digit. To give read and write access to the group 4+2=6 is placed in the second digit. Only read access to others is given as the third digit is 4. chmod g-w,o+x /etc/newpass removes write permission to group and gives execute permission to others resulting in rwxr--r-x cat /etc/passwd displays the contents of the file passwd in the directory etc. If the file has more number of lines, the screen scrolls and the last part of the file stays in the screen.

pg /etc/passwd displays the contents of the file, one screen and waits for user to press enter to display the next screen. more /etc/passwd displays one screen, and has additional features like scrolling back. Redirecting output of one command as input to the next command could be done by using the pipe(|) symbol ls l | more displays the output of the command including the features of the more. Redirecting output to a file is also possible using the (>) symbol ls l > /tmp/list stores the output in the given file instead of displaying in the screen. head -10 /etc/passwd displays first 10 lines of the file. tail -10 /etc/passwd displays last 10 lines of the file. cp /etc/passwd /tmp/password copies file passwd to tmp directory with new name. cp /tmp/password /home copies file password to the new location with the same name. mv /home/password /opt moves file password to new location. It is deleted from original location after the completion of the command.

mv /opt/password /opt/newpass renames a file if specified in the same directory. ln /opt/newpass /opt/linkpass gives an additional name for the file. The file remains with the new name even if the original is deleted. This is a hardlink and could be used only with files within the same filesystem. Hardlink could not be used with directories. ln s /tmp /home/temp creates a softlink to the directory tmp which could be accessed as a subdirectory of home directory. rm /opt/newpass deletes a file. grep filter grep is a filter available for pattern matching. grep system /etc/passwd displays lines that contains the work system in the given file. cat /etc/passwd | grep system result is same as the above command. ls l | grep i test The flag is used to ignore case while matching. vi editor Command mode : to use alphabets to control the text. Input mode : to type alphabets and characters as part of the text. Editor will be in command mode when it is started. Esc key is used as prefix before commands. Esc i put vi in input mode and Esc gets back to command mode. vi /opt/newpass opens the file in vi editor. If the file does not exist already a blank editor opens and the file will be created by issuing a save command. :wq Saves file and quits editor. :w

Saves and continues to be in editor. :q Quits editor. :q! Quits editor without saving the changes. Cursor movement h left l right k up j down w next word b previous word 0 beginning of line Shift + a - end of line Ctrl + f one screen forward Ctrl + b one screen backward Shift + h first line Shift + G last line Text insertion i insert before cursor a insert after cursor o new line below O new line above Text editing cw change word dw delete word dd delete line Copying and moving yy copy line dd cut line p paste a number could be added before the above commands to repeat command for that many times. 4yy copies 4 lines. 4dw deletes 4 words. Processes A program while running is called as a process. Every process will be assigned a unique number called Process Identifier.

ps displays the list of process running. ps ef displays all processes running in the system with more details. An & should be added at the end of the command to run as a background process. This returns to command prompt as the process continues to run at the background, Whereas the process running at the foreground does not give the command prompt till it completes. Ctrl + c is used to terminate a foreground process and get back to command prompt. For terminating a background process, its process id should be found and killed using the kill command. Shells and variables A shell is a working environment. Depending on the type of usage shell could be provided to users. End user or data entry operator does not need system management commands. They will be using basic commands. System administrators will be using the system management commands. Bourne shell :- sh Simple shell for end user. Displays $ as the prompt. Korn shell :- ksh Provides additional constructs. Displays $ as the prompt C shell :- csh Provides programming features. Displays % as the prompt The prompt will be # if the user is logged as root Changing shells :Every user is assigned a default shell and will be in that shell on login. This could be changed by entering sh, ksh or csh in the command line. exit brings back to the previous shell. The characteristics of a shell are controlled by environment variables. SHELL default shell TERM terminal type LOGNAME login name

HOME home directory PS1 prompt echo $LOGNAME displays the content of the variable LOGNAME. Apart from environment variable users can also have their own variables. cppath = /tmp/test sets variable cppath and assigns the value to it. This could be used with any command where the assigned value to be used. echo $cppath displays the assigned value. Variables are local to the shell by default and could not be accesses if the shell is changed. These could be made as global variables if they are exported. export cppath makes cppath as a global variable, thus could be accessed in all the shells. Variables are confined to the current login session only and will not be available for future login sessions. These can be entered in a special file to be executed each time a user logs in. A file in the home directory of every user is executed everytime the user logs in. That file is the .profile file for bourne and korn shells. If the variable declaration, initialization and export commands are entered in this file, it will be executed on every login and is available without being executed manually. Root user will have the profile file in the etc directory. For C shell the home directory will have .login file for users cron jobs Commands to be run automatically at the specified time could be submitted to cron. The information will be stored in specific files and will be executed at the mentioned times. crontab l displays the currently submitted cron jobs. crontab -e allows to edit the crontab to add or delete jobs. Uses vi editor commands.

Each line in the crontab is a separate job. The line should begin with the date and time details in 5 columns. minute hour date month day 0-59 0-23 0-31 1-12 0-7 command

* in any column indicates all possible values. Distinct values or range could also be given. The jobs submitted are stored in a file with the username as the filename in /var/spool/cron/crontabs. /var/adm/cron/cron.allow file contains usernames who are allowed to submit cron jobs. All other users are denied. /var/adm/cron/cron.deny file contains usernames who are denied to submit cron jobs. All other users are allowed. Pseries and AIX introduction Classification of microprocessors Complex instruction set computers (CISC) and Reduced Instruction set computers (RISC) are two classification of computers based on the number of instructions that could be executed. RISC system has fewer instructions and are faster and reliable. IBM system series IBM has the following series of systems x series intel based systems z series Mainframe systems i series AS/400 systems p series RISC systems P series evolution IBM introduced RISC System (RS/6000) in 1986. Performance Optimized With Enhanced Risc (POWER) system was introduced in 1990. Which was the starting of the pseries.

Power 2 was introduced in 1993 and power 3 in 1999. New naming as eserver pseries was given on 2000 and power 4 was introduced. Regatta was introduced in 2001 which included LPARs.
Models : p690, p670, p650, p595, p570, 7026 -6H1, 7017-S85, H80, 7028, 7013-59H, 7038

Power 5 : p510,p520,p550,p570, p575, p590, p595 Power 4 : p615,p630,p650,p670,p655,p690 AIX versions AIX was introduced even before the pseries during the initial RS/6000 days in 1986. The initial version is 1.3 Version 3.0 was introduced in 1990 which included LVM and SMIT. Version 3.1 introduced Journalled File System (JFS) Version 4.2 in april 1997 supported nfs3 Version 4.3 provided support for 64 bit architecture and online backup Version 5.1 in May,2001 is the minimum level for power4 systems. 64 bit kernel, jfs2 and LPAR are introduced. Version 5.2 introduced mpio fiber channel, DLPAR and is the minimum level for power5 systems. Version 5.3 is the current AIX version and includes VIO and micro partitioning, and filesystem shrink. OS Installation Installation types New and Complete Overwrite - Done on a new machine - Done when rootvg is corrupted Migration - Done for upgrading OS version - /tmp is overwritten

Preservation - Preserves only user data - /usr, /tmp, /var, / are overwritten (recreated) - /etc/preserve.list contains a list to be preserved Trusted Computing Base It enforces information security It monitors every file in the /dev directory It also monitors 600 other files which are listed in /etc/security/sysck.cfg It can be enabled only during installation /usr/bin/tcbck displays usage if it is enabled. Installation methods [NIM, alt_disk_install] AIX comes in CDs and can be installed using CD ROM. NIM(Network Install Management) facilitates installtion using a network source, avoiding human assistance at the server location. This can be accomplished from remote location. The installable resources will be created on a NIM master and the NIM client can be installed with AIX operating system. Alt_disk_install is a method used during OS migration. The mirror will be broken and the new version will be installed in one of the disks. The system will be available during the time with the existing version. After installation on one of the disk, the system will be booted with that disk and tested. If everything is fine the old version can be removed. If the new version gives some issues, old version can be used. ODM and device configuration Objects and Classes The basic components of ODM are object classes and objects. Object - an entity that requires storage and management of data object class - A group of objects with the same definition Object Descriptors - Variable name with type Disk is a class, which defines some the characteristics any disk should possess. A physical harddisk is Object Data Manager System data managed by ODM includes: Network configuration Logical volume management configuration Installed software information Devices that AIX has drivers for

Logical devices or software drivers Physical hardware device installed Menus, screens and commands that SMIT uses Location of ODM /etc/objrepos - Main location for the ODM /usr/lib/objrepos /usr/share/lib/objrepos This settings is in - > /etc/environment ODMDIR = /etc/objrepos Types of Databases predefined and customized Predefined database - > PdDv Devices that are supported but not currently installed /usr/lib/objrepos Customized Database - > CuDv Devices found and configured /etc/objrepos ODM commands odmadd - Add an object to class odmchange - to change a specfefic object in aclass odmdelete - to delete an object odmcreate - > created an empty object class odmdrop - delete a odm object class odmget - list the objects in the obj class odmshow - list the properities of the odb class Device status Available and defined Available users can access the device Defined Device available in ODM, users cannot access Handling devices list, change, remove, make lsdev - displays device and charecteristics lscfg - displays configuration lsattr - displays attributes with values cdcux57:root:/>lsdev -l ent0 ent0 Available 20-70 IBM 10/100 Mbps Ethernet PCI Adapter (23100020) cdcux57:root:/>lscfg -vl ent0 ent0 U0.1-P1-I4/E1 IBM 10/100 Mbps Ethernet PCI Adapter (23100020)

Serial Number...............02092195 FRU Number..................091H0397 Part Number.................091H0397 Network Address.............0004AC5ED4A3 Displayable Message.........PCI Ethernet Adapter (23100020) Device Specific.(YL)........U0.1-P1-I4/E1 cdcux57:root:/>lsattr -El ent0 alt_addr 0x000000000000 ALTERNATE ETHERNET address busintr 25 Bus interrupt level False busio 0x7ff800 Bus I/O address False fast_reset yes Enable Fast Reset True intr_priority 3 Interrupt priority False ip_gap 96 Inter-Packet Gap True mcast_filter no Enable Multicast Filtering True media_speed 100_Full_Duplex Media Speed True poll_link no Enable Link Polling True poll_link_timer 500 Time interval for Link Polling True rx_hog 1000 RX buffers processed per RX interrupt True rx_que_size 256 RECEIVE queue size True rxbuf_pool_size 384 RECEIVE buffer pool size True slih_hog 10 Interrupt events processed per interrupt True tx_que_size 8192 TRANSMIT queue size True use_alt_addr no Enable ALTERNATE ETHERNET address cdcux57:root:/> Changing a device The attributes given as True can be changed by using chdev command. chdev l ent0 a media_speed=auto Removing a device rmdev l ent0 The above command will remove the device from usage and take it defined state. The device is still available on the ODM. rmdev dl ent0 The d flag will remove the device from ODM and thus completely removing from the system. To physically remove a device, this option should be used. Configuring devices cfgmgr, mkdev True

True

A device in defined state can be brought back as available because ODM has its information. mkdev l ent0 A device removed from ODM or a new device connected to the system can be configured by the following. cfgmgr This will configure and make the device available. Some devices sys0 entire system sysplanar0 system board ent0 Ethernet card mem0 - memory hdisk0 hard disk rmt0 tape drive fcs0 fiber adapter ide0 IDE I/O adapter scsi0 SCSI adapter proc0 Processor The first device of a type will have 0 as suffix to the name and the consecutive devices of the same type will get 1,2,3 and so on. System Resource Controller http://publib.boulder.ibm.com/infocenter/pseries/v5r3/index.jsp? topic=/com.ibm.aix.baseadmn/doc/baseadmndita/sysrescon.htm The SRC provides a single set of commands to start, stop, trace, refresh, and query the status of a subsystem
The System Resource Controller (SRC) is started during system initialization with a record for the /usr/sbin/srcmstr daemon in the /etc/inittab file.

Daemon A process running continuously at the background to provide an additional feature or perform an activity of an operating system. Subsystem and subserver

A subsystem is any program or process or set of programs or processes that is usually capable of operating independently or with a controlling system. A subsystem is designed as a unit to provide a designated function

A subsystem as a program or set of related programs designed as a unit to perform related functions A subserver, commonly known to UNIX programmers as a daemon, is a process that belongs to and is controlled by a subsystem
The System Resource Controller hierarchy begins with the operating system followed by a subsystem group (such as tcpip), which contains a subsystem (such as the inetd daemon), which in turn can own several subservers (such as the ftp daemon and the finger command).

SRC list, start, stop and refresh dupprt04:/>lssrc -g tcpip Subsystem Group PID Status xntpd tcpip 286934 active snmpd tcpip 282808 active hostmibd tcpip 295114 active snmpmibd tcpip 299208 active aixmibd tcpip 311500 active muxatmd tcpip 258216 active inetd tcpip 504020 active dupprt04:/>lssrc -g nfs Subsystem Group PID Status biod nfs 266428 active nfsd nfs 233644 active rpc.mountd nfs 135310 active rpc.statd nfs 315582 active rpc.lockd nfs 307372 active nfsrgyd nfs inoperative gssd nfs inoperative dupprt04:/>lssrc -g spooler Subsystem Group PID Status qdaemon spooler 225462 active writesrv spooler 291008 active lpd spooler 168140 active dupprt04:/> lssrc s inetd [lists the information about inetd subsystem

lssrc t ftp startsrc stopsrc refresh

[lists the information about ftp subserver

-s for sybsystem -t for subserver -g for group Software Installation http://www.ibm.com/developerworks/aix/library/au-dutta_work.html Filesets It is a smallest unit of installation Package and LPP Package is a set of related filesets. LPP(licensed program package) is a group of related packages and filesets. APAR and PTF Program Temporary Fix is an immediate solution to a reported problem. A report is associated a Problem Management Report(PMR) number. An Authorized Program Analysis
Report (APAR) associates a fix to a PMR. APARs will be assigned a unique number like IY18782

Maintenance and Technology levels

A Maintenance Level (ML) is the service updates that are necessary to upgrade the base operating system (BOS) or an optional software product to the current release level. Starting in 2006, as part of the new AIX 5L Service Strategy, MLs are replaced by Technology Levels (TLs). They are defined below. Technology Level A Technology Level (TL) is the new term for the twice yearly AIX 5L releases, which contain new hardware and software features and service updates. The first TL will be restricted to hardware features and enablement, as well as software service. The second TL will include hardware features and enablement, software service, and new software features. Installing a TL should be viewed as an "all or nothing" operation, meaning that requisites will be added so that the whole TL is installed, and not allow a TL to be partially installed. You should back up your system prior to installing a TL. Service Pack A Service Pack (SP) consists of service-only updates (also known as PTF's) that are released between Technology Levels to be grouped together for easier identification. These fixes address highly pervasive, critical, or security-related issues. Service Packs are provided for the N and N-1 releases (for example, V5.3 and V5.2) on the latest Technology Level for each release (for example, 5300-04 and 5200-08). Concluding Service Pack Concluding Service Pack (CSP) is the last Service Pack for a Technology Level. The CSP contains fixes for highly pervasive, critical, or security-related issues just like a Service Pack, but it might also contain fixes from the newly released Technology Level that fall into these categories. Therefore, a CSP contains a very small subset of service that was just released as a part of a new Technology Level. CSPs allow for extended service on a Technology Level through the utilization of Interim Fixes. Interim Fix

The term Interim Fix is used as a replacement for "emergency fix" or "efix". While the term emergency fix is still applicable in some situations (a fix given in the middle of the night with minimal testing), the term Interim Fix is more descriptive in that it implies a temporary state until an update can be applied that has been through more extensive testing.

Applied Vs Committed An installed fileset can either be in applied or committed state. A new version of a fileset will be put in applied state. The existing version will be maintained in the system and the new version will be used. If the applied version does not perform well it can be rejected and the previous version maintained at the system will be put back in use. If the new version is found to be perfect, it will be committed. Table of contents Installable files will be of backup file format(.bff) The directory that contains the bff files should also have table of contents file .toc If bff files are copied to a directory the .toc can be created by the command inutoc <directorypath> instfix, installp and lppchk installp is the command used to install filesets, ml and tl. instfix is the command used to install fixes and APARs installp c to commit an applied version installp r to reject an applied version installp u to uninstall committed fileset lslpp l to list all the installed filesets and packages lslpp h to display the fileset history with dates instfix -k IY69289 -d /dev/cd0 to install APAR from the cd. instfix i to list all the installed APARs instfix -ik IY69289 to check whether the APAR is installed instfix i | grep ML to check all APARs are up to date to current ML. lppchk v to check for software consistency. This will report the broken fileset(improperly installed) . installp C will cleanup the broken filesets. Vital Product Data lpp(description and status) displayed in lslpp product(prerequisites) base requirement history(updates) version wise history inventory(files) actual files. A software consists of three parts

/usr contains the part that can be shared with other systems having the same hardware configuration. / contains the part that are individual for the installed system /usr/share contains part that can be shared with any system Logical Volume Manager Concepts PV,PP,VG,LV,LP and FS Default LVs Quoram VGDA, VGSA, LVCB Journalled File System Paging space list, add and remove VG operations mirroring, extending, reducing, syncvg and exporting LV operations create, copy, extend and remove FS operations create, increase, remove, mount and unmount Space commands df and du Sysdump and nfs Boot Process Loading the operating system in memory is called as booting. AIX systems carries out booting in three phases. Phase 1: - Configures base devices Phase 2 :- rootvg is brought online Phase 3 :- All devices and vgs are setup
The initial step in booting a system is the Power On Self Test (POST). Its purpose is to verify that the basic hardware is in a functional state. The memory, keyboard, communication, and audio devices are also initialized System Read Only Storage (ROS) will locate and load bootstrap code. Software ROS (also named bootstrap) forms an IPL control block, takes control and builds specific boot information. A special file system located in memory and named the RAMFS file system is created. Software ROS then locates, loads, and turns control over to the boot logical volume (BLV). A complete list of files that are part of the BLV can be obtained from the /usr/lib/boot directory. The most important components are the following: The kernel Boot commands called during the boot process, such as bootinfo and cfgmgr A reduced version of the ODM. Many devices need to be configured before hd4 is made available, so their corresponding methods have to be stored in the BLV.

The rc.boot script The kernel is loaded and takes control. The kernel will complete the boot process by configuring devices and starting the init process. So far, the system has tested the hardware, found a BLV, created the RAMFS, and started the init process from the BLV. The rootvg has not yet been activated. From now on, the rc.boot script will be called three times, and is passed a different parameter each time. Phase 1 The init process started from RAMFS executes the boot script rc.boot 1 The restbase command is called to copy a partial image of ODM from the BLV into the RAMFS. Base devices are all devices that are necessary to access rootvg. cfgmgr f configures the base devices. The bootinfo -b command is called to determine the last boot device. Phase 2 The rc.boot script is passed to the parameter 2 as rc.boot 2 The rootvg volume group is varied on with the ipl_varyon command. Root file system hd4 is checked using the fsck -f command. This will verify whether the file system was unmounted cleanly before the last shutdown. The root file system (/dev/hd4) is mounted on a temporary mount point (/mnt) in RAMFS. The /usr file system is verified using the fsck -f command and then mounted. The /var file system is verified using the fsck -f command and then mounted. The copycore command checks if a dump occurred. If it did, it is copied from default dump devices, /dev/hd6, to the default copy directory, /var/adm/ras. Afterwards, /var is unmounted. The primary paging space from rootvg, /dev/hd6, will be activated. The mergedev process is called and all /dev files from the RAM file system are copied onto disk. All customized ODM files from the RAM file system are copied to disk. Both ODM versions from hd4 and hd5 are now synchronized. The root file system from rootvg (disk) is mounted over the root file system from the RAMFS. The mount points for the rootvg file systems become available. The /var and /usr file systems from the rootvg are mounted again on their ordinary mount points.

rootvg is activated.

Phase 3
/etc/init process is started. It reads the /etc/inittab file and calls rc.boot with argument 3. The /tmp file system is mounted. rootvg is synchronized by calling the syncvg command. The cfgmgr command is called to configure all other devices that are not base devices. The console is configured by calling the cfgcon command. After the configuration of the console, boot messages are sent to the console. Before this, all boot messages will be copied to alog. The alog command maintains and manages logs. The synchronization of the ODM in the BLV with the ODM from the / (root) file system is done by the savebase command. The syncd daemon and errdemon are started. The LED display is turned off. If the file /etc/nologin exists, it will be removed. This file, if exist, will prevent users other than root from logging into the system. The contents of this file will be displayed as a message for users other than root. The execution of rc.boot is has completed. Process init will continue processing the next command from /etc/inittab.

Networking IP address notation used to identify a network resource inetd daemon inetd daemon provides internet service mgmt, invokes other related deamons only when needed. /etc/inetd.conf file specifies the subservers(ftpd, telnetd, etc) controlled by inetd. /etc/services file specifies the port at which the subserver provides its service. commands ifconfig, entstat, ping, traceroute, netstat, route Every network adapter will have a corresponding interface. ifconfig command configures or displays network interface parameters. ifconfig a display information about all interfaces in the system.

ifconfig en0 192.168.5.25 alias adds an address to interface en0 ifconfig en0 192.168.5.25 delete removes the specified address from en0 ifconfig en0 detach removes network card from the interface list. mktcpip sets values for tcpip
mktcpip -h hostname -a 192.9.200.4 -i en0 -n 192.9.200.1

entstat d ent0 displays the statistics of the device. Details about collisions, MAC address, etc., will be displayed. The link status and connection speed are also given. netstat displays the state of all configured interfaces
(/)> netstat -i Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll en0 1500 link#2 0.60.94.e9.8b.9d 39476281 0 55159681 0 0 en0 1500 52.99.9 asdux02i 39476281 0 55159681 0 0 en1 1500 link#3 0.6.29.6c.88.d3 247102188 0 243097048 0 0 en1 1500 153.116.242 asdux02 247102188 0 243097048 0 0 en2 1500 link#4 0.6.29.6c.b0.2d 310281117 0 1701 0 0 en2 1500 153.116.243 asdux02-bu 310281117 0 1701 0 0 css0 65504 link#5 36326212 0 37558194 0 0 css0 65504 52.99.8 asdux02s 36326212 0 37558194 0 0 lo0 16896 link#1 61901228 0 61928648 0 0 lo0 16896 127 loopback 61901228 0 61928648 0 0 lo0 16896 ::1 61901228 0 61928648 0 0 root@[asdux02]: (/)> netstat -ni Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Coll en0 1500 link#2 0.60.94.e9.8b.9d 39476292 0 55159690 0 0 en0 1500 52.99.9 52.99.9.17 39476292 0 55159690 0 0 en1 1500 link#3 0.6.29.6c.88.d3 247102225 0 243097081 0 0 en1 1500 153.116.242 153.116.242.32 247102225 0 243097081 0 en2 1500 link#4 0.6.29.6c.b0.2d 310281190 0 1701 0 0 en2 1500 153.116.243 153.116.243.63 310281190 0 1701 0 0 css0 65504 link#5 36326222 0 37558203 0 0 css0 65504 52.99.8 52.99.8.17 36326222 0 37558203 0 0 lo0 16896 link#1 61901237 0 61928657 0 0 lo0 16896 127 127.0.0.1 61901237 0 61928657 0 0 lo0 16896 ::1 61901237 0 61928657 0 0 root@[asdux02]: (/)>

netstat r gives the routing table.

(/)> netstat -nr Routing tables Destination Gateway

Flags Refs

Use If PMTU Exp Groups -

Route Tree for Protocol Family 2 (Internet): default 153.116.242.1 UG 9 27923861 en1 - 52.99.4/24 52.99.8.250 UG 0 0 css0 - - -

route command is used to manipulate the routing table. route add default 192.168.5.25 adds another default gateway route delete default 192.168.5.25 removes the IP address from being a default gateway. route add 192.100.201.7 192.100.13.7 Packets reaching 192.100.13.7 will be sent to host with address 192.100.201.7 . route add -net 192.100.201.0 192.100.13.7 Packets reaching 192.100.13.7 will be sent to any host on the destination network. route f clears the routing table. ping command is used to check end to end communication. traceroute command is used to check the hops of the packet. sendmail sendmail.cf Sendmail daemon provides means to send and receive mails and reads /etc/sendmail.cf file. sendmail sparthasarat@csc.com < /etc/motd sends the contents of the file as mail body uuencode /etc/motd newname | mail -s "test mail" sparthasarat@csc.com sends the file as an attachment with given name. Nameserver resolv.conf Lookup Finding the IP address of device based on the hostname Reverse Lookup finding the hostname based on given IP address. /etc/hosts file will contain IP address and hostnames and a IP can be fetched for a given hostname from this file.

The hostname and IP addresses can also be made available on a DNS server where the lookup is performed when it is not available in the /etc/hosts file. The DNS server information is stored in /etc/resolv.conf file. The lookup order can be changed by making appropriate entry in /etc/netsvc.conf file. hosts=local,bind this entry will first search the /etc/hosts file and then the DNS Backup and Restoration System backup - mksysb Tape control tctl Backup strategies Full, Differential, Incremental VG Backup savevg and restvg File Backup backup and restore Compressions tar and gzip Error handling errdemon is started during boot and will serve to capture and report errors. Errors will be stored in /var/adm/ras/errlog file. errpt fetches information and displays in readable format.
(/)> errpt | more IDENTIFIER TIMESTAMP T C RESOURCE_NAME DESCRIPTION AA8AB241 0726050107 T O OPERATOR OPERATOR NOTIFICATION BD797922 0726010007 P H enclosure1 SUBSYSTEM FAILURE BD797922 0726000007 P H enclosure1 SUBSYSTEM FAILURE BD797922 0725230007 P H enclosure1 SUBSYSTEM FAILURE BD797922 0725220007 P H enclosure1 SUBSYSTEM FAILURE

First column is a label. Second column is timestamp in the format MMDDhhmmYY. Third column tells the severity as P for permant, T for temporary errors and I for information. Fourth column shows the type of the resource as S for software, H for hardware. Fifth column gives the resource name and the last column gives the error description. errpt j BD797922 displays only errors with the given label errpt a displays detailed report about all errors. errpt aj BD797922 displays detailed report about the given label.
(/)> errpt -aj BEE2FB4A | more --------------------------------------------------------------------------LABEL: TS_DEATH_TR IDENTIFIER: BEE2FB4A

Date/Time: Wed Jun 5 20:04:03 DFT Sequence Number: 69138 Machine Id: 000219844C00 Node Id: tsdux41 Class: U Type: UNKN Resource Name: hats.tsdcw01 Resource Class: NONE Resource Type: NONE Location: NONE VPD: Description Contact with a neighboring adapter lost Probable Causes The neighboring adapter mal-functioned Networking problem renders neighboring adapter unreachable Failure Causes The neighboring adapter mal-functioned Problem with the network Recommended Actions Verify status of the faulty adapter Verify status of network Detail Data DETECTING MODULE rsct,threephs.C, 1.135.1.11,3944 ERROR ID .8hjsyyH8Zzw.LwI1dYkMo.................... REFERENCE CODE The IP address of the faulty adapter 52.99.8.42 Node number where the adapter is located 7

errclear clears the errors from errlog errclear 0 clears all errors. errclear 5 removes errors before 5 days errclear d S 0 removes software errors errclear T PERM 0 removes permanent errors

errlogger is used to log operator messages. errlogger test error message puts and operator notification. Performance Monitoring vmstat iostat sar svmon topas Tuning - vmo, no and vmtune Print Queue Management Creating print queue smitty queue Checking status lpstat -a Printing a file lp -d qdaemon User Administration Password and group files Commands lsuser, mkuser, passwd, rmuser Environment and limits Miscellaneous commands prtconf uname bootinfo bootlist bindprocessor

You might also like