You are on page 1of 31

DYNAMIC ROUTING

PROTOCOLS

Enabling RIP

RIP
RIP exists in two versions RIP v1, RIP v2
RIP was designed for smaller networks (Max Hop
Count - 15)
Although it lacks the capabilities of many of its
successors, its simplicity and widespread use
Operates from UDP port 520
encapsulated in a UDP (User Datagram Protocol)
segment with both the Source and Destination
Port
fields set
RIP version
1 to that value.
RIP Version 2
Classful Routing

Classless Routing

No Support for IPv6,


Multicast

Supports IPv6, Multicast

Does not advertise Subnet


Mask

Advertise Subnet Mask, Next


Hop

No Summarization Support

Supports Summarization

No VLSM

VLSM

RIP Operation
RIP defines two message types:
Request messages - Used to ask neighboring routers to send
an update
Response messages - Carries the update.

Metric Hop Count


1: Directly Connected Network
16: Un-reachable Network

RIP Process
On startup, RIP broadcasts a packet carrying a Request
message out each RIP-enabled interface
RIP process then enters a loop, listening for RIP Request or
Response messages from other routers
Neighbors receiving the Request send a Response containing
their route table If they have RIP Enabled on that Interface

Destination address of the update is the all-hosts


broadcast 255.255.255.255

RIP Timers and Stability Features


Update Timer 30 Sec
Router's full route table with the exception of entries
suppressed by the split horizon rule
Invalid Timer 180 Sec
use to limit the amount of time a route can stay in a route
table without being updated
Flush Timer 240 Sec
Route will be advertised with the unreachable metric until the
flush timer expires, at which time the route will be removed
from the route table
Holddown Timer 180 Sec
Update with a hop count higher than the metric recorded in
the route table will cause the route to go into holddown for
180 seconds
Router(config)#Router rip
Router(config-router)#timers basic update invalid holddown flush
Timing of all the routers in the RIP domain must be changed

RIP Operation
Administrative Distance 120
Case Study 1 - Classful Routing: Directly
Connected Subnets
Classful route lookups

Case Study 2 - Summarization at Boundary


Routers

IP Routing
Configuration Tasks
Router configuration
Select routing protocols.
Specify networks or
interfaces.

Dynamic Routing
Configuration
Router(config)#router protocol [keyword]

Defines an IP routing protocol

Router(config-router)#network network-number

Mandatory configuration command for each


IP routing process
Identifies the physically connected network that routing
updates are forwarded to

RIP Configuration
Router(config)#router rip

Starts the RIP routing process

Router(config-router)#network network-number

Selects participating attached networks


Requires a major classful network number

RIP Configuration Example

Verifying the RIP


Configuration

Displaying the
IP Routing Table

debug ip rip Command

Case Study 1 Configuring RIP


Enable RIP with the command router rip
Specify each major network on which to run RIP
with the network command
debug ip rip Observe network summarization
and split horizon

Case Study 2 Passive Interfaces

Floyd (Dont Include network 192.168.12.0)


Router rip
Network 192.168.100.0

Will the above method work for Andy Router??


To block RIP broadcasts on an interface connected to a
subnet of a RIP-enabled network.
Makes a router a silent host on the data link specified
Add the passive-interface interface# command to
the RIP process

Case Study 3 Configuring Unicast


Updates

No RIP updates should be exchanged between


Andy and Floyd, but both should exchange
updates with Bea
Addition of a neighbor command under the RIP
processes of Andy enables RIP to send a Unicast
advertisement to Bea's interface
passive-interface command continues to
prevent broadcast updates on the link

Case Study 3 Configuring Unicast


Updates
Beas Rip Configurations
router rip
network 192.168.12.0
network 192.168.200.0
Andys Rip Configuration
router rip
passive-interface Ethernet0
network 172.17.0.0
network 192.168.12.0
network 192.168.83.0
neighbor 192.168.12.67
Floyd RIP Configurations
router rip
passive-interface Ethernet0
network 192.168.12.0
network 192.168.100.0
neighbor 192.168.12.67

Case Study 3 Debug Ip RIP


Andy#debug ip rip events

RIP event debugging is on

Andy#
RIP: received v1 update from 192.168.12.67 on Ethernet0
RIP: Update contains 1 routes
RIP: sending v1 update to 255.255.255.255 via Ethernet1
(192.168.83.1)
RIP: Update contains 4 routes
RIP: Update queued
RIP: Update sent via Ethernet1
RIP: sending v1 update to 255.255.255.255 via Ethernet2
(192.168.12.195)
RIP: Update contains 6 routes
RIP: Update queued
RIP: Update sent via Ethernet2

RIP: sending v1 update to 255.255.255.255 via Serial0 (172.17.1.1)


RIP: Update contains 7 routes
RIP: Update queued

Case Study 3 Debug Ip RIP


RIP: Update sent via Serial0
RIP: sending v1 update to 255.255.255.255 via Serial1
(172.17.2.1)
RIP: Update contains 7 routes
RIP: Update queued
RIP: Update sent via Serial1
RIP: sending v1 update to 192.168.12.67 via Ethernet0
(192.168.12.65)
RIP: Update contains 4 routes
RIP: Update queued
RIP: Update sent via Ethernet0
RIP: received v1 update from 172.17.1.2 on Serial0
RIP: Update contains 1 routes
RIP: received v1 update from 172.17.2.2 on Serial1
RIP: Update contains 1 routes
RIP: received v1 update from 192.168.12.67 on Ethernet0
RIP: Update contains 1 routes

Case Study 4: Discontiguous


Subnets
Classful protocols such as RIP and IGRP cannot
route a topology in which the subnets of network
10.0.0.0 are separated by different networks
Result is Andy will be "fooled into thinking" that it has
two equal-cost paths to the same network
Andy will load share on the links to Barney and Ernest_T
There is now only a 50-50 chance that packets to
network 10.0.0.0 will reach the correct subnet

Case Study 4: Secondary


Addresses
Barney Configuration
interface e0
ip address 10.33.55.1 255.255.240.0 secondary

Andys Configuration

interface e1
ip address 10.33.55.2 255.255.240.0 secondary
interface e2
ip address 10.33.75.1 255.255.240.0 secondary
router rip
network 10.0.0.0

Ernest Configurations
interface e0
ip address 10.33.75.2 255.255.240.0 secondary

Case Study 4: Secondary


Addresses
Secondary addresses are used to connect the

subnets of network 10.0.0.0 across the same links


on which other network addresses exist
The routing process in this router sees the
subnets 192.168.12.192/27 and 10.33.64.0/20 as
separate data links, although they reside on the
same physical interface
Check with Show ip route

Case Study 5: Manipulating RIP


Metrics
RIP metrics must be manipulated so that the two-hop
Ethernet route will be preferred over the one-hop serial
route.
Serial Link as a Back Up Link
The route metrics can be manipulated with the offset-list
command
Offset-list {access-list-number | name} { in | out}
offset [type number]

Case Study 5: Manipulating RIP


Metrics
Ernest_T's RIP configuration with an inbound offset list

access-list 1 permit 10.33.0.0 0.0.0.0


router rip
network 192.168.12.0
network 10.0.0.0
offset-list 1 in 2 Serial0

Barney's RIP configuration with an inbound offset list


router rip
offset-list 5 in 2 Serial0
network 10.0.0.0
network 192.168.83.0
access-list 5 permit 10.33.32.0 0.0.0.0

Examine RIP advertisements incoming from interface S0. For route


entries matching the addresses specified in access list 1, add 2 hops
to the metric

Troubleshooting RIP
Most difficulties with classful protocols such as RIP
involve
misconfigured subnet masks or
discontiguous subnets.
If a route table contains inaccurate or missing
routes, check all subnets for contiguity and all
subnet masks for consistency
When a high-speed router is sending multiple RIP
messages to a low-speed router. In such a case, the
low-speed router might not be able to process
updates as quickly as they are received, and routing
information might be lost.
output-delay delay can be used under the RIP
command to set an inter-packet gap of between 8
and 50 milliseconds

Review Questions

What port does RIP use?


What metric does RIP use? How is the metric used to
indicate an unreachable network?
What is the update period for RIP?
How many updates must be missed before a route entry
will be marked as unreachable?
What is the purpose of the garbage collection timer?
Why is a random timer associated with triggered updates?
What is the range of this timer?
What is the difference between a RIP Request message and
a RIP Response message?
Which two types of Request messages does RIP use?
Under what circumstances will a RIP response be sent?
Why does RIP hide subnets at major network boundaries?

Configuration Examples
Write configurations for six routers in Figure to route to all
subnets via RIP

Change the configurations of Configuration Exercise 1 so that RIP


updates are unicast between RTC and RTD, instead of broadcast.
The bandwidth of the serial link between RTC and RTD in Figure is
very limited. Configure RIP to send updates across this link every
two minutes. Carefully consider what timers must be changed
and on what routers the timers must be changed.

Configuration Examples

A policy has been established that dictates that network


192.168.4.0 should be unreachable from RTA and that
network 192.168.5.0 should be unreachable from RTB. Use
one or more offset lists to implement this policy.
Subnet masks within a major, class-level network must be
consistent. The section does not, however, say that subnet
masks within a major, class-level network must be identical.
The RIP configuration for both routers in Figure follows:
router rip network 192.168.20.0

Will packets be routed correctly in this small network?


Explain why or why not.

RIP Version 2

Subnet masks carried with each route entry


Authentication of routing updates
Next-hop addresses carried with each route entry
External route tags - Tagging external routes or
routes that have been redistributed into the RIPv2
process
Multicast route updates
RIPv2 multicasts updates to other RIPv2-speaking
routers, using the reserved class D address
224.0.0.9.

Case Study 1: Compatibility with


RIPv1
router rip
version 2 - send and receive version 2

router rip
version 1

interface Ethernet0
ip address 192.168.50.129 255.255.255.192
ip rip send version 1
ip rip receive version 1

interface Ethernet1
ip address 172.25.150.193 255.255.255.240
ip rip send version 1 2

interface Ethernet2
ip address 172.25.150.225 255.255.255.240

router rip
version 2

RIP V1

RIP V2

Summary
RIP is a distance vector routing protocol that uses
hop count as the metric for route selection and
broadcasts routing updates every 30 seconds.
To enable a dynamic routing protocol, you will
select the routing protocol and then assign IP
network numbers.
The router rip command specifies RIP as the routing
protocol. The network command identifies a
participating attached network.
The show ip commands display information about
routing protocols and the routing table.
Use the debug ip rip command to display
information on RIP routing transactions.

You might also like